X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Hilfeforum

I would like to stop the annoying reload Drudgereport.com does. How?

Veröffentlicht

Everyone going to the above mentioned website experiences the same annoying reloads. Please add a method to Firefox like IE has that can restrict sites reloading, assuming this doesn't exist already. Thanks

Everyone going to the above mentioned website experiences the same annoying reloads. Please add a method to Firefox like IE has that can restrict sites reloading, assuming this doesn't exist already. Thanks

Ausgewählte Lösung

I tried this script with Greasemonkey and I haven't seen a refresh. I don't know if it also works with Tampermonkey and Violentmonkey.

// ==UserScript==
// @name        Drudge Report - No Reload
// @namespace   Drudge Report
// @description Disable automatic reloads on Drudge Report.
// @include     http://drudgereport.com/*
// @include     https://drudgereport.com/*
// @version     1
// @grant       none
// ==/UserScript==
clearInterval(unsafeWindow.timer);
Diese Antwort im Kontext lesen 1
Zitieren

Mehr Details zum System

Installierte Plugins

Ghostery , Facebook Container , Google Analytics Blocker

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4394 Lösungen 61644 Antworten
Veröffentlicht

I had no problem with Drudgereport.com


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I had no problem with Drudgereport.com Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Thanks Fred,

I have tried both suggestions above but the same (.....for years now!) "problem" or annoying website trait still exists. I don't think it is a matter with my use of Firefox. Like I said above, I am fairly certain everyone reading the news headlines there get an automatic reload after about 4 minutes. Any other suggestions or could the developers there add a "restricted site" way to handle the annoyance like I have seen IE has?

Thanks Fred, I have tried both suggestions above but the same (.....for years now!) "problem" or annoying website trait still exists. I don't think it is a matter with my use of Firefox. Like I said above, I am fairly certain everyone reading the news headlines there get an automatic reload after about 4 minutes. Any other suggestions or could the developers there add a "restricted site" way to handle the annoyance like I have seen IE has?
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17857 Lösungen 161589 Antworten
Veröffentlicht

You can use a bookmarklet to disable the reload on drudgereport.com or possibly convert the script to an extension like Greasemonkey or Tampermonkey.

javascript:clearInterval(timer);void(autoRefresh=null);

See:

You can use a bookmarklet to disable the reload on drudgereport.com or possibly convert the script to an extension like Greasemonkey or Tampermonkey. javascript:clearInterval(timer);void(autoRefresh=null); See: *[/questions/1058404] Option to 'Warn me when websites...try to reload' doesn't work? *https://greasyfork.org/en/forum/discussion/6024/script-request-stop-auto-reload-of-page
Hat Ihnen das weitergeholfen? 0
Zitieren
FredMcD
  • Top 10 Contributor
4394 Lösungen 61644 Antworten
Veröffentlicht
Check out: https://www.google.nl/search?authuser=1&sxsrf=ACYBGNTmT2SCOspwkd7PaX6D_oJit9TUAA%3A1581833219196&source=hp&ei=A9xIXtfLCYyZsAe8_YFA&q=in+firefox%3A+drudgereport.com+keeps+reloading&oq=in+firefox%3A+drudgereport.com+keeps+reloading&gs_l=psy-ab.3...4467.22368..23271...2.0..0.154.3099.44j1......0....1..gws-wiz.......35i39j0j0i67j0i20i263j0i22i30j0i22i10i30j33i160j33i10.b1zZRuOeM-I&ved=0ahUKEwiX2fz4s9XnAhWMDOwKHbx-AAgQ4dUDCAU&uact=5
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Running this greasemonkey script at drudgereport.com now but the page still reloads. What is wrong?

// ==UserScript==

   // @name        Drudge Report - No Reload
   // @namespace   Drudge Report
   // @description Disable automatic reloads on Drudge Report.
   // @include     http://*drudgereport.com*/*
   // @version     1
   // @grant       none
   // ==/UserScript==
   var script = document.createElement("script");
   script.innerHTML = '(function(){clearInterval(timer); autoRefresh = function(){};})();';
   var body = document.getElementsByTagName("body")[0];
   body.appendChild(script);
Running this greasemonkey script at drudgereport.com now but the page still reloads. What is wrong? // ==UserScript== // @name Drudge Report - No Reload // @namespace Drudge Report // @description Disable automatic reloads on Drudge Report. // @include http://*drudgereport.com*/* // @version 1 // @grant none // ==/UserScript== var script = document.createElement("script"); script.innerHTML = '(function(){clearInterval(timer); autoRefresh = function(){};})();'; var body = document.getElementsByTagName("body")[0]; body.appendChild(script);
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong?

Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong?
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
629 Lösungen 6019 Antworten
Veröffentlicht

Hilfreiche Antwort

Eastcreek said

Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong?

Hello Easrcreek,

You left out the colon between "about" and "config" - it's:
about:config

''Eastcreek [[#answer-1290738|said]]'' <blockquote> Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong? </blockquote> Hello Easrcreek, You left out the colon between "about" and "config" - it's: <BR>about''':'''config
Hat Ihnen das weitergeholfen? 1
Zitieren

Fragesteller

accessibility.blockautorefresh was already set to false. :( Guess my problem is elsewhere.

accessibility.blockautorefresh was already set to false. :( Guess my problem is elsewhere.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
629 Lösungen 6019 Antworten
Veröffentlicht

Hilfreiche Antwort

Eastcreek said

accessibility.blockautorefresh was already set to false. :( Guess my problem is elsewhere.

You should set the value of that preference to true ......

(you want to block the autorefresh)

''Eastcreek [[#answer-1290748|said]]'' <blockquote> accessibility.blockautorefresh was already set to false. :( Guess my problem is elsewhere. </blockquote> You should set the value of that preference to '''true''' ...... (you ''want'' to block the autorefresh)
Hat Ihnen das weitergeholfen? 1
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17857 Lösungen 161589 Antworten
Veröffentlicht

The accessibility pref accessibility.blockautorefresh won't work for Drudge report as this only works for a location change via a meta tag and is meant for users with certain disabilities. This pref only works in this case and not in other cases like a reload via JavaScript that Drudge uses. This is one of the reason that this setting was removed from Options/Preferences.

Drudge report still uses the same code for auto refresh as you can see if you inspect the page source.

var timer = setInterval("autoRefresh()", 1000 * 40 * 3);
function autoRefresh(){self.location.reload(true);}

Did you try the bookmarklet ?

  • javascript:clearInterval(timer);void(autoRefresh=null);

You can create a new bookmark and paste the JavaScript code in its Location field where you normally place the URL.

You need to invoke the bookmarklet each time you load or refresh a Drudge report page unlike the Greasemonkey script that would run automatically.

The accessibility pref accessibility.blockautorefresh won't work for Drudge report as this only works for a location change via a meta tag and is meant for users with certain disabilities. This pref only works in this case and not in other cases like a reload via JavaScript that Drudge uses. This is one of the reason that this setting was removed from Options/Preferences. Drudge report still uses the same code for auto refresh as you can see if you inspect the page source. <pre><nowiki>var timer = setInterval("autoRefresh()", 1000 * 40 * 3); function autoRefresh(){self.location.reload(true);}</nowiki></pre> Did you try the bookmarklet ? *javascript:clearInterval(timer);void(autoRefresh=null); You can create a new bookmark and paste the JavaScript code in its <u>Location field</u> where you normally place the URL. You need to invoke the bookmarklet each time you load or refresh a Drudge report page unlike the Greasemonkey script that would run automatically.

Geändert am von cor-el

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17857 Lösungen 161589 Antworten
Veröffentlicht

You may only have to change http:// to https:// is this line or add this line to support both protocols.

// @include     https://*drudgereport.com*/*
You may only have to change http:// to https:// is this line or add this line to support both protocols. // @include https://*drudgereport.com*/*
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Changed about:config to true and added the second line to my copied script (..and saved it) and it still reloads. Frustrating. I'm starting to wonder if Matt Drudge has done something extra and hidden to make sure no reload blocks can occur to ensure profits stay in place? :)

I don't understand this: "Did you try the bookmarklet ?

You can create a new bookmark and paste the JavaScript code in its Location field where you normally place the URL.

You need to invoke the bookmarklet each time you load or refresh a Drudge report page unlike the Greasemonkey script that would run automatically."

Changed about:config to true and added the second line to my copied script (..and saved it) and it still reloads. Frustrating. I'm starting to wonder if Matt Drudge has done something extra and hidden to make sure no reload blocks can occur to ensure profits stay in place? :) I don't understand this: "Did you try the bookmarklet ? You can create a new bookmark and paste the JavaScript code in its Location field where you normally place the URL. You need to invoke the bookmarklet each time you load or refresh a Drudge report page unlike the Greasemonkey script that would run automatically."

Geändert am von Eastcreek

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17857 Lösungen 161589 Antworten
Veröffentlicht

Ausgewählte Lösung

I tried this script with Greasemonkey and I haven't seen a refresh. I don't know if it also works with Tampermonkey and Violentmonkey.

// ==UserScript==
// @name        Drudge Report - No Reload
// @namespace   Drudge Report
// @description Disable automatic reloads on Drudge Report.
// @include     http://drudgereport.com/*
// @include     https://drudgereport.com/*
// @version     1
// @grant       none
// ==/UserScript==
clearInterval(unsafeWindow.timer);
I tried this script with Greasemonkey and I haven't seen a refresh. I don't know if it also works with Tampermonkey and Violentmonkey. <pre><nowiki>// ==UserScript== // @name Drudge Report - No Reload // @namespace Drudge Report // @description Disable automatic reloads on Drudge Report. // @include http://drudgereport.com/* // @include https://drudgereport.com/* // @version 1 // @grant none // ==/UserScript== clearInterval(unsafeWindow.timer);</nowiki></pre>
Hat Ihnen das weitergeholfen? 1
Zitieren

Fragesteller

That one worked! Thank You!

That one worked! Thank You!
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
629 Lösungen 6019 Antworten
Veröffentlicht

@ Eastcreek :

I noticed that you marked one of my posts as "Chosen Solution"; would you be so kind as to remove that mark by clicking on the "Undo" button (to the right of that post) and then mark cor-el's post by clicking on the "Solved the problem" button to the right of his last post ?

Thank you in advance !

@ Eastcreek : I noticed that you marked one of my posts as "Chosen Solution"; would you be so kind as to remove that mark by clicking on the "Undo" button (to the right of that post) and then mark cor-el's post by clicking on the "Solved the problem" button to the right of his last post ? Thank you in advance !
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

McCoy said

Eastcreek said
Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong?

Hello Easrcreek,

You left out the colon between "about" and "config" - it's:
about:config McCoy said

@ Eastcreek I noticed that you marked one of my posts as "Chosen Solution"; would you be so kind as to remove that mark by clicking on the "Undo" button (to the right of that post) and then mark cor-el's post by clicking on the "Solved the problem" button to the right of his last post ? Thank you in advance !

I would but I don't see an "undo" button like your describing. Oh, and your seeing that I missed the colon actually fixed that issue I was having!

''McCoy [[#answer-1290745|said]]'' <blockquote> ''Eastcreek [[#answer-1290738|said]]'' <blockquote> Every time I type "about config" in the search bar Startpage does an internet search. I don't get the warning message. What am I doing wrong? </blockquote> Hello Easrcreek, You left out the colon between "about" and "config" - it's: <BR>about''':'''config </blockquot''McCoy [[#answer-1291137|said]]'' <blockquote> @ Eastcreek I noticed that you marked one of my posts as "Chosen Solution"; would you be so kind as to remove that mark by clicking on the "Undo" button (to the right of that post) and then mark cor-el's post by clicking on the "Solved the problem" button to the right of his last post ? Thank you in advance ! </blockquote> I would but I don't see an "undo" button like your describing. Oh, and your seeing that I missed the colon actually fixed that issue I was having!
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.