X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

I have folders in my Bookmarks Toolbar, and when I hover over the folder the list of bookmarks is not appearing.

Veröffentlicht

Typically when I hover my mouse over the folder, a drop down list of the bookmarks appears. And sometimes it still does! But sometimes it doesn't ... but I can still follow the link by moving my cursor where the link SHOULD BE and clicking on it. It's super weird.

Typically when I hover my mouse over the folder, a drop down list of the bookmarks appears. And sometimes it still does! But sometimes it doesn't ... but I can still follow the link by moving my cursor where the link SHOULD BE and clicking on it. It's super weird.
Zitieren

Mehr Details zum System

Installierte Plugins

OpenH264 by Cisco Widevine by Google

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0

Weitere Informationen

Matthew Thomas
  • Top 25 Contributor
13 Lösungen 90 Antworten
Veröffentlicht

That is super weird. Do you happen to have any custom themes installed? You can find them under add-ons.

Next, do you make use of userChrome.css or the Stylish extension?

Any of these could make the menu invisible. Try switching to the default theme or disabling these extensions if you have them.

Otherwise, does the error still occur in private mode?

That ''is'' super weird. Do you happen to have any custom themes installed? You can find them under add-ons. Next, do you make use of userChrome.css or the Stylish extension? Any of these could make the menu invisible. Try switching to the default theme or disabling these extensions if you have them. Otherwise, does the error still occur in private mode?

Geändert am von Matthew Thomas

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17864 Lösungen 161648 Antworten
Veröffentlicht

Does this only happen if you visit some specific websites ?

I noticed that some changes have been made that seem to affect the z-index of some components and that might be causing the list to be no longer visible.

Does this only happen if you visit some specific websites ? I noticed that some changes have been made that seem to affect the z-index of some components and that might be causing the list to be no longer visible.
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

No custom themes installed - currently using the default. My only extensions are 1Password, Amazon Assistant, Grammarly, and Facebook Container. I'll try disabling Amazon & Grammarly and see if that makes a difference.

No custom themes installed - currently using the default. My only extensions are 1Password, Amazon Assistant, Grammarly, and Facebook Container. I'll try disabling Amazon & Grammarly and see if that makes a difference.
Hat Ihnen das weitergeholfen?
Zitieren
crankygoat
  • Top 10 Contributor
40 Lösungen 471 Antworten
Veröffentlicht

You can just restart Firefox in safe mode and see if the issue persists. This will disable extensions and some setting for the duration of safe mode.

☰Menu → Help → Restart with Add-ons Disabled

You can just restart Firefox in safe mode and see if the issue persists. This will disable extensions and some setting for the duration of safe mode. ☰Menu → Help → Restart with Add-ons Disabled
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

So it appears that YouTube (or the specific channel analytic page) is the culprit. Not sure how to fix it, but at least I've identified the source.

So it appears that YouTube (or the specific channel analytic page) is the culprit. Not sure how to fix it, but at least I've identified the source.
Hat Ihnen das weitergeholfen?
Zitieren
Matthew Thomas
  • Top 25 Contributor
13 Lösungen 90 Antworten
Veröffentlicht

alifreeman93 said

So it appears that YouTube (or the specific channel analytic page) is the culprit. Not sure how to fix it, but at least I've identified the source.

Are you referring to https://www.youtube.com/analytics

I can't reproduce the issue. Though, the top bar has a z-index set, so I'm guessing cor-el was right about the issue.

''alifreeman93 [[#answer-1288477|said]]'' <blockquote> So it appears that YouTube (or the specific channel analytic page) is the culprit. Not sure how to fix it, but at least I've identified the source. </blockquote> Are you referring to https://www.youtube.com/analytics I can't reproduce the issue. Though, the top bar has a z-index set, so I'm guessing cor-el was right about the issue.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17864 Lösungen 161648 Antworten
Veröffentlicht

What drop-down list is this about ? If you open the list from a toolbar button on the Bookmarks Toolbar then is is probably possible to increase the z-index of the drop-down list via code in userChrome.css.

See also this tread for a similar z-index related issue.

  • /questions/1276942 Bookmark sidebar is only showing up in the console window. How to restore original view?

Try to add this code to the userChrome.css file below the default @namespace line to see if that has effect.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks menupop {
 z-index: 2147483647 !important;
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

What drop-down list is this about ? If you open the list from a toolbar button on the Bookmarks Toolbar then is is probably possible to increase the z-index of the drop-down list via code in userChrome.css. See also this tread for a similar z-index related issue. *[/questions/1276942] Bookmark sidebar is only showing up in the console window. How to restore original view? Try to add this code to the <b>userChrome.css</b> file below the default @namespace line to see if that has effect. <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks menupop { z-index: 2147483647 !important; } </nowiki></pre> It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a plain text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file. See also: *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true See: *https://www.userchrome.org/firefox-changes-userchrome-css.html
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Thanks for the detailed instructions, cor-el. Unfortunately that did not solve the problem. Oh well. The problem is annoying but not impossible to deal with so I guess I'll just work around it.

Thanks for the detailed instructions, cor-el. Unfortunately that did not solve the problem. Oh well. The problem is annoying but not impossible to deal with so I guess I'll just work around it.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.