X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Main window blank, all accounts gone after upgrade to 68.3.1 on OSX Catalina

Veröffentlicht

I upgraded to 68.3.1 because the global search window (the one that searches across all boxes) never worked since I switched laptops to OSX Catalina. Instead of fixing the problem, I now see a completely blank window. If I click on "About Thunderbird" it is perpetually stuck on "Applying Update".

This is after several reboots. It sounds similar to this thread: https://support.mozilla.org/en-US/questions/1268403

However that is a Windows install.

When I start to compose a new message, none of my identities / accounts are available in the "From" pulldown.

Going into Tools -> Account Settings does nothing.

If I go into File -> Get New Messages For, I do see my list of accounts.

I upgraded to 68.3.1 because the global search window (the one that searches across all boxes) never worked since I switched laptops to OSX Catalina. Instead of fixing the problem, I now see a completely blank window. If I click on "About Thunderbird" it is perpetually stuck on "Applying Update". This is after several reboots. It sounds similar to this thread: https://support.mozilla.org/en-US/questions/1268403 However that is a Windows install. When I start to compose a new message, none of my identities / accounts are available in the "From" pulldown. Going into Tools -> Account Settings does nothing. If I go into File -> Get New Messages For, I do see my list of accounts.
Angefügte Screenshots

Geändert am von MarkJr

Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36

Weitere Informationen

Wayne Mery
  • Top 25 Contributor
  • Moderator
600 Lösungen 5738 Antworten
Veröffentlicht

1. visit help > troubleshooting > about:profiles - how many profiles are listed and what are their names?

2. is thunderbird properly installed? in other words, is it running from the .dmg download file, or is it running from the applications folder?

1. visit help > troubleshooting > about:profiles - how many profiles are listed and what are their names? 2. is thunderbird properly installed? in other words, is it running from the .dmg download file, or is it running from the applications folder?
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Wayne Mery said

1. visit help > troubleshooting > about:profiles - how many profiles are listed and what are their names?

Going to Help -> Troubleshooting Information doesn't do anything, the windows just remain blank.

2. is thunderbird properly installed? in other words, is it running from the .dmg download file, or is it running from the applications folder?

It is definitely running from the applications folder. I deleted and reinstalled it just in case.

Also, when I move the ~Library/Thunderbird directory to make it look like a fresh install, it seems to be working. I'd have to re-add all my email accounts and start with new profiles I guess.

So it must be something in my profiles data that is causing this.

''Wayne Mery [[#answer-1278051|said]]'' <blockquote> 1. visit help > troubleshooting > about:profiles - how many profiles are listed and what are their names? </blockquote> Going to '''Help''' -> '''Troubleshooting Information''' doesn't do anything, the windows just remain blank. <blockquote> 2. is thunderbird properly installed? in other words, is it running from the .dmg download file, or is it running from the applications folder? </blockquote> It is definitely running from the applications folder. I deleted and reinstalled it just in case. Also, when I move the '''~Library/Thunderbird''' directory to make it look like a fresh install, it seems to be working. I'd have to re-add all my email accounts and start with new profiles I guess. So it must be something in my profiles data that is causing this.

Geändert am von MarkJr

Hat Ihnen das weitergeholfen?
Zitieren
Wayne Mery
  • Top 25 Contributor
  • Moderator
600 Lösungen 5738 Antworten
Veröffentlicht

If your system isn't using the correct profile (where the data is stored) you can get to the profile manager another way. I'm not a Mac person so this might take a couple iterations. 1. open terminal window 2. do /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -profilemanager --allow-downgrade

Thunderbird will open with profile manager. Typically, the profile at the top of the list will be the default profile that had your data.

If your system isn't using the correct profile (where the data is stored) you can get to the profile manager another way. I'm not a Mac person so this might take a couple iterations. 1. open terminal window 2. do /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -profilemanager --allow-downgrade Thunderbird will open with profile manager. Typically, the profile at the top of the list will be the default profile that had your data.
Hat Ihnen das weitergeholfen?
Zitieren
Wayne Mery
  • Top 25 Contributor
  • Moderator
600 Lösungen 5738 Antworten
Veröffentlicht

Problem solved?

Problem solved?
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Hi, sorry about that interval. Been using Postbox since this posting but it has its own issues that drive me a little crazy.

So I tried this, your command line got it right, it brought up two profiles:

default and default-release

neither works

I think at this point I will run this command, use it to create a new profile, re-add all my accounts, then re add all my filter rules.

In other words, rebuild my config from scratch

I saw a new version today but that upgrade didn't work either.

Thanks again.

Hi, sorry about that interval. Been using Postbox since this posting but it has its own issues that drive me a little crazy. So I tried this, your command line got it right, it brought up two profiles: default and default-release neither works I think at this point I will run this command, use it to create a new profile, re-add all my accounts, then re add all my filter rules. In other words, rebuild my config from scratch I saw a new version today but that upgrade didn't work either. Thanks again.
Hat Ihnen das weitergeholfen?
Zitieren
tyomak 0 Lösungen 11 Antworten
Veröffentlicht

Restore your profile from backup and downgrade back to 60.9.1 until tbird gets their sh*t together. Can't believe they released something so broken.

Disable upgrade feature as well until it's fixed.

Restore your profile from backup and downgrade back to 60.9.1 until tbird gets their sh*t together. Can't believe they released something so broken. Disable upgrade feature as well until it's fixed.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

SOLVED via another thread,

sfhowes said

Apart from Enigmail issues, the problem of the disappearing profile after the update is often fixed by deleting the global sqlite file: https://support.mozilla.org/en-US/questions/1277737

see: https://support.mozilla.org/en-US/questions/1277603

SOLVED via another thread, ''sfhowes [[#answer-1282616|said]]'' <blockquote> Apart from Enigmail issues, the problem of the disappearing profile after the update is often fixed by deleting the global sqlite file: https://support.mozilla.org/en-US/questions/1277737 </blockquote> see: https://support.mozilla.org/en-US/questions/1277603
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.