X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Web pages load slowly.

Veröffentlicht

Web pages are loading painfully slowly, 11-34 seconds, some never load before timing out. Other browser (Edge) is loading pages quickly. Internet connection reasonably fast (35.7 Mbps). I tried the following:

  - Safe Mode, no change.
  - Refreshed Firefox, no change.
  - Disabled Antivirus and Firewall, no change.
  - Disabled Network Proxy, no change.
  - Content Process Limit set at 8.
  - Firefox is using 550 MB of memory (out of 10.2 GB)

There are instances when Firefox does load pages quickly, but they are increasingly infrequent and not predictable.

Web pages are loading painfully slowly, 11-34 seconds, some never load before timing out. Other browser (Edge) is loading pages quickly. Internet connection reasonably fast (35.7 Mbps). I tried the following: - Safe Mode, no change. - Refreshed Firefox, no change. - Disabled Antivirus and Firewall, no change. - Disabled Network Proxy, no change. - Content Process Limit set at 8. - Firefox is using 550 MB of memory (out of 10.2 GB) There are instances when Firefox does load pages quickly, but they are increasingly infrequent and not predictable.

Ausgewählte Lösung

Did you try to boot the computer in the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect?

Is is possible that your security software hasn't finished its initialization and blocks Firefox. When you disable security software then you usually only disable its user interface and the services keep running in the background.

Diese Antwort im Kontext lesen 0
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4307 Lösungen 60486 Antworten
Veröffentlicht

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
Hat Ihnen das weitergeholfen?
Zitieren
FredMcD
  • Top 10 Contributor
4307 Lösungen 60486 Antworten
Veröffentlicht
https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding https://support.mozilla.org/en-US/kb/firefox-takes-long-time-start-up
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

The problem was not there in safe mode. All eight web sites I opened loaded expeditiously.

The problem was not there in safe mode. All eight web sites I opened loaded expeditiously.
Hat Ihnen das weitergeholfen?
Zitieren
FredMcD
  • Top 10 Contributor
4307 Lösungen 60486 Antworten
Veröffentlicht

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Hat Ihnen das weitergeholfen?
Zitieren

Hilfreiche Antwort

Disabled all extensions, restarted Firefox. No difference, still slow.

Just in case, I disabled all the Plugins. That didn't work either.

Disabled Hardware Acceleration. No change.

Then I had an epiphany. Every morning when I boot, Firefox opens from the Startup folder in my Start Menu. Could this be the culprit? I took Firefox out of the Startup folder and restarted the computer. When I started Firefox from a shortcut, Bingo!, every web page loaded double quick. I don't understand, but at this stage I'll take it. Thank you for trying to solve the unsolvable.

Disabled all extensions, restarted Firefox. No difference, still slow. Just in case, I disabled all the Plugins. That didn't work either. Disabled Hardware Acceleration. No change. Then I had an epiphany. Every morning when I boot, Firefox opens from the Startup folder in my Start Menu. Could this be the culprit? I took Firefox out of the Startup folder and restarted the computer. When I started Firefox from a shortcut, Bingo!, every web page loaded double quick. I don't understand, but at this stage I'll take it. Thank you for trying to solve the unsolvable.
Hat Ihnen das weitergeholfen? 1
Zitieren
FredMcD
  • Top 10 Contributor
4307 Lösungen 60486 Antworten
Veröffentlicht

Hilfreiche Antwort

That was very good work. Well Done.

This could be a possible bug. I am calling for more help.

That was very good work. Well Done. This could be a possible bug. I am calling for more help.
Hat Ihnen das weitergeholfen? 1
Zitieren

Fragesteller

I forgot to say that I have been loading Firefox from that Startup folder for years without problem. The slow loading web pages started last week. Why, is a mystery. I haven't installed anything, or changed my Firefox or computer settings for months. Good luck.

I forgot to say that I have been loading Firefox from that Startup folder for years without problem. The slow loading web pages started last week. Why, is a mystery. I haven't installed anything, or changed my Firefox or computer settings for months. Good luck.
Hat Ihnen das weitergeholfen? 1
Zitieren
Noah_SUMO
  • Moderator
99 Lösungen 639 Antworten
Veröffentlicht

I'm really curious if you made a custom shortcut for Firefox in that startup folder & if that shortcut had any additional commands in it when it starts Firefox. You can inspect that shortcut you moved out of the Startup folder by right-click > Properties > Shortcut tab. Then copy & paste everything in the "Target" line here. Maybe a command at the end of the target line caused Firefox to load the pages slowly.

Screenshot:

I'm really curious if you made a custom shortcut for Firefox in that startup folder & if that shortcut had any additional commands in it when it starts Firefox. You can inspect that shortcut you moved out of the Startup folder by right-click > Properties > Shortcut tab. Then copy & paste everything in the "Target" line here. Maybe a command at the end of the target line caused Firefox to load the pages slowly. Screenshot: <img src=https://www.howtogeek.com/wp-content/uploads/2017/02/12_changing_target.png>
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I made an ordinary shortcut to Firefox to put in the Startup folder. Here is the Target line: "C:\Program Files\Mozilla Firefox\firefox.exe"

There is another situation that may have relevance here. I use Autoruns to corral which programs open when I log on. This screenshot shows that when I put the single shortcut to Firefox in the Startup folder it appears three times in Autoruns. I'm not qualified to do anything but guess, but could these three links be fighting with each other to open and the result is slow page loading?

I made an ordinary shortcut to Firefox to put in the Startup folder. Here is the Target line: "C:\Program Files\Mozilla Firefox\firefox.exe" There is another situation that may have relevance here. I use Autoruns to corral which programs open when I log on. This screenshot shows that when I put the single shortcut to Firefox in the Startup folder it appears three times in Autoruns. I'm not qualified to do anything but guess, but could these three links be fighting with each other to open and the result is slow page loading?
Hat Ihnen das weitergeholfen?
Zitieren
Noah_SUMO
  • Moderator
99 Lösungen 639 Antworten
Veröffentlicht

That's a really good guess actually. That could be the cause. Especially if it's calling them constantly for the entire browsing session. Unless someone can come up with a better explanation. :P

Thanks for the quick reply back! And have a Happy New Year! :)

That's a really good guess actually. That could be the cause. Especially if it's calling them constantly for the entire browsing session. Unless someone can come up with a better explanation. :P Thanks for the quick reply back! And have a Happy New Year! :)
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17685 Lösungen 159997 Antworten
Veröffentlicht

Ausgewählte Lösung

Did you try to boot the computer in the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect?

Is is possible that your security software hasn't finished its initialization and blocks Firefox. When you disable security software then you usually only disable its user interface and the services keep running in the background.

Did you try to boot the computer in the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect? *https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *https://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 Is is possible that your security software hasn't finished its initialization and blocks Firefox. When you disable security software then you usually only disable its user interface and the services keep running in the background.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Noah_SUMO,

I appreciate the compliment. I'm truly an amateur, in way over my head. Happy New Year back to you!

Noah_SUMO, I appreciate the compliment. I'm truly an amateur, in way over my head. Happy New Year back to you!
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el,

Yes, I did open Firefox in Safe Mode with network support. Firefox worked perfectly there.

Taking Firefox out of the Startup folder and starting it manually did the trick also. I should learn to be patient. Right. :)

cor-el, Yes, I did open Firefox in Safe Mode with network support. Firefox worked perfectly there. Taking Firefox out of the Startup folder and starting it manually did the trick also. I should learn to be patient. Right. :)
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.