X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Hilfeforum

Update Firefox on Ubuntu 16.04

Veröffentlicht

Running FF 67.0.3 on Ubuntu 16.04 LTS. When I go to certain web pages (Amazon, My Music) I get an intrusive pop-up saying my version of FF is no longer supported and I should upgrade. The pop-up cannot be dismissed, and the only option is 'update now'. (And FWIW, the Amazon page behind it is "out of focus" ) The 'update now' takes me to a page telling me to open the 'help - about' and it will automatically start downloading. Only it doesn't start downloading . And other pages say FF is supposed to update automatically, without any intervention on my part. So I'm stuck.

Running FF 67.0.3 on Ubuntu 16.04 LTS. When I go to certain web pages (Amazon, My Music) I get an intrusive pop-up saying my version of FF is no longer supported and I should upgrade. The pop-up cannot be dismissed, and the only option is 'update now'. (And FWIW, the Amazon page behind it is "out of focus" ) The 'update now' takes me to a page telling me to open the 'help - about' and it will automatically start downloading. Only it doesn't start downloading . And other pages say FF is supposed to update automatically, without any intervention on my part. So I'm stuck.
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8957 Lösungen 73389 Antworten
Veröffentlicht

Hilfreiche Antwort

Hi edstevens, is there a way to update via your package manager? The current release are either:

  • Regular release: Firefox 71.0
  • Extended Support Release: Firefox 68.3.0esr

If not, you could switch to a Mozilla release. However, I don't know whether there are special considerations in making the switch. I guess a backup wouldn't hurt: Back up and restore information in Firefox profiles.

Hi edstevens, is there a way to update via your package manager? The current release are either: * Regular release: Firefox 71.0 * Extended Support Release: Firefox 68.3.0esr If not, you could switch to a Mozilla release. However, I don't know whether there are special considerations in making the switch. I guess a backup wouldn't hurt: [[Back up and restore information in Firefox profiles]].
Hat Ihnen das weitergeholfen? 1
Zitieren
James
  • Moderator
1603 Lösungen 11348 Antworten
Veröffentlicht

edstevens said

The 'update now' takes me to a page telling me to open the 'help - about' and it will automatically start downloading. Only it doesn't start downloading . And other pages say FF is supposed to update automatically, without any intervention on my part. So I'm stuck.

The internal Firefox updates are with the official builds of Firefox from mozilla.org or www.mozilla.org/firefox/all/

Third-party builds like those provided by Linux distros do not get Firefox updates from Mozilla since Mozilla did not well build those builds.

You can check your package manager for Firefox updates or perhaps try apt as below will update the already installed Firefox using the default Ubuntu repository. If the Firefox is not installed yet it will be installed:

$ sudo apt install firefox

''edstevens [[#question-1274868|said]]'' <blockquote>The 'update now' takes me to a page telling me to open the 'help - about' and it will automatically start downloading. Only it doesn't start downloading . And other pages say FF is supposed to update automatically, without any intervention on my part. So I'm stuck. </blockquote> The internal Firefox updates are with the official builds of Firefox from mozilla.org or www.mozilla.org/firefox/all/ Third-party builds like those provided by Linux distros do not get Firefox updates from Mozilla since Mozilla did not well build those builds. You can check your package manager for Firefox updates or perhaps try apt as below will update the already installed Firefox using the default Ubuntu repository. If the Firefox is not installed yet it will be installed: $ sudo apt install firefox
Hat Ihnen das weitergeholfen?
Zitieren
James
  • Moderator
1603 Lösungen 11348 Antworten
Veröffentlicht

Hilfreiche Antwort

jscher2000 said

If not, you could switch to a Mozilla release. However, I don't know whether there are special considerations in making the switch.

One thing you need to make sure is the Firefox folder has read/write permissions for the user so Firefox can get updates from Mozilla which is why many may put Firefox in /home/username/folder to keep things simple if an only user.

''jscher2000 [[#answer-1272789|said]]'' <blockquote> If not, you could switch to a Mozilla release. However, I don't know whether there are special considerations in making the switch. </blockquote> One thing you need to make sure is the Firefox folder has read/write permissions for the user so Firefox can get updates from Mozilla which is why many may put Firefox in /home/username/folder to keep things simple if an only user.

Geändert am von James

Hat Ihnen das weitergeholfen? 1
Zitieren

Fragesteller

apt failed ...

ed@ed-Gazelle-00:~$ sudo apt install firefox [sudo] password for ed: Reading package lists... Error! E: Unable to parse package file /var/lib/apt/lists/ppa.launchpad.net_libreoffice_ppa_ubuntu_dists_xenial_Release (1) E: The package lists or status file could not be parsed or opened. ed@ed-Gazelle-00:~$

Which matches with an alert that's been lurking on my status bar for some time. When I tried to that down on the Ubuntu forum, only advice was 'if everything else is working, ignore it'. Well, now "everything else" is not working, but I'm not really enough of an Ubuntu guy to know how to deal with it. Now, if it were Red Hat .... :-)

apt failed ... ed@ed-Gazelle-00:~$ sudo apt install firefox [sudo] password for ed: Reading package lists... Error! E: Unable to parse package file /var/lib/apt/lists/ppa.launchpad.net_libreoffice_ppa_ubuntu_dists_xenial_Release (1) E: The package lists or status file could not be parsed or opened. ed@ed-Gazelle-00:~$ Which matches with an alert that's been lurking on my status bar for some time. When I tried to that down on the Ubuntu forum, only advice was 'if everything else is working, ignore it'. Well, now "everything else" is not working, but I'm not really enough of an Ubuntu guy to know how to deal with it. Now, if it were Red Hat .... :-)
Hat Ihnen das weitergeholfen? 1
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.