X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox doesn't know how to open this address, because one of the following protocols (ms-word) isn't associated with any program or is not allowed in this cont

Veröffentlicht

Unable to open Word and Excel documents from within SharePoint. This has never been an issue but now the error message is shown. "Firefox doesn't know how to open this address, because one of the following protocols (ms-word) isn't associated with any program or is not allowed in this context." The documents should either open in the browser or trigger the desktop app. Installing older versions hasn't fixed this.

Looking for solutions, thanks

Unable to open Word and Excel documents from within SharePoint. This has never been an issue but now the error message is shown. "Firefox doesn't know how to open this address, because one of the following protocols (ms-word) isn't associated with any program or is not allowed in this context." The documents should either open in the browser or trigger the desktop app. Installing older versions hasn't fixed this. Looking for solutions, thanks
Zitieren
jscher2000
  • Top 10 Contributor
8888 Lösungen 72718 Antworten
Veröffentlicht

Hi mrs.von, does the workaround in the following thread help:

https://support.mozilla.org/questions/1265375#answer-1239993

Hi mrs.von, does the workaround in the following thread help: https://support.mozilla.org/questions/1265375#answer-1239993
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

We tried that before I posted here and that unfortunately doesn't work either. Several users tested this. This wasn't a problem until recently.

We tried that before I posted here and that unfortunately doesn't work either. Several users tested this. This wasn't a problem until recently.
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

To clarify, when selecting the link, Firefox adds the following to the front of the actual link in the URL

ms-word:ofv|u|https:// or ms-excel:ofv|ofc|u|https://

And the page with the error messages appears.

When removing ms-word:ofv|u|or ms-excel:ofv|ofc|u| the links work and do as expected. This happens on a Mac and PC.

To clarify, when selecting the link, Firefox adds the following to the front of the actual link in the URL ms-word:ofv|u|https:// or ms-excel:ofv|ofc|u|https:// And the page with the error messages appears. When removing ms-word:ofv|u|or ms-excel:ofv|ofc|u| the links work and do as expected. This happens on a Mac and PC.
Hat Ihnen das weitergeholfen? 1
Zitieren
Romy Fitschen 0 Lösungen 4 Antworten
Veröffentlicht

I have had this problem for a couple of months. The message I get is the same. I have uninstalled, reinstalled and tried countless suggestions. Sadly I have to stop messing with this and switch to another browser which is upsetting to me as I don't like to use microsoft or google. This is really frustrating.

I have had this problem for a couple of months. The message I get is the same. I have uninstalled, reinstalled and tried countless suggestions. Sadly I have to stop messing with this and switch to another browser which is upsetting to me as I don't like to use microsoft or google. This is really frustrating.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

As it turns out you can no longer sync folder with Microsoft OneDrive either. The URL adds the following: odopen://sync

This makes Firefox unusable for Office 365. A real real shame.

As it turns out you can no longer sync folder with Microsoft OneDrive either. The URL adds the following: odopen://sync This makes Firefox unusable for Office 365. A real real shame.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I have checked with Microsoft and they said there is nothing they can do about this. If this is not fixed then Firefox will render useless for hundreds of thousands of work devices.

I have checked with Microsoft and they said there is nothing they can do about this. If this is not fixed then Firefox will render useless for hundreds of thousands of work devices.
Hat Ihnen das weitergeholfen?
Zitieren
Valerie 0 Lösungen 1 Antworten
Veröffentlicht

I am having the same issue. Removing ms-word:ofv|u| as indicated above by mrs.von downloads a copy of the file and does not permit co-authoring in the documents.

There are workarounds (e.g., opening the document in the browser view, then opening Word to access the file through the recent documents), but these are time consuming and impractical. Looks like there's an issue with how Firefox handles these links.

As indicated above, if this is not resolved, I will have to switch to a different browser for business use.

I am having the same issue. Removing ms-word:ofv|u| as indicated above by mrs.von downloads a copy of the file and does not permit co-authoring in the documents. There are workarounds (e.g., opening the document in the browser view, then opening Word to access the file through the recent documents), but these are time consuming and impractical. Looks like there's an issue with how Firefox handles these links. As indicated above, if this is not resolved, I will have to switch to a different browser for business use.
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8888 Lösungen 72718 Antworten
Veröffentlicht

Hi Valerie, did you already set up the new preference as described in this post:

https://support.mozilla.org/questions/1265375#answer-1239993

Hi Valerie, did you already set up the new preference as described in this post: https://support.mozilla.org/questions/1265375#answer-1239993
Hat Ihnen das weitergeholfen? 0
Zitieren
Romy Fitschen 0 Lösungen 4 Antworten
Veröffentlicht

Having the same issue - going to have to switch browsers. This is really frustrating....

Having the same issue - going to have to switch browsers. This is really frustrating....
Hat Ihnen das weitergeholfen?
Zitieren
rsyd 0 Lösungen 1 Antworten
Veröffentlicht

Is there any update from Firefox on whether or not this problem will be resolved in the near future? I have the same problem. The solution above, doing the about:config thing, pasting in "network.protocol-handler.external.ms-word" and making sure it says "true" worked at first - i.e. when I started to have this problem last summer or so. It worked a few times, but it is no longer a solution. When I go to about:config for both Word and Excel it is already "true". Sad to leave my favourite browser.

Is there any update from Firefox on whether or not this problem will be resolved in the near future? I have the same problem. The solution above, doing the about:config thing, pasting in "network.protocol-handler.external.ms-word" and making sure it says "true" worked at first - i.e. when I started to have this problem last summer or so. It worked a few times, but it is no longer a solution. When I go to about:config for both Word and Excel it is already "true". Sad to leave my favourite browser.

Geändert am von rsyd

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17774 Lösungen 160764 Antworten
Veröffentlicht

On Windows the protocol needs to be added to the Windows Registry (HKEY_CLASSES_ROOT) by the application that support it to make it possible for other applications to find and use it.

On Windows the protocol needs to be added to the Windows Registry (HKEY_CLASSES_ROOT) by the application that support it to make it possible for other applications to find and use it.
Hat Ihnen das weitergeholfen?
Zitieren
RobertJ
  • Top 10 Contributor
141 Lösungen 1453 Antworten
Veröffentlicht

cor-el said

On Windows the protocol needs to be added to the Windows Registry (HKEY_CLASSES_ROOT) by the application that support it to make it possible for other applications to find and use it.

Check, Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see

  • Choose Default Apps By File Type
  • Choose Default Apps By Protocol
  • Set Defaults By App

Select *Choose Default Apps By Protocol (it may take a minute for the list to load) find the Protocol and click on the line to the right of it to select an app.

''cor-el [[#answer-1287290|said]]'' <blockquote> On Windows the protocol needs to be added to the Windows Registry (HKEY_CLASSES_ROOT) by the application that support it to make it possible for other applications to find and use it. </blockquote> Check, Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see *Choose Default Apps By File Type *Choose Default Apps By Protocol *Set Defaults By App Select *Choose Default Apps By Protocol (it may take a minute for the list to load) find the Protocol and click on the line to the right of it to select an app.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.