X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox is constantly signing me out of tabs and windows that I am still using/navigating – how do I fix this?

Veröffentlicht

I am being frequently signed out of open pages on firefox as I am using them. This isn't a regular security settings/cookies problem, this will happen at random without closing the tab or page. The page will refresh or I will click a link to another part of the website and I will be suddenly signed out.

This started happening very recently and I can't point to any clear changes that would have caused it. Has anyone had this problem?

I am being frequently signed out of open pages on firefox as I am using them. This isn't a regular security settings/cookies problem, this will happen at random without closing the tab or page. The page will refresh or I will click a link to another part of the website and I will be suddenly signed out. This started happening very recently and I can't point to any clear changes that would have caused it. Has anyone had this problem?
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:70.0) Gecko/20100101 Firefox/70.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8785 Lösungen 71851 Antworten
Veröffentlicht

Hi Alex, I agree, as long as your cookies are intact, that's not normal.

Some sites will force you to re-login if your IP address changes. That's not very common, but let's check your Connection setting:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default is "Use system proxy settings". "Auto-detect" can lead to a flaky connection. You may want to try "No proxy" and see whether that is more reliable.

Any difference?


If not, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi Alex, I agree, as long as your cookies are intact, that's not normal. Some sites will force you to re-login if your IP address changes. That's not very common, but let's check your Connection setting: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default is "Use system proxy settings". "Auto-detect" can lead to a flaky connection. You may want to try "No proxy" and see whether that is more reliable. Any difference? ---- If not, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Hey, thanks for your quick response!

I was on the default setting of "Use system proxy settings", and tried "no proxy". This didn't change anything.

Restarting in safe mode does seem to solve the problem, so I guess one of my add-ons is causing the issue.

Hey, thanks for your quick response! I was on the default setting of "Use system proxy settings", and tried "no proxy". This didn't change anything. Restarting in safe mode does seem to solve the problem, so I guess one of my add-ons is causing the issue.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17567 Lösungen 158896 Antworten
Veröffentlicht

Are you using content blocking or cookie related extensions ?

A detail like a website remembering you is stored in a cookie.

You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear the cookies.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"

You can create an allow exception to keep specific cookies.

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Are you using content blocking or cookie related extensions ? A detail like a website remembering you is stored in a cookie. You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear the cookies. *Options/Preferences -> Privacy & Security<br>Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed" You can create an allow exception to keep specific cookies. "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory/Folder:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.