X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Why are my IcedTea and Flash plugins INVALID in pluginreg.dat?

Veröffentlicht

Oracle Linux 7, FF 68.2 ESR, recent update to Flash 32.0.0.293, I check in Addons that newest Flash is there (had issues a few weeks ago where I had to remove pluginreg.dat as 32.0.0.270 wouldn't get noticed and FF thought it was 32.0.0.255 still, complaining I had an out-of-date version), and surprise - both Flash and IcedTea aren't there.

So I confidently close FF, remove pluginreg.dat, fire FF up again - but no dice.

Check contents of pluginreg.dat, and here they are:

Generated File. Do not edit.

[HEADER]
Version:0.19t:$
Arch:x86_64-gcc3:$

[PLUGINS]

[INVALID]
/usr/lib64/IcedTeaPlugin.so:$
1564598268000:$
/usr/lib64/flash-plugin/libflashplayer.so:$
1572453153000:$

Funny, so I try downgrading Flash via YUM, which can't be done as Adobe promptly removes old versions from its repos. OK, so I just YUM erase Flash, only to achieve an INVALID IcedTea plugin. What?

Did I perhaps use FF 68.2 for 2 weeks without noticing the issue? Well if that's the case a downgrade to 68.1 will fix things, right? So I re-add via YUM the latest Flash plugin, but alas 68.1 still thinks that and IcedTea are INVALID.

Mumble. Well let me get the big hammer and further downgrade to FF 60.9, remove pluginreg.dat, fire FF up again and... oh. Still INVALID. Now I'm 100% sure there's something weird - but what is it?

Long story short, even creating an entirely new UNIX user and firing up FF which obviously created a new profile from scratch, it gets the same pluginreg.dat right off the bat with Flash and IcedTea plugins marked as INVALID.

So, what are the further debugging steps here as I guess I'm out of options?

Oracle Linux 7, FF 68.2 ESR, recent update to Flash 32.0.0.293, I check in Addons that newest Flash is there (had issues a few weeks ago where I had to remove pluginreg.dat as 32.0.0.270 wouldn't get noticed and FF thought it was 32.0.0.255 still, complaining I had an out-of-date version), and surprise - both Flash and IcedTea aren't there. So I confidently close FF, remove pluginreg.dat, fire FF up again - but no dice. Check contents of pluginreg.dat, and here they are: <pre><nowiki> Generated File. Do not edit. [HEADER] Version:0.19t:$ Arch:x86_64-gcc3:$ [PLUGINS] [INVALID] /usr/lib64/IcedTeaPlugin.so:$ 1564598268000:$ /usr/lib64/flash-plugin/libflashplayer.so:$ 1572453153000:$</nowiki></pre> Funny, so I try downgrading Flash via YUM, which can't be done as Adobe promptly removes old versions from its repos. OK, so I just YUM erase Flash, only to achieve an INVALID IcedTea plugin. What? Did I perhaps use FF 68.2 for 2 weeks without noticing the issue? Well if that's the case a downgrade to 68.1 will fix things, right? So I re-add via YUM the latest Flash plugin, but alas 68.1 still thinks that and IcedTea are INVALID. Mumble. Well let me get the big hammer and further downgrade to FF 60.9, remove pluginreg.dat, fire FF up again and... oh. Still INVALID. Now I'm 100% sure there's something weird - but what is it? Long story short, even creating an entirely new UNIX user and firing up FF which obviously created a new profile from scratch, it gets the same pluginreg.dat right off the bat with Flash and IcedTea plugins marked as INVALID. So, what are the further debugging steps here as I guess I'm out of options?

Geändert am von cor-el

Zitieren

Mehr Details zum System

Installierte Plugins

The issue happens even from completely new profiles generated by freshly created UNIX users.

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17578 Lösungen 158993 Antworten
Veröffentlicht

The Java plugin is no longer supported. Firefox 52 and later releases only support the Shockwave Flash plugin and disable all other plugins.

That Flash plugin might have been a very old Shockwave Flash plugin that isn't supported for some reason. Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no longer work.

You can download the latest NPAPI Flash plugin for Firefox on this page.

The Java plugin is no longer supported. Firefox 52 and later releases only support the Shockwave Flash plugin and disable all other plugins. That Flash plugin might have been a very old Shockwave Flash plugin that isn't supported for some reason. Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no longer work. *https://support.mozilla.org/en-US/kb/npapi-plugins You can download the latest NPAPI Flash plugin for Firefox on this page. *https://get.adobe.com/flashplayer/otherversions/
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Thanks for trying cor-el, but I guess it would help if you took note of the versions I mentioned - where there is no "very old" anything, and I'm running the latest Flash plugin, which I've been using without issues at least until October 18 (possibly later, but that's the latest date I have proof of, having viewed Flash content and commented on that per work email exchange).

I'll even share specific dates for plugin updates (just in case someone will actually take time to read):

[root@myhost ~]# grep 'Updated: flash' /var/log/yum.log Sep 11 11:53:13 Updated: flash-plugin-32.0.0.255-release.x86_64 Oct 10 12:37:47 Updated: flash-plugin-32.0.0.270-release.x86_64 Nov 13 11:02:28 Updated: flash-plugin-32.0.0.293-release.x86_64

For completeness, I have just updated FF to 68.2 ESR on my Windows 10 VM, installed the 32.0.0.293 NPAPI plugin from Adobe, per attached screenshot, and it just works (well, it doesn't when loading a HTML file with Flash content from local storage as it just loops there despite having set plugins.http_https_only = false - but I don't want to mix up different issues here; the plugin shows up in Addons whereas it doesn't anymore under Linux, with this latter behavior appearing to be intentional per pluginreg.dat evidence).

I won't make further comments about IcedTea as of yet, because I can't test joining a WebEx conf at the moment via IcedTea Web plugin, but that's something I have done for sure in October.


So, let's not make this as I've been teleported from early 2017 and complaining about something that has been known for a long while - this stuff stopped working in the last weeks (maybe an issue on my side, that's entirely possible) and up-to-date Flash in up-to-date FF ESR is supposed to work still.


Any more input obviously welcome. Thanks.

Thanks for trying cor-el, but I guess it would help if you took note of the versions I mentioned - where there is no "very old" anything, and I'm running the latest Flash plugin, which I've been using without issues at least until October 18 (possibly later, but that's the latest date I have proof of, having viewed Flash content and commented on that per work email exchange). I'll even share specific dates for plugin updates (just in case someone will actually take time to read): [root@myhost ~]# grep 'Updated: flash' /var/log/yum.log Sep 11 11:53:13 Updated: flash-plugin-32.0.0.255-release.x86_64 Oct 10 12:37:47 Updated: flash-plugin-32.0.0.270-release.x86_64 Nov 13 11:02:28 Updated: flash-plugin-32.0.0.293-release.x86_64 For completeness, I have just updated FF to 68.2 ESR on my Windows 10 VM, installed the 32.0.0.293 NPAPI plugin from Adobe, per attached screenshot, and it just works (well, it doesn't when loading a HTML file with Flash content from local storage as it just loops there despite having set plugins.http_https_only = false - but I don't want to mix up different issues here; the plugin shows up in Addons whereas it doesn't anymore under Linux, with this latter behavior appearing to be intentional per pluginreg.dat evidence). I won't make further comments about IcedTea as of yet, because I can't test joining a WebEx conf at the moment via IcedTea Web plugin, but that's something I have done for sure in October. So, let's not make this as I've been teleported from early 2017 and complaining about something that has been known for a long while - this stuff stopped working in the last weeks (maybe an issue on my side, that's entirely possible) and up-to-date Flash in up-to-date FF ESR is supposed to work still. Any more input obviously welcome. Thanks.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

So I took a bit of time to see what happens if I start a VirtualBox VM image based on Oracle Linux 7 update 6, and:

- out of the box, FF60.2.2esr detects Flash Plugin 29 and invites to update it as it's vulnerable (fair enough). I take a VM snapshot here.

- YUM update to Flash 32.0.0.293 (without anything else being updated) gets FF60.2.2esr to mark the plugin as INVALID in pluginreg.dat, and the plugin doesn't show in Plugins tab

- reverting to the OOB snapshot, YUM update of Firefox (without anything else being updated) gets FF68.2.0esr to STILL DETECT Flash Plugin 29, with same invitation to update

- updating Flash Plugin alone at this point to 32.0.0.293 causes FF68.2.0esr to mark Flash INVALID in pluginreg.dat, and it doesn't show in Plugins tab

Bottom line, Flash Plugin 32.0.0.293 seems to break every FF from at least 60.1esr onwards.

So I took a bit of time to see what happens if I start a VirtualBox VM image based on Oracle Linux 7 update 6, and: - out of the box, FF60.2.2esr detects Flash Plugin 29 and invites to update it as it's vulnerable (fair enough). I take a VM snapshot here. - YUM update to Flash 32.0.0.293 (without anything else being updated) gets FF60.2.2esr to mark the plugin as INVALID in pluginreg.dat, and the plugin doesn't show in Plugins tab - reverting to the OOB snapshot, YUM update of Firefox (without anything else being updated) '''gets FF68.2.0esr to STILL DETECT Flash Plugin 29,''' with same invitation to update - updating Flash Plugin alone at this point to 32.0.0.293 causes FF68.2.0esr to mark Flash INVALID in pluginreg.dat, and it doesn't show in Plugins tab Bottom line, Flash Plugin 32.0.0.293 seems to break every FF from at least 60.1esr onwards.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Formally logged bug at Adobe here: https://tracker.adobe.com/#/view/FP-4199058

Formally logged bug at Adobe here: [https://tracker.adobe.com/#/view/FP-4199058 https://tracker.adobe.com/#/view/FP-4199058]
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.