X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

FF70 freezes entire machine (Fedora 31)

DMW
Veröffentlicht

Overview:

Firefox 70 on a Fedora 30/31 KDE machine will freeze the entire machine within minutes (sometimes seconds) of launch. A hard reboot is usually the only way to reset. The issue is not associated with any particular URL.

The System:

Operating System: Fedora 31 / KDE Plasma Version: 5.16.5 / KDE Frameworks Version: 5.61.0 / Qt Version: 5.12.5 / Kernel Version: 5.3.7-301.fc31.x86_64 / OS Type: 64-bit / Processors: 4 × Intel® Core™ i5-4590 CPU @ 3.30GHz / Memory: 7.7 GiB of RAM

When It Started:

The problem began as soon as Firefox was updated to version 70 on the Fedora 30 installation. I then upgraded Fedora itself to 31, but the Firefox problem persisted.

What I have tried:

1. I created a brand new user on the system and ran Firefox from that account. Problem still exists.

2. I launched Firefox from the command line in safe mode. Problem still exists.

   $ firefox -safe-mode

3. I launched Firefox with Wayland. Problem still exists.

   $ /usr/bin/firefox-wayland

4. I launched Firefox with X11. Problem still exists.

   $ /usr/bin/firefox-x11


Something odd:

The user agent string being presented by Firefox is inaccurate. It is presenting itself as Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

And yet this is definitely FF70 on Fedora, as I can attest to, unless I have gone insane and am not realizing it yet. It particularly troubles me that I have to post this support request from a different browser (so disregard the auto-detected user agent associated with this post). Oh, the humanity!

Overview: Firefox 70 on a Fedora 30/31 KDE machine will freeze the entire machine within minutes (sometimes seconds) of launch. A hard reboot is usually the only way to reset. The issue is not associated with any particular URL. The System: Operating System: Fedora 31 / KDE Plasma Version: 5.16.5 / KDE Frameworks Version: 5.61.0 / Qt Version: 5.12.5 / Kernel Version: 5.3.7-301.fc31.x86_64 / OS Type: 64-bit / Processors: 4 × Intel® Core™ i5-4590 CPU @ 3.30GHz / Memory: 7.7 GiB of RAM When It Started: The problem began as soon as Firefox was updated to version 70 on the Fedora 30 installation. I then upgraded Fedora itself to 31, but the Firefox problem persisted. What I have tried: 1. I created a brand new user on the system and ran Firefox from that account. Problem still exists. 2. I launched Firefox from the command line in safe mode. Problem still exists. $ firefox -safe-mode 3. I launched Firefox with Wayland. Problem still exists. $ /usr/bin/firefox-wayland 4. I launched Firefox with X11. Problem still exists. $ /usr/bin/firefox-x11 Something odd: The user agent string being presented by Firefox is inaccurate. It is presenting itself as Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0 And yet this is definitely FF70 on Fedora, as I can attest to, unless I have gone insane and am not realizing it yet. It particularly troubles me that I have to post this support request from a different browser (so disregard the auto-detected user agent associated with this post). Oh, the humanity!

Geändert am von DMW

Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36

Weitere Informationen

jscher2000
  • Top 10 Contributor
8792 Lösungen 71910 Antworten
Veröffentlicht

Hi derek16, your browser user agent might be disguised if you set privacy.resistFingerprinting to true in about:config. Otherwise, that is hard to explain.

Could you download a copy of this article for reference in the next steps:

How to stop Firefox from making automatic connections

Then, could you test what happens when your computer has no network connection at all: cable disconnected, wi-fi disabled, etc. Does Firefox still behave badly or is it calm?

If Firefox is calm when it's "offline," check through the settings article and see whether there are any things you might want to try disabling.

Hi derek16, your browser user agent might be disguised if you set privacy.resistFingerprinting to true in about:config. Otherwise, that is hard to explain. Could you download a copy of this article for reference in the next steps: [[How to stop Firefox from making automatic connections]] Then, could you test what happens when your computer has no network connection at all: cable disconnected, wi-fi disabled, etc. Does Firefox still behave badly or is it calm? If Firefox is calm when it's "offline," check through the settings article and see whether there are any things you might want to try disabling.
Hat Ihnen das weitergeholfen?
Zitieren
DMW
Veröffentlicht

Fragesteller

Hi, thanks for the advice. I did restore the correct user agent by changing the privacy.resistFingerprinting setting back.

I disabled all of the background connection settings in FF, and it then ran stable. Now I have been re-enabling them one at a time, running FF for a while between each change, to see which one causes it to freeze.

I'm still perplexed how one of the FF settings can result in the entire machine freezing...there is no core dump either.

Once I can determine the faulty setting, I'll post it back to this thread.

Hi, thanks for the advice. I did restore the correct user agent by changing the privacy.resistFingerprinting setting back. I disabled all of the background connection settings in FF, and it then ran stable. Now I have been re-enabling them one at a time, running FF for a while between each change, to see which one causes it to freeze. I'm still perplexed how one of the FF settings can result in the entire machine freezing...there is no core dump either. Once I can determine the faulty setting, I'll post it back to this thread.
Hat Ihnen das weitergeholfen?
Zitieren
DMW
Veröffentlicht

Fragesteller

Update on the issue.

I am still seeing FF70 hang, and cause the whole system to hang as well. It is not as often as previously observed.

I have followed the troubleshooting advice, going through the steps of disabling background activities; clearing out the places database; disabling extensions and addons; and monitoring memory usage.

I monitor CPU and memory usage, and neither are spiking at the time of the freeze. I even monitored "about:performance" and "about:memory" and nothing unusual is happening.

There is no core dump being generated, as the process isn't crashing.

I need to take this investigation to the next level. Could someone please advise what that would be?

Update on the issue. I am still seeing FF70 hang, and cause the whole system to hang as well. It is not as often as previously observed. I have followed the troubleshooting advice, going through the steps of disabling background activities; clearing out the places database; disabling extensions and addons; and monitoring memory usage. I monitor CPU and memory usage, and neither are spiking at the time of the freeze. I even monitored "about:performance" and "about:memory" and nothing unusual is happening. There is no core dump being generated, as the process isn't crashing. I need to take this investigation to the next level. Could someone please advise what that would be?
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.