X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Notifications not working

Veröffentlicht

Since updating to Firefox 70.0 my desktop notifications aren't working on Windows 7 PC. I used to get a notification near the Windows taskbar when I received an email or a facebook event. I've checked in Firefox options and they are definitely enabled. I've also checked on the permissions for the individual sites and notifications are definitely set to Allow. I've tried clearing the cache/cookies/data completely. I've also tried disabling notifications and then re-enabling them

Since updating to Firefox 70.0 my desktop notifications aren't working on Windows 7 PC. I used to get a notification near the Windows taskbar when I received an email or a facebook event. I've checked in Firefox options and they are definitely enabled. I've also checked on the permissions for the individual sites and notifications are definitely set to Allow. I've tried clearing the cache/cookies/data completely. I've also tried disabling notifications and then re-enabling them
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Weitere Informationen

dlsakbo 0 Lösungen 11 Antworten
Veröffentlicht

teps to reproduce:

Ran a web app that posted a desktop notification.


Actual results:

The notification disappeared automatically after 2 seconds. This is the same behavior that the HTML Desktop Notifications add-on used to have; the add-on has now been fixed so that the notifications stay up.


Expected results:

The notification should remain visible until it is closed by the user or the web app. This particular web app (in development) depends on the notification remaining visible so that the user can refer to it while working in another window.

teps to reproduce: Ran a web app that posted a desktop notification. Actual results: The notification disappeared automatically after 2 seconds. This is the same behavior that the HTML Desktop Notifications add-on used to have; the add-on has now been fixed so that the notifications stay up. Expected results: The notification should remain visible until it is closed by the user or the web app. This particular web app (in development) depends on the notification remaining visible so that the user can refer to it while working in another window.
Hat Ihnen das weitergeholfen?
Zitieren
lihininisansala95 0 Lösungen 16 Antworten
Veröffentlicht

go to firefox control center and check whether your website permission are given or not . check permissions in their and allow webpush notifications .

go to firefox control center and check whether your website permission are given or not . check permissions in their and allow webpush notifications .
Hat Ihnen das weitergeholfen?
Zitieren
akilaperera1910 0 Lösungen 7 Antworten
Veröffentlicht

Click the Site Info button icon to bring up the Control Center.

   Click the arrow in the prompt.
   Click More information to bring up the Page Info window.
   Click the Permissions tab.
   Under Send Notifications, choose a notification option: Always Ask, Allow, or Block. If your choices are greyed out, remove the checkmark next to Use Default.
Click the Site Info button icon to bring up the Control Center. Click the arrow in the prompt. Click More information to bring up the Page Info window. Click the Permissions tab. Under Send Notifications, choose a notification option: Always Ask, Allow, or Block. If your choices are greyed out, remove the checkmark next to Use Default.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

teps to reproduce: Ran a web app that posted a desktop notification. Actual results: The notification disappeared automatically after 2 seconds. This is the same behavior that the HTML Desktop Notifications add-on used to have; the add-on has now been fixed so that the notifications stay up. Expected results: The notification should remain visible until it is closed by the user or the web app. This particular web app (in development) depends on the notification remaining visible so that the user can refer to it while working in another window.

My problem is not that notifications are quickly disappearing - the problem is that they are not appearing at all !

<blockquote> teps to reproduce: Ran a web app that posted a desktop notification. Actual results: The notification disappeared automatically after 2 seconds. This is the same behavior that the HTML Desktop Notifications add-on used to have; the add-on has now been fixed so that the notifications stay up. Expected results: The notification should remain visible until it is closed by the user or the web app. This particular web app (in development) depends on the notification remaining visible so that the user can refer to it while working in another window. </blockquote> My problem is not that notifications are quickly disappearing - the problem is that they are not appearing at all !
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

lihininisansala95 said

go to firefox control center and check whether your website permission are given or not . check permissions in their and allow webpush notifications .

My permissions are definitely set to 'Allow' all notifications

''lihininisansala95 [[#answer-1262045|said]]'' <blockquote> go to firefox control center and check whether your website permission are given or not . check permissions in their and allow webpush notifications . </blockquote> My permissions are definitely set to 'Allow' all notifications
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

akilaperera1910 said

Click the Site Info button icon to bring up the Control Center. Click the arrow in the prompt. Click More information to bring up the Page Info window. Click the Permissions tab. Under Send Notifications, choose a notification option: Always Ask, Allow, or Block. If your choices are greyed out, remove the checkmark next to Use Default.

My notifications are already set to 'Allow' for the relevant sites

''akilaperera1910 [[#answer-1262049|said]]'' <blockquote> Click the Site Info button icon to bring up the Control Center. Click the arrow in the prompt. Click More information to bring up the Page Info window. Click the Permissions tab. Under Send Notifications, choose a notification option: Always Ask, Allow, or Block. If your choices are greyed out, remove the checkmark next to Use Default. </blockquote> My notifications are already set to 'Allow' for the relevant sites
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

Hello DavidM,

As you are talking about notifications on Windows taskbar; maybe,
for some reason, the notifications feature has been turned off in Windows' Settings - you could check to make sure :

Settings => System => Notifications & actions

Hello DavidM, As you are talking about notifications on Windows taskbar; maybe, <BR>for some reason, the notifications feature has been turned off in Windows' Settings - you could check to make sure : Settings => System => Notifications & actions
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

McCoy said

Hello DavidM, As you are talking about notifications on Windows taskbar; maybe,
for some reason, the notifications feature has been turned off in Windows' Settings - you could check to make sure : Settings => System => Notifications & actions

Windows notifications are definitely enabled and working fine (taskbar popus eg. windows update are showing ok) but the desktop notifications i used to get from firefox are no longer appearing at all

''McCoy [[#answer-1262183|said]]'' <blockquote> Hello DavidM, As you are talking about notifications on Windows taskbar; maybe, <BR>for some reason, the notifications feature has been turned off in Windows' Settings - you could check to make sure : Settings => System => Notifications & actions </blockquote> Windows notifications are definitely enabled and working fine (taskbar popus eg. windows update are showing ok) but the desktop notifications i used to get from firefox are no longer appearing at all
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

alerts.useSystemBackend

and set its value to true (default value is "false")

Then close and restart Firefox.



On the "about:config" page you could check this :

Type in the search bar notifications

And look for the preference :

dom.webnotifications.enabled

and make sure its value is set to true

Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''alerts.useSystemBackend''' and set its value to '''true''' (default value is "false") Then close and restart Firefox. ---------------------------<BR> On the "about:config" page you could check this : Type in the search bar '''notifications''' And look for the preference : '''dom.webnotifications.enabled''' and make sure its value is set to '''true'''
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

McCoy said

Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : alerts.useSystemBackend and set its value to true (default value is "false") Then close and restart Firefox.

On the "about:config" page you could check this :

Type in the search bar notifications

And look for the preference :

dom.webnotifications.enabled

and make sure its value is set to true

Thanks, but I can confirm that both settings are set to 'True'. I've closed and restarted firefox but the problem persists

''McCoy [[#answer-1262196|said]]'' <blockquote> Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''alerts.useSystemBackend''' and set its value to '''true''' (default value is "false") Then close and restart Firefox. ---------------------------<BR> On the "about:config" page you could check this : Type in the search bar '''notifications''' And look for the preference : '''dom.webnotifications.enabled''' and make sure its value is set to '''true''' </blockquote> Thanks, but I can confirm that both settings are set to 'True'. I've closed and restarted firefox but the problem persists
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

Running out of ideas .....

Maybe try to toggle some other "dom.webnotifications" preferences ?

You've already done everything in the book  :(

Running out of ideas ..... Maybe try to toggle some other "dom.webnotifications" preferences ? You've already done everything in the book :(
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Hi. I know, I don't understand it either!! I've experimented by setting every one of the 'notification' options to true but it still hasn't worked. I've again cleared cache / cookies / data, restarted firefox, rebooted computer etc etc, but no good.

Hi. I know, I don't understand it either!! I've experimented by setting every one of the 'notification' options to true but it still hasn't worked. I've again cleared cache / cookies / data, restarted firefox, rebooted computer etc etc, but no good.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

DavidM said

I used to get a notification near the Windows taskbar when I received an email or a facebook event.

I don't know which email provider(s) you use, but as for Facebook; does this help (?) :

https://www.facebook.com/help/269880466696699/?helpref=hc_fnav

Probably not, as you've already tried just about everything ..... :(



I forgot to ask : do you get the desktop notifications when you use another browser ?

''DavidM [[#question-1271600|said]]'' <blockquote> I used to get a notification near the Windows taskbar when I received an email or a facebook event. </blockquote> I don't know which email provider(s) you use, but as for Facebook; does this help (?) : https://www.facebook.com/help/269880466696699/?helpref=hc_fnav Probably not, as you've already tried just about everything ..... :( -----------------------------<BR> I forgot to ask : do you get the desktop notifications when you use another browser ?
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17564 Lösungen 158873 Antworten
Veröffentlicht

Is this about desktop notifications or about push notifications?

You can see all registered service workers on these pages: about:serviceworkers and about:debugging#workers You can check WebSockets via this page: about:networking#websockets See also serviceworker.txt in the profile folder.

There is a checkbox in Page Info for the current website:

  • Tools -> Page Info -> Permissions : Receive Notifications

You can check what websites you have allowed to send you messages via the Push API.

  • Options/Preferences -> Privacy & Security -> Permissions -> Notifications
Is this about desktop notifications or about push notifications? You can see all registered service workers on these pages: <b>about:serviceworkers</b> and <b>about:debugging#workers</b> You can check WebSockets via this page: <b>about:networking#websockets</b> See also serviceworker.txt in the profile folder. There is a checkbox in Page Info for the current website: *Tools -> Page Info -> Permissions : Receive Notifications You can check what websites you have allowed to send you messages via the Push API. *Options/Preferences -> Privacy & Security -> Permissions -> Notifications
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

McCoy said

DavidM said
I used to get a notification near the Windows taskbar when I received an email or a facebook event.

I don't know which email provider(s) you use, but as for Facebook; does this help (?) :

https://www.facebook.com/help/269880466696699/?helpref=hc_fnav

Probably not, as you've already tried just about everything ..... :(



I forgot to ask : do you get the desktop notifications when you use another browser ?

Yeah, Facebook notification settings are all active. I haven't tried a different browser yet but I guess I'll need to. I usually only use Firefox though as I'm loyal to it.

''McCoy [[#answer-1262352|said]]'' <blockquote> ''DavidM [[#question-1271600|said]]'' <blockquote> I used to get a notification near the Windows taskbar when I received an email or a facebook event. </blockquote> I don't know which email provider(s) you use, but as for Facebook; does this help (?) : https://www.facebook.com/help/269880466696699/?helpref=hc_fnav Probably not, as you've already tried just about everything ..... :( -----------------------------<BR> I forgot to ask : do you get the desktop notifications when you use another browser ? </blockquote> Yeah, Facebook notification settings are all active. I haven't tried a different browser yet but I guess I'll need to. I usually only use Firefox though as I'm loyal to it.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

cor-el said

Is this about desktop notifications or about push notifications? You can see all registered service workers on these pages: about:serviceworkers and about:debugging#workers You can check WebSockets via this page: about:networking#websockets See also serviceworker.txt in the profile folder. There is a checkbox in Page Info for the current website:
  • Tools -> Page Info -> Permissions : Receive Notifications
You can check what websites you have allowed to send you messages via the Push API.
  • Options/Preferences -> Privacy & Security -> Permissions -> Notifications

The 'serviceworkers' shows that there are entries for facebook and outlook so that seems ok. there are 2 entries for outlook and on the debugging page, one of them is Running (https://outlook.live.com/mail/sw.js) and the other is Stopped (https://outlook.live.com/mail/sw_webpush.js). I've tried unregistering both of them, then restarting firefox, then opening outlook and clicking on 'allow notification' when prompted. it hasn't worked though!

''cor-el [[#answer-1262477|said]]'' <blockquote> Is this about desktop notifications or about push notifications? You can see all registered service workers on these pages: <b>about:serviceworkers</b> and <b>about:debugging#workers</b> You can check WebSockets via this page: <b>about:networking#websockets</b> See also serviceworker.txt in the profile folder. There is a checkbox in Page Info for the current website: *Tools -> Page Info -> Permissions : Receive Notifications You can check what websites you have allowed to send you messages via the Push API. *Options/Preferences -> Privacy & Security -> Permissions -> Notifications </blockquote> The 'serviceworkers' shows that there are entries for facebook and outlook so that seems ok. there are 2 entries for outlook and on the debugging page, one of them is Running (https://outlook.live.com/mail/sw.js) and the other is Stopped (https://outlook.live.com/mail/sw_webpush.js). I've tried unregistering both of them, then restarting firefox, then opening outlook and clicking on 'allow notification' when prompted. it hasn't worked though!
Hat Ihnen das weitergeholfen?
Zitieren
Dinushi Dhananjani
  • Top 25 Contributor
3 Lösungen 173 Antworten
Veröffentlicht
[http://example.com https://support.mozilla.org/en-US/kb/push-notifications-firefox]
Hat Ihnen das weitergeholfen?
Zitieren
Dinushi Dhananjani
  • Top 25 Contributor
3 Lösungen 173 Antworten
Veröffentlicht

1. Open Mozilla Firefox and type about:config in the addressbar and press Enter. It'll show you a warning message, click on "I accept the risk!" button.

2. Now type alerts in Search filter box and it'll show following preference in the window:

   alerts.useSystemBackend

3. If the preference value is set to true, it means Firefox will show websites notifications in Windows 10 Action Center. If the value is set to false, it means Firefox will show notifications in its own notification system.


To modify the preference, double-click on alerts.useSystemBackend preference and change its value. Alternatively, you can right-click on the preference and select Toggle option.

To enable Windows 10 Action Center support i.e. show notifications in Action Center, set the value to true.

To disable Windows 10 Action Center support i.e. show notifications in Firefox classic notification system, set the value to false.

1. Open Mozilla Firefox and type about:config in the addressbar and press Enter. It'll show you a warning message, click on "I accept the risk!" button. 2. Now type alerts in Search filter box and it'll show following preference in the window: alerts.useSystemBackend 3. If the preference value is set to true, it means Firefox will show websites notifications in Windows 10 Action Center. If the value is set to false, it means Firefox will show notifications in its own notification system. To modify the preference, double-click on alerts.useSystemBackend preference and change its value. Alternatively, you can right-click on the preference and select Toggle option. To enable Windows 10 Action Center support i.e. show notifications in Action Center, set the value to true. To disable Windows 10 Action Center support i.e. show notifications in Firefox classic notification system, set the value to false.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Dinushi Dhananjani said

1. Open Mozilla Firefox and type about:config in the addressbar and press Enter. It'll show you a warning message, click on "I accept the risk!" button. 2. Now type alerts in Search filter box and it'll show following preference in the window: alerts.useSystemBackend 3. If the preference value is set to true, it means Firefox will show websites notifications in Windows 10 Action Center. If the value is set to false, it means Firefox will show notifications in its own notification system. To modify the preference, double-click on alerts.useSystemBackend preference and change its value. Alternatively, you can right-click on the preference and select Toggle option. To enable Windows 10 Action Center support i.e. show notifications in Action Center, set the value to true. To disable Windows 10 Action Center support i.e. show notifications in Firefox classic notification system, set the value to false.

Thanks but I've already tried that. I've tried setting it with both 'true' and 'false' but I'm still not getting the notifications. I'm on Windows 7

''Dinushi Dhananjani [[#answer-1263038|said]]'' <blockquote> 1. Open Mozilla Firefox and type about:config in the addressbar and press Enter. It'll show you a warning message, click on "I accept the risk!" button. 2. Now type alerts in Search filter box and it'll show following preference in the window: alerts.useSystemBackend 3. If the preference value is set to true, it means Firefox will show websites notifications in Windows 10 Action Center. If the value is set to false, it means Firefox will show notifications in its own notification system. To modify the preference, double-click on alerts.useSystemBackend preference and change its value. Alternatively, you can right-click on the preference and select Toggle option. To enable Windows 10 Action Center support i.e. show notifications in Action Center, set the value to true. To disable Windows 10 Action Center support i.e. show notifications in Firefox classic notification system, set the value to false. </blockquote> Thanks but I've already tried that. I've tried setting it with both 'true' and 'false' but I'm still not getting the notifications. I'm on Windows 7

Geändert am von DavidM

Hat Ihnen das weitergeholfen?
Zitieren
Senali Madawala
  • Top 25 Contributor
1 Lösungen 150 Antworten
Veröffentlicht

One of the most common reasons why iPhone notifications are not working is because Do Not Disturb is turned on. ... To turn off Do Not Disturb, open the Settings app on your iPhone and tap Do Not Disturb. Then, tap on the switch next to Do Not Disturb to turn it off.

  1. Reboot Your Phone. ...
   2.Review the App's Notification Settings. ...
   3.Disable Software Battery Optimizations. ...
   4.Check for Proprietary Power Savers. ...
   5.Reinstall the App or Wait for Updates. ...
   6.Check the Do Not Disturb Mode. ...
   7.Is Background Data Enabled?
   8.Is Data Saver Turned On?
   9.Is the App Allowed to Function in the Background?
One of the most common reasons why iPhone notifications are not working is because Do Not Disturb is turned on. ... To turn off Do Not Disturb, open the Settings app on your iPhone and tap Do Not Disturb. Then, tap on the switch next to Do Not Disturb to turn it off. 1. Reboot Your Phone. ... 2.Review the App's Notification Settings. ... 3.Disable Software Battery Optimizations. ... 4.Check for Proprietary Power Savers. ... 5.Reinstall the App or Wait for Updates. ... 6.Check the Do Not Disturb Mode. ... 7.Is Background Data Enabled? 8.Is Data Saver Turned On? 9.Is the App Allowed to Function in the Background?
Hat Ihnen das weitergeholfen? 1
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.