X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Since the last firefox update, it takes over my xterm cursor after 5 seconds after every mouse click - interrupting my typing; how to fix this?

Veröffentlicht

After a mouse click in the xterm window, the cursor focus is taken away from xterm by firefox after 3 seconds. It comes back after a 10 second wait and then stays in xterm. This did not happen before the latest update (version 70.0) - which also changed the logo.

After a mouse click in the xterm window, the cursor focus is taken away from xterm by firefox after 3 seconds. It comes back after a 10 second wait and then stays in xterm. This did not happen before the latest update (version 70.0) - which also changed the logo.
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:70.0) Gecko/20100101 Firefox/70.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4269 Lösungen 59852 Antworten
Veröffentlicht

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Hat Ihnen das weitergeholfen? 0
Zitieren
Veröffentlicht

Fragesteller

Safe mode did not solve problem. Can't find anywhere where to look.

Safe mode did not solve problem. Can't find anywhere where to look.
Hat Ihnen das weitergeholfen?
Zitieren
Danny Colin 7 Lösungen 18 Antworten
Veröffentlicht

Since you're on Linux, could you try to disable webrender and see if it solves the problem.

To disable it, you need to:

  1. Type about:config in the URLbar
  2. Click on the "Accept the Risk and Continue" button
  3. Search for gfx.webrender.force-disabled and set it to true
  4. Restart Firefox

If it doesn't work, you can re-enable webrender by setting the preferences to false and restarting Firefox again.

Also, could you provide more information about your linux distribution and desktop environment. Sometimes, those bug are due to a conflict with an other program. For example, I had problem with recent Firefox version because there was a bug in the Xorg intel driver that hasn't been patched for years.

Since you're on Linux, could you try to disable webrender and see if it solves the problem. To disable it, you need to: # Type ''about:config'' in the URLbar # Click on the "Accept the Risk and Continue" button # Search for ''gfx.webrender.force-disabled'' and set it to ''true'' # Restart Firefox If it doesn't work, you can re-enable webrender by setting the preferences to false and restarting Firefox again. Also, could you provide more information about your linux distribution and desktop environment. Sometimes, those bug are due to a conflict with an other program. For example, I had problem with recent Firefox version because there was a bug in the Xorg intel driver that hasn't been patched for years.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Did not solve the problem. it occurs when using xterm under Xcode on MacOSX9.5

Did not solve the problem. it occurs when using xterm under Xcode on MacOSX9.5
Hat Ihnen das weitergeholfen?
Zitieren
Bahu 0 Lösungen 6 Antworten
Veröffentlicht

Visit this blog vi this email, it may help you. https://bugzilla.mozilla.org/show_bug.cgi?id=736811

Visit this blog vi this email, it may help you. https://bugzilla.mozilla.org/show_bug.cgi?id=736811
Hat Ihnen das weitergeholfen?
Zitieren
Danny Colin 7 Lösungen 18 Antworten
Veröffentlicht

wakker said

Did not solve the problem. it occurs when using xterm under Xcode on MacOSX9.5

You mean XQuartz? In any case, I'll bet my money the problem is related to the X server of Apple not playing well with X applications especially xterm.

''wakker [[#answer-1261687|said]]'' <blockquote> Did not solve the problem. it occurs when using xterm under Xcode on MacOSX9.5 </blockquote> You mean XQuartz? In any case, I'll bet my money the problem is related to the X server of Apple not playing well with X applications especially xterm.
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Yes, Xquartz.

However, this problem did not really happen before the last firefox update. The carbonite server would take it over every 1 minute, but I could pause it and it would not do it.

Only after the last firefox update did the problem start.

It could be apple X server not interacting well with xterm, but why did this not happen before. And is there some flag to prevent it?

Yes, Xquartz. However, this problem did not really happen before the last firefox update. The carbonite server would take it over every 1 minute, but I could pause it and it would not do it. Only after the last firefox update did the problem start. It could be apple X server not interacting well with xterm, but why did this not happen before. And is there some flag to prevent it?
Hat Ihnen das weitergeholfen?
Zitieren
Danny Colin 7 Lösungen 18 Antworten
Veröffentlicht

wakker said

It could be apple X server not interacting well with xterm, but why did this not happen before. And is there some flag to prevent it?

There could be a lot of reason. I think the best solution should be to file a bugreport on bugzilla.mozilla.org and give as much information as you can. Maybe you could include a short video of the bug. Oh and if you file a report please post a link to it on this thread :).

Also, in the meantime, make sure you have the latest xterm version. It should be version 349.

''wakker [[#answer-1262413|said]]'' <blockquote> It could be apple X server not interacting well with xterm, but why did this not happen before. And is there some flag to prevent it? </blockquote> There could be a lot of reason. I think the best solution should be to file a bugreport on bugzilla.mozilla.org and give as much information as you can. Maybe you could include a short video of the bug. Oh and if you file a report please post a link to it on this thread :). Also, in the meantime, make sure you have the latest xterm version. It should be version 349.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.