X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Re-enable autoplay permission for website using Web Audio API

Veröffentlicht

Hi. Doing some clean up I removed an exception for https://www.diki.pl/ to autoplay sounds (e.g. https://www.diki.pl/dog ). I expected to have a an ability to add it again when entered on the website and clicked the (i) icon with Permissions as described in https://support.mozilla.org/en-US/kb/block-autoplay . However, for that site I don't see anything special (the screenshot attached). The aforementioned site has the "Add sites to your list to autoplay media", but it doesn't allow to add pages, only to remove them or change the settings.

After some digging I was able to restore an exception by adding the following row in the moz_perms table in permissions.sqlite: insert into moz_perms values(XXX, 'https://www.diki.pl', 'autoplay-media', 1, 0, 0, 1570918391133);

However, I would expect to have an easier way to do that - I tested it with a clean profile and the effect is the same - just media.autoplay.block-webaudio needs to be set to true to block it at all).

Is there any easier way to (re-)enable autoplay for shy website (here using Web Audio API)?

Firefox 69.0.1, Fedora 30.

Hi. Doing some clean up I removed an exception for https://www.diki.pl/ to autoplay sounds (e.g. https://www.diki.pl/dog ). I expected to have a an ability to add it again when entered on the website and clicked the (i) icon with Permissions as described in https://support.mozilla.org/en-US/kb/block-autoplay . However, for that site I don't see anything special (the screenshot attached). The aforementioned site has the "Add sites to your list to autoplay media", but it doesn't allow to add pages, only to remove them or change the settings. After some digging I was able to restore an exception by adding the following row in the moz_perms table in permissions.sqlite: insert into moz_perms values(XXX, 'https://www.diki.pl', 'autoplay-media', 1, 0, 0, 1570918391133); However, I would expect to have an easier way to do that - I tested it with a clean profile and the effect is the same - just media.autoplay.block-webaudio needs to be set to true to block it at all). Is there any easier way to (re-)enable autoplay for shy website (here using Web Audio API)? Firefox 69.0.1, Fedora 30.
Angefügte Screenshots
Zitieren

Mehr Details zum System

Installierte Plugins

N/A - tested also with a new clear profile.

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17468 Lösungen 157853 Antworten
Veröffentlicht

Hilfreiche Antwort

Did you try "Tools -> Page Info -> Permissions" ? *https://support.mozilla.org/en-US/kb/page-info-window-view-technical-details-about-page
Hat Ihnen das weitergeholfen? 1
Zitieren
Veröffentlicht

Fragesteller

Thanks @cor-el! That was something I needed - much simpler than operating at the SQLite DB level :).

Anyway, it would be probably good to mention it at: https://support.mozilla.org/en-US/kb/block-autoplay

In addition, I still would expect to have a page using Web Audio API for autoplay to trigger a question to a user about his/her decision what to do (when `media.autoplay.block-webaudio == true`). WDYT?

Thanks @cor-el! That was something I needed - much simpler than operating at the SQLite DB level :). Anyway, it would be probably good to mention it at: https://support.mozilla.org/en-US/kb/block-autoplay In addition, I still would expect to have a page using Web Audio API for autoplay to trigger a question to a user about his/her decision what to do (when `media.autoplay.block-webaudio == true`). WDYT?
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.