X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Can I disable the blue dot indicating that a pinned tab title has changed?

Veröffentlicht

The previous question linked below addressed this problem, but the css suggested there (copied below) no longer seems to work. Is there an option that works with FF 69?

This is the previous question: https://support.mozilla.org/en-US/questions/1181537 The suggestion there doesn't seem to do anything for me: .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged] {

   background-image: none !important;
 }
The previous question linked below addressed this problem, but the css suggested there (copied below) no longer seems to work. Is there an option that works with FF 69? This is the previous question: https://support.mozilla.org/en-US/questions/1181537 The suggestion there doesn't seem to do anything for me: .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged] { background-image: none !important; }
Zitieren

Mehr Details zum System

Installierte Plugins

OpenH264 Video Codec provided by Cisco Systems, Inc. Widevine Content Decryption Module provided by Google Inc.

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:69.0) Gecko/20100101 Firefox/69.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17571 Lösungen 158937 Antworten
Veröffentlicht

See this CSS file for the rule that adds the blue dot.


There seems to be an extra attribute (:not([selected="true"])) added to the selector:

.tabbrowser-tab:-moz-any([image], [pinned]) > .tab-stack > .tab-content[attention]:not([selected="true"]),
.tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) {}
See this CSS file for the rule that adds the blue dot. *https://dxr.mozilla.org/mozilla-release/source/browser/themes/shared/tabs.inc.css#601 *chrome://browser/skin/tabbrowser/indicator-tab-attention.svg ---- There seems to be an extra attribute (:not([selected="true"])) added to the selector: <pre><nowiki>.tabbrowser-tab:-moz-any([image], [pinned]) > .tab-stack > .tab-content[attention]:not([selected="true"]), .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) {}</nowiki></pre>
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Unfortunately, adding that extra attribute doesn't seem to have changed anything—the blue dot still appears. Here's the updated rule I used, still without success (please let me know if I made an error):

.tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) {

 background-image: none !important;

}

Unfortunately, adding that extra attribute doesn't seem to have changed anything—the blue dot still appears. Here's the updated rule I used, still without success (please let me know if I made an error): .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) { background-image: none !important; }
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17571 Lösungen 158937 Antworten
Veröffentlicht

I don't have a test website that reloads pages and change the title, so I can check what is going on. If you have one that doesn't require to login then please post a link.

I don't have a test website that reloads pages and change the title, so I can check what is going on. If you have one that doesn't require to login then please post a link.
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8790 Lösungen 71883 Antworten
Veröffentlicht

Hilfreiche Antwort

Hmm, the above code works for me:

/* Suppress blue dot on pinned tab */
.tabbrowser-tab > .tab-stack >
 .tab-content[pinned][titlechanged]:not([selected="true"]){
  background-image: none !important;
}

This also works for me:

/* Suppress blue dot on pinned tab */
.tabbrowser-tab > .tab-stack >
 .tab-content[pinned][titlechanged]:not([selected="true"]){
  background-size: 0px 0px;
}

If you want a more subtle sign of changes on the tab, you could apply a bottom border:

/* Suppress blue dot on pinned tab */
.tabbrowser-tab > .tab-stack >
 .tab-content[pinned][titlechanged]:not([selected="true"]){
  background-image: none !important;
  /* blue bottom border at 40% opacity */
  border-bottom: 2px solid rgba(0, 0, 255, 0.4);
}

For testing purposes, I pinned a tab and executed the following in the Web Console to modify the title every 5 seconds:

var titlechanger = window.setInterval(function(){document.title=document.title+'0';}, 5000);

Hmm, the above code works for me: <pre>/* Suppress blue dot on pinned tab */ .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]){ background-image: none !important; } </pre> This also works for me: <pre>/* Suppress blue dot on pinned tab */ .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]){ background-size: 0px 0px; } </pre> If you want a more subtle sign of changes on the tab, you could apply a bottom border: <pre>/* Suppress blue dot on pinned tab */ .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]){ background-image: none !important; /* blue bottom border at 40% opacity */ border-bottom: 2px solid rgba(0, 0, 255, 0.4); } </pre> ''For testing purposes, I pinned a tab and executed the following in the Web Console to modify the title every 5 seconds:'' var titlechanger = window.setInterval(function(){document.title=document.title+'0';}, 5000);
Hat Ihnen das weitergeholfen? 1
Zitieren
jscher2000
  • Top 10 Contributor
8790 Lösungen 71883 Antworten
Veröffentlicht

Ausgewählte Lösung

More generally for Firefox 69: https://www.userchrome.org/firefox-changes-userchrome-css.html#fx69
Hat Ihnen das weitergeholfen? 1
Zitieren

Fragesteller

Looks like I was asking the wrong question. As pointed out by jscher2000, starting with Firefox 69, toolkit.legacyUserProfileCustomizations.stylesheets needs to be set to true (in about:config) in order to use userChrome.css

Looks like I was asking the wrong question. As pointed out by jscher2000, starting with Firefox 69, toolkit.legacyUserProfileCustomizations.stylesheets needs to be set to true (in about:config) in order to use userChrome.css
Hat Ihnen das weitergeholfen?
Zitieren
norbertk 0 Lösungen 1 Antworten
Veröffentlicht

I was having this problem, and didn't understand how to enable the rule in my .css sheet. For others who have the same question, these steps should work:

https://www.reddit.com/r/FirefoxCSS/comments/73dvty/tutorial_how_to_create_and_livedebug_userchromecss/

This is my userChrome.css:

@-moz-document url(chrome://browser/content/browser.xhtml) {

.tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) {

 background-image: none !important;
 }

}

I was having this problem, and didn't understand how to enable the rule in my .css sheet. For others who have the same question, these steps should work: https://www.reddit.com/r/FirefoxCSS/comments/73dvty/tutorial_how_to_create_and_livedebug_userchromecss/ This is my userChrome.css: @-moz-document url(chrome://browser/content/browser.xhtml) { .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([selected="true"]) { background-image: none !important; } }
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.