X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

how to get Adobe Flash always allowed on one of our local webpage?

Veröffentlicht

our VMware ruining on our local server and it needs Adobe Flash to run, how do i set my browser to allow adobe flash prlyer to always work on that site?

our VMware ruining on our local server and it needs Adobe Flash to run, how do i set my browser to allow adobe flash prlyer to always work on that site?
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8695 Lösungen 71076 Antworten
Veröffentlicht

Hilfreiche Antwort

Hi ntewfik, starting in Firefox 69, Flash can only be activated on a particular site for the current session, not permanently.

https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/

Hi ntewfik, starting in Firefox 69, Flash can only be activated on a particular site for the current session, not permanently. [https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/ https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/]

Geändert am von jscher2000

Hat Ihnen das weitergeholfen? 2
Zitieren

Fragesteller

Thank you for you replay. unfortunately that means i have to use a different browser for my work browsing.

Thank you for you replay. unfortunately that means i have to use a different browser for my work browsing.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17479 Lösungen 157962 Antworten
Veröffentlicht

You can possibly consider to use Firefox 68 ESR with is own dedicated profile in such cases.

You can possibly consider to use Firefox 68 ESR with is own dedicated profile in such cases. *https://www.mozilla.org/en-US/firefox/organizations/all/ *https://support.mozilla.org/en-US/kb/dedicated-profiles-firefox-installation
Hat Ihnen das weitergeholfen?
Zitieren
bpfoley89 0 Lösungen 1 Antworten
Veröffentlicht

Hilfreiche Antwort

jscher2000 said

Hi ntewfik, starting in Firefox 69, Flash can only be activated on a particular site for the current session, not permanently. https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/
  • Everyone Hated That*

Seriously, that's become a major annoyance for me. And there's no add-ons yet that re-enable the always-allow feature.

Just give me the option to whitelist sites or something for it.

FFS, I might end up going back to chrome otherwise.

''jscher2000 [[#answer-1250690|said]]'' <blockquote> Hi ntewfik, starting in Firefox 69, Flash can only be activated on a particular site for the current session, not permanently. [https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/ https://www.fxsitecompat.dev/en-CA/docs/2019/flash-player-can-no-longer-always-be-activated/] </blockquote> *Everyone Hated That* Seriously, that's become a major annoyance for me. And there's no add-ons yet that re-enable the always-allow feature. Just give me the option to whitelist sites or something for it. FFS, I might end up going back to chrome otherwise.
Hat Ihnen das weitergeholfen? 2
Zitieren
jscher2000
  • Top 10 Contributor
8695 Lösungen 71076 Antworten
Veröffentlicht

Extensions cannot modify this plugin-related setting (for example, they can't automatically activate Flash for you on a site).

Two updates to my earlier reply:

(1) The developers are looking at extending the temporary approval period because it now expires after just 1 hour, which is surprisingly short.

The new duration might be your entire session (until you exit/quit Firefox), or some long period of time. That is TBD and will take some time to roll out.

(2) It is possible to use an Enterprise policy to give one or more sites permanent approval to run Flash.

This is a little tricky to set up because it involves creating a new folder and text file in the Firefox program folder, which Windows restricts to those with Administrator privileges.

See this reply from a couple days ago: https://support.mozilla.org/questions/1268957#answer-1252862

To add more sites to the list, use a comma between them:

{
  "policies": {
    "FlashPlugin": {
      "Allow": [
        "https://helpx.adobe.com/",
        "https://www.example.com/"
      ]
    }
  }
}
Extensions cannot modify this plugin-related setting (for example, they can't automatically activate Flash for you on a site). Two updates to my earlier reply: (1) The developers are looking at extending the temporary approval period because it now expires after just 1 hour, which is surprisingly short. The new duration might be your entire session (until you exit/quit Firefox), or some long period of time. That is TBD and will take some time to roll out. (2) It is possible to use an Enterprise policy to give one or more sites permanent approval to run Flash. This is a ''little'' tricky to set up because it involves creating a new folder and text file in the Firefox program folder, which Windows restricts to those with Administrator privileges. See this reply from a couple days ago: https://support.mozilla.org/questions/1268957#answer-1252862 To add more sites to the list, use a comma between them: <pre>{ "policies": { "FlashPlugin": { "Allow": [ "https://helpx.adobe.com/", "https://www.example.com/" ] } } } </pre>
Hat Ihnen das weitergeholfen?
Zitieren
ajpeavler 0 Lösungen 4 Antworten
Veröffentlicht

I also have noticed this in the past few days on a couple of Facebook games which I play. They do not load, and I have to click on the black space where the game is supposed to be in order to get the popup to allow Flash. I am having to do this daily. This is very annoying. And why does Firefox plan to no longer support Flash next year? As long as these Facebook games exist and are not updated, people will need to use Flash to play them. (I'm playing Bejeweled Blitz and Solitaire Blitz from Popcap.)

I also have noticed this in the past few days on a couple of Facebook games which I play. They do not load, and I have to click on the black space where the game is supposed to be in order to get the popup to allow Flash. I am having to do this daily. This is very annoying. And why does Firefox plan to no longer support Flash next year? As long as these Facebook games exist and are not updated, people will need to use Flash to play them. (I'm playing Bejeweled Blitz and Solitaire Blitz from Popcap.)
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

ajpeavler said

And why does Firefox plan to no longer support Flash next year? As long as these Facebook games exist and are not updated, people will need to use Flash to play them.

It is not Firefox (or Mozilla) who made this decision : Adobe (the company behind Flash) announced back in 2017 already that it would be the end-of-life for Flash at the end of 2020. Sites that still use Flash will have to get ready to switch to HTML5 instead - they had (and still have) ample time to make the switch.

All major browsers have already disabled the option to permanently enable Flash, which in my opinion is premature and only causes users a lot of work; simply warning users that it will be the end of Flash at the end of 2020 would have sufficed. But in the end it's the sites' responsibility to make sure that people will still be able to use their site - it's in their own best interest as well ....

''ajpeavler [[#answer-1254073|said]]'' <blockquote> And why does Firefox plan to no longer support Flash next year? As long as these Facebook games exist and are not updated, people will need to use Flash to play them. </blockquote> It is not Firefox (or Mozilla) who made this decision : Adobe (the company behind Flash) announced back in 2017 already that it would be the end-of-life for Flash at the end of 2020. Sites that still use Flash will have to get ready to switch to HTML5 instead - they had (and still have) ample time to make the switch. All major browsers have already disabled the option to permanently enable Flash, which in my opinion is premature and only causes users a lot of work; simply warning users that it will be the end of Flash at the end of 2020 would have sufficed. But in the end it's the sites' responsibility to make sure that people will still be able to use their site - it's in their own best interest as well ....
Hat Ihnen das weitergeholfen? 2
Zitieren
ChrisG 2 Lösungen 39 Antworten
Veröffentlicht

The National Weather Service Doppler Radar Loop Maps USE ADOBE FLASH. It's not just games and such.

Having to click twice (once in the map area to run Adobe, then the Allow (WHY NOT REMEMBERED???) to get my map is annoying.

The National Weather Service Doppler Radar Loop Maps USE ADOBE FLASH. It's not just games and such. Having to click twice (once in the map area to run Adobe, then the Allow (WHY NOT REMEMBERED???) to get my map is annoying.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

@ jpeavler :

I just noticed that you marked my post as Chosen Solution - as you are not the OP of this thread (only they can mark a thread as solved); I will flag this thread and ask a moderator to remove that mark.

@ jpeavler : I just noticed that you marked my post as Chosen Solution - as you are not the OP of this thread (only they can mark a thread as solved); I will flag this thread and ask a moderator to remove that mark.
Hat Ihnen das weitergeholfen?
Zitieren
ChrisG 2 Lösungen 39 Antworten
Veröffentlicht

All I did was post a comment at the bottom of the thread. I did not click on anything.

All I did was post a comment at the bottom of the thread. I did not click on anything.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

ChrisG said

All I did was post a comment at the bottom of the thread. I did not click on anything.

Hello ChrisG,

In case you're referring to my post about the Chosen Solution mark : that was directed at "jpeavler", not you .....

As for your problem with having to click "Allow" every time you visit a site that still uses Flash : your frustration is very understandable  !

Please see this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1581664

You can give this bug report a vote, to show your interest :

https://bugzilla.mozilla.org/page.cgi?id=voting.html

''ChrisG [[#answer-1254622|said]]'' <blockquote> All I did was post a comment at the bottom of the thread. I did not click on anything. </blockquote> Hello ChrisG, In case you're referring to my post about the Chosen Solution mark : that was directed at "jpeavler", not you ..... As for your problem with having to click "Allow" every time you visit a site that still uses Flash : your frustration is very understandable ! Please see this bug report : https://bugzilla.mozilla.org/show_bug.cgi?id=1581664 You can give this bug report a vote, to show your interest : https://bugzilla.mozilla.org/page.cgi?id=voting.html
Hat Ihnen das weitergeholfen? 1
Zitieren
jscher2000
  • Top 10 Contributor
8695 Lösungen 71076 Antworten
Veröffentlicht

I was looking at the code of an upcoming change to extend the length of temporary Flash permission, and it mentioned a preference for how long that permission lasts in Firefox 69. I haven't had time to test this myself, but if you want to try extending it beyond one hour:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste minutes and pause while the list is filtered

(3) Double-click the plugin.sessionPermissionNow.intervalInMinutes preference to display a dialog where you can change from 60 minutes to some other number. For example, there are 1440 minutes in 24 hours. After making the change, click OK.

(I set mine to 1440 and activated flash on Adobe's test page so I'll check that page a few times today to see whether it stays activated after an hour. I didn't restart Firefox... I hardly ever restart Firefox.)

I was looking at the code of an upcoming change to extend the length of temporary Flash permission, and it mentioned a preference for how long that permission lasts in Firefox 69. I haven't had time to test this myself, but if you want to try extending it beyond one hour: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''minutes''' and pause while the list is filtered (3) Double-click the '''plugin.sessionPermissionNow.intervalInMinutes''' preference to display a dialog where you can change from '''60''' minutes to some other number. For example, there are '''1440''' minutes in 24 hours. After making the change, click OK. (I set mine to 1440 and activated flash on [https://helpx.adobe.com/flash-player.html Adobe's test page] so I'll check that page a few times today to see whether it stays activated after an hour. I didn't restart Firefox... I hardly ever restart Firefox.)
Hat Ihnen das weitergeholfen?
Zitieren
ajpeavler 0 Lösungen 4 Antworten
Veröffentlicht

McCoy said

@ jpeavler : I just noticed that you marked my post as Chosen Solution - as you are not the OP of this thread (only they can mark a thread as solved); I will flag this thread and ask a moderator to remove that mark.

I don't think I clicked "chosen solution"; there's a box that asked if the reply was "helpful to you" and I think I clicked on that one because you provided good information.

''McCoy [[#answer-1254616|said]]'' <blockquote> @ jpeavler : I just noticed that you marked my post as Chosen Solution - as you are not the OP of this thread (only they can mark a thread as solved); I will flag this thread and ask a moderator to remove that mark. </blockquote> I don't think I clicked "chosen solution"; there's a box that asked if the reply was "helpful to you" and I think I clicked on that one because you provided good information.

Geändert am von ajpeavler

Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

ajpeavler said

I don't think I clicked "chosen solution"; there's a box that asked if the reply was "helpful to you" and I clicked that because you provided good information.

Must have happened somehow, but a moderator already removed the mark.

But thank you for the compliment, though !

''ajpeavler [[#answer-1254687|said]]'' <blockquote> I don't think I clicked "chosen solution"; there's a box that asked if the reply was "helpful to you" and I clicked that because you provided good information. </blockquote> Must have happened somehow, but a moderator already removed the mark. But thank you for the compliment, though !
Hat Ihnen das weitergeholfen?
Zitieren
SMAdler 0 Lösungen 7 Antworten
Veröffentlicht

The removal of the option to always allow Flash is a major pain. Please re-allow it until Flash is no longer available.

The removal of the option to always allow Flash is a major pain. Please re-allow it until Flash is no longer available.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

SMAdler said

The removal of the option to always allow Flash is a major pain. Please re-allow it until Flash is no longer available.

I've been pleading to create a preference on the "about:config" page that will force-enable Flash; all one would have to do is set its value to "true", but it's like talking to a brick wall.

''SMAdler [[#answer-1255032|said]]'' <blockquote> The removal of the option to always allow Flash is a major pain. Please re-allow it until Flash is no longer available. </blockquote> I've been pleading to create a preference on the "about:config" page that will force-enable Flash; all one would have to do is set its value to "true", but it's like talking to a brick wall.
Hat Ihnen das weitergeholfen? 0
Zitieren
ChrisG 2 Lösungen 39 Antworten
Veröffentlicht

I now have a page I sometimes use where it totally won't load the content because it uses Flash. It does not ask me if I want to open flash; there is absolutely no way to see the content on this page with V69.

https://www.kgw.com/radar

The current map is supposed to be at the top of the page (it's there with Safari), but instead I have a white screen with no way to enable Adobe Flash.

While it's one thing that a page is more difficult to load and maintain over time, but it's totally unacceptable that a page's content does not load at all with V 69.

I would really hate to go back to Safari; it appears Mozolla is not listening to reality.

It's not their job to CHANGE reality, but rather it's their job to make reality accessible!

I now have a page I sometimes use where it totally won't load the content because it uses Flash. It does not ask me if I want to open flash; there is absolutely no way to see the content on this page with V69. https://www.kgw.com/radar The current map is supposed to be at the top of the page (it's there with Safari), but instead I have a white screen with no way to enable Adobe Flash. While it's one thing that a page is more difficult to load and maintain over time, but it's totally unacceptable that a page's content does not load at all with V 69. I would really hate to go back to Safari; it appears Mozolla is not listening to reality. It's not their job to CHANGE reality, but rather it's their job to make reality accessible!
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

ChrisG said

I would really hate to go back to Safari; it appears Mozolla is not listening to reality.

It wouldn't do you any good to go back to Safari, though :

https://www.computerworld.com/article/3403345/where-do-browsers-stand-on-flashs-impending-demise.html

''ChrisG [[#answer-1255065|said]]'' <blockquote> I would really hate to go back to Safari; it appears Mozolla is not listening to reality. </blockquote> It wouldn't do you any good to go back to Safari, though : https://www.computerworld.com/article/3403345/where-do-browsers-stand-on-flashs-impending-demise.html
Hat Ihnen das weitergeholfen? 1
Zitieren
jscher2000
  • Top 10 Contributor
8695 Lösungen 71076 Antworten
Veröffentlicht

ChrisG said

I now have a page I sometimes use where it totally won't load the content because it uses Flash. It does not ask me if I want to open flash; there is absolutely no way to see the content on this page with V69. https://www.kgw.com/radar The current map is supposed to be at the top of the page (it's there with Safari), but instead I have a white screen with no way to enable Adobe Flash.

Hi ChrisG, that weather widget doesn't use Flash as far as I can tell. I don't know why it stays blank in Firefox (or at least, it stays blank without unblocking way more junk than I want to unblock).

''ChrisG [[#answer-1255065|said]]'' <blockquote> I now have a page I sometimes use where it totally won't load the content because it uses Flash. It does not ask me if I want to open flash; there is absolutely no way to see the content on this page with V69. https://www.kgw.com/radar The current map is supposed to be at the top of the page (it's there with Safari), but instead I have a white screen with no way to enable Adobe Flash. </blockquote> Hi ChrisG, that weather widget doesn't use Flash as far as I can tell. I don't know why it stays blank in Firefox (or at least, it stays blank without unblocking way more junk than I want to unblock).
Hat Ihnen das weitergeholfen? 1
Zitieren
ChrisG 2 Lösungen 39 Antworten
Veröffentlicht

It worked with V68 a week ago. Today with V69 it does not, but Safari does. I didn't change permissions, so something changed at KGW.com. I (try to) ask them.

It worked with V68 a week ago. Today with V69 it does not, but Safari does. I didn't change permissions, so something changed at KGW.com. I (try to) ask them.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.