Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Why won't Firefox COMPLETELY block video autoplay?

  • 41 Antworten
  • 5 haben dieses Problem
  • 1550 Aufrufe
  • Letzte Antwort von gumby_dammit223

more options

After following all the suggestions found by searching video autoplay, Firefox currently still autoplays videos with the sound muted. This is in websites other than those like YouTube, such as news websites and the like. What I REALLY want is to COMPLETELY PREVENT automatic playback of any of these videos, and if necessary, whitelist domains like YouTube to allow autoplay. Is this even feasible?

Ausgewählte Lösung

I am running Firefox 68.0.2 64-bit on a Win7 Pro 64-bit system. Webroot SecureAnywhere v9.0.26.61 is my antivirus. uBlock Origin is the ad blocker addon in operation.

If I go to the Bloomberg URL I provided, I see stock ticker data for a French company AND a video is playing. With sound muted. My complaint is that the video is playing. I would prefer it to be paused until I unpause it.

I get that the current version of Firefox will not prevent the playing of muted video on its own. It is not how I would have designed it, but it is what it is. If any Mozilla developers are watching this thread, please file this as a request for a future revision: Do not allow non-whitelisted websites (or domains) from playing video, muted or otherwise, without authorization.

Thank you.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (20)

more options

have you ever tried to update the Firefox browser to the latest version?

more options

i do need more information .

more options

sorry i am not really understanding what your problem is i am sorry.

more options
more options

here is a helpful link

more options

Ausgewählte Lösung

I am running Firefox 68.0.2 64-bit on a Win7 Pro 64-bit system. Webroot SecureAnywhere v9.0.26.61 is my antivirus. uBlock Origin is the ad blocker addon in operation.

If I go to the Bloomberg URL I provided, I see stock ticker data for a French company AND a video is playing. With sound muted. My complaint is that the video is playing. I would prefer it to be paused until I unpause it.

I get that the current version of Firefox will not prevent the playing of muted video on its own. It is not how I would have designed it, but it is what it is. If any Mozilla developers are watching this thread, please file this as a request for a future revision: Do not allow non-whitelisted websites (or domains) from playing video, muted or otherwise, without authorization.

Thank you.

more options

if you enter your ublock origin in the addon settings do you see play videos automatically? if you do see that turn it off.

more options

it may have been because of that.

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

more options

September 4, 2019

I was not able to block videos from automatically playing on the ESPN website.

Operating system = Windows 7 - 64 bit Firefox web browser version 69 is installed and the Autoplay feature was set to Block Audio and Video.

I closed Firefox and restarted my system. I made sure the Block Audio and Video selection was still enabled.

I went to the ESPN website, selected MLB from the pull down menu and selected SCORES. From there I picked any game that was played and selected BOX SCORE. The summary page for that game displayed on the web page and the small autoplay video screen to the right began to play (without sound).

I noticed that if I selected the "circle I" from the address bar and then selected "Clear Cookies and Site Data ..." at the bottom of the pull-down menu, I could clear two cookies (espn.com and www.espn.com) and then the autoplay video screen would be blacked out. But this work-around is required every time I visit the ESPN website, which defeats the purpose of the new video blocking feature of Firefox version 69.

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

more options

How is it possible to block a poster? Look at this thread. This one guy (jaeyoung kim) is wasting gigantic amounts of space because he's posting from a phone, tiny snippets at a time. Typical of phone users. They think in tiny parsed increments. Its like having the attention span of a lightning bolt.

Of course Mozilla gives us no option for this. Beside every user should be the opportunity to block that user.

Geändert am von moz2u

more options

jaeyoung kim said

have you ever tried to update the Firefox browser to the latest version?

jaeyoung kim, your suggestions are so simplistic. Are you 5 years old? How about learning about what you're posting about instead of wasting so much space here and clogging the forum with your useless suggestions? Hint: Spend more time outside and that bloated face will trim down so girls will actually find you interesting and appealing. You're Korean, you have some of the best athletic genetics on the planet. In every field that Koreans focus on they dominate athletically. Its evident everywhere Koreans are in the world. You'll get results very fast if you put in the effort. Its worth it. Its called fast twitch muscle response and both blacks and Koreans are about the best in the world. This ability helps all athletics, not just dancing where they already dominate the world. Learn about pure food, fasting and fitness and you'll be a new person in a few months. Nobody will recognize you. That control over your own body is very empowering. It will spread to all facets of your life. Its exceedingly positive.

more options

First of all, i would like to apologize for all of that useless stuff i put on here. It was my fault for putting that here, but however i am not 5 years old, but please be nice, i dont think you are supposed to say that on here, i am currently taking classes, for school, that is why i decided to help out in this forums, but thank you for your advice on this fourums (i actually did research though but i didnt find anything) (P.s: sorry for this i just started helping out on this forums because i am good with technology i am a first time user who started helping on this forums couple months ago P.s 2 the reason why i posted multiple suggestions sorry about that) (i forget sometimes)

more options

Understood. You take criticism well. Impressive. Few people do! But next time, how about researching first if you're not familiar with the topic (and why would someone comment on something they aren't familiar with unless they are having the same problem?), THEN comment once you find something definite?

The internet is so packed with useless information from people because its so easy to post stuff. So its important to be careful with what we do.

And please don't use a phone to post. Its a terrible tool to work with as the tiny screen size doesn't allow much to be displayed at once. You should frame your thoughts, proofread them, then post them. Not a few words at a time. Surely you have a computer! You mention forgetting about your posts. Think of how easy it would be to review all your posts if you're working with a normal sized screen (24" - 27") that is so affordable today.

Geändert am von moz2u

more options

In the url box type in about:config

Then search for autoplay

Right click on each of the results then click on toggle. You should then see the word [false] in the value column

more options

Not so simple. With 64 bit version 70.0 on my Win7 box, the attached PNG shows my settings. To my meager brain, Firefox has all of its settings configured to prevent what autoplaying it can. However, going to this website

https://www.bloomberg.com/quote/LBIRD:FP

I see streaming video. Audio is muted. After a couple seconds, a popup complains that I have an adblocker enabled. Tough. After 5 seconds, I can make the popup go away. The muted video is still playing.

What I want is for that video frame to sit there, black and quiet, until I decide I want to use my bandwidth to view whatever is there.

To my smooth-surfaced brain, that seems like something that should be feasible. Again, if Firefox simply cannot be configured that way, that's fine. I'd just like to know that. Thank you for taking the time to respond!

more options

@gumby

Here's a wrinkle for you :)

Look at the image I posted

Right click each on those two bold faced lines then click on [Toggle] until you see the word [False] in the value column

BTW & FWIW I don't see any video in the link you posted.

Geändert am von rp2345

more options

VERY interesting! @rp2345 what OS are you running? I'm using my computer at work right now and it's behaving similarly to my home box (Win7 64 but not the exact same flavor as at home).

I set all the autoplay options to false except the "block event" option as shown and the video still plays with the exact same behavior as I described yesterday.

Maybe it's a Win7 thing???

more options

Win7 Pro 64bit

Have you considered moving to Waterfox (branched from FireFox)

  1. 1
  2. 2
  3. 3