X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

tab crash mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead

fs
Veröffentlicht

Hi, my firefox tabs crashe constantly.

The signature is mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead

I reported the crashes https://crash-stats.mozilla.org/report/index/e9960374-a690-4480-a343-8902e0190717

It happens on nearly every page, including most reddit pages, imgur, twitch, basicly everwhere where anyform of media is shown. I've tried the firefox secure start up without any addons...still the tabs crash.

This never happend to me before, I did not change anything about Firefox or my PC in the last couple of days. Firefox is up to date.(well I DID uninstall one add on which has nothing to do with media playback, and which was deactivated anyway).

Can somebody help me out? Thanks in advance.

Hi, my firefox tabs crashe constantly. The signature is mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead I reported the crashes https://crash-stats.mozilla.org/report/index/e9960374-a690-4480-a343-8902e0190717 It happens on nearly every page, including most reddit pages, imgur, twitch, basicly everwhere where anyform of media is shown. I've tried the firefox secure start up without any addons...still the tabs crash. This never happend to me before, I did not change anything about Firefox or my PC in the last couple of days. Firefox is up to date.(well I DID uninstall one add on which has nothing to do with media playback, and which was deactivated anyway). Can somebody help me out? Thanks in advance.

Ausgewählte Lösung

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.

Diese Antwort im Kontext lesen 0
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8579 Lösungen 70147 Antworten
Veröffentlicht

Hi fs, sorry to hear about this problem.

If I understand, you tried Firefox "Safe Mode" (Restart with Add-ons Disabled...) and you had the same problem?

Did it start in Firefox 67, or just after the update to Firefox 68 (since last week)?


Could you disable the new graphics engine called WebRender and see whether that makes any difference? Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webren and pause while the list is filtered

Near the bottom:

(3) If the gfx.webrender.enabled preference is true, double-click it to toggle it to false

(4) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true

Presumably that will take effect after you next exit and restart Firefox.

Any improvement?

Hi fs, sorry to hear about this problem. If I understand, you tried Firefox "Safe Mode" (Restart with Add-ons Disabled...) and you had the same problem? Did it start in Firefox 67, or just after the update to Firefox 68 (since last week)? ---- Could you disable the new graphics engine called WebRender and see whether that makes any difference? Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webren''' and pause while the list is filtered ''Near the bottom:'' (3) If the '''gfx.webrender.enabled''' preference is true, double-click it to toggle it to false (4) Double-click the '''gfx.webrender.force-disabled''' preference to switch the value from false to true Presumably that will take effect after you next exit and restart Firefox. Any improvement?
Hat Ihnen das weitergeholfen?
Zitieren
fs
Veröffentlicht

Fragesteller

Hey, it started yesterday, I used the same PC everday, however I do not know when the updated to 68 happened. If the update happened before 2019-07-17 then the occurrence of the error is not directly correlated to the update, but with some delay.

gfx.webrender.enabled was false.

gfx.webrender.force-disabled was false as well...but if the webrender was not enabled anyway, what will this change?

I will try it anyway as soon as possible.

Hey, it started yesterday, I used the same PC everday, however I do not know when the updated to 68 happened. If the update happened before 2019-07-17 then the occurrence of the error is not directly correlated to the update, but with some delay. gfx.webrender.enabled was false. gfx.webrender.force-disabled was false as well...but if the webrender was not enabled anyway, what will this change? I will try it anyway as soon as possible.
Hat Ihnen das weitergeholfen?
Zitieren
fs
Veröffentlicht

Ausgewählte Lösung

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.