X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Content-Type “video/mp4” is not supported on website, but downloaded video plays fine (Linux/Fedora30)

Ran
Veröffentlicht

I cannot play mp4/h264 videos on websites, but I can download the file and play it in the browser just fine (ffmpeg is installed).

== From twitter web page: error in web console:

For example, on twitter i get a "the media could not be played" placeholder and this in the web console:

HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home

The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2"

== Local file in firefox

When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line:

firefox qFCcMLAnjR_MBans.mp4

== Local html file with control element:

The same file plays fine also when i open a local html file with the vide controls element. So why do I get those errors when this is viewed on the twitter website?

Any pointers appreciated.

Thanks!

I cannot play mp4/h264 videos on websites, but I can download the file and play it in the browser just fine (ffmpeg is installed). == From twitter web page: error in web console: For example, on twitter i get a "the media could not be played" placeholder and this in the web console: <i><b> HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2" </i></b> == Local file in firefox When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line: firefox qFCcMLAnjR_MBans.mp4 == Local html file with control element: The same file plays fine also when i open a local html file with the vide controls element. So why do I get those errors when this is viewed on the twitter website? Any pointers appreciated. Thanks!

Geändert am von Ran

Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Weitere Informationen

hellosct1 13 Lösungen 139 Antworten
Veröffentlicht

Hi,

it is possible to be active and see the HD by following the following link

https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos

Hi, it is possible to be active and see the HD by following the following link https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17267 Lösungen 156057 Antworten
Veröffentlicht

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


gvfs-mime --query video/mp4
Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. *https://www.mozilla.org/en-US/firefox/all/ ---- gvfs-mime --query video/mp4
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.