X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

every time I close the program my history is gone and I make the setting remember my history then I log out from my account then login to sync again

Veröffentlicht

hello every time I close the program my history is gone and I make the setting remember my history then I log out from my account then login to sync again to get my history back and then it has gone again when I close the program reinstall the program same problem make refresh same problem anyone can help me here ?

hello every time I close the program my history is gone and I make the setting remember my history then I log out from my account then login to sync again to get my history back and then it has gone again when I close the program reinstall the program same problem make refresh same problem anyone can help me here ?
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8632 Lösungen 70599 Antworten
Veröffentlicht

When you start Firefox, it has been changed to automatic private browsing? That is set using either:

  • "Firefox will: Never remember history"
  • "Firefox will: Use custom settings for history" + check in the box for "Always use private browsing mode"

I don't know whether an add-on could do that. ?? Could you check these other possibilities (details below):

(1) user.js file (2) Autoconfig file (3) modified Firefox shortcut

user.js

This is an optional settings file that Firefox looks for at startup to override your previous session settings. Open up the Troubleshooting Information page using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Use Find (Ctrl+f) to look for user.js and see whether the page mentions that you have one. In that case, there will be a link to view its contents. The line that might cause this problem would be similar to:

user_pref("browser.privatebrowsing.autostart", true);

If you see that, you can remove the user.js file. There is a section on that in the following article:

How to fix preferences that won't save


Autoconfig file

This is a file that can set initial preference values and/or lock them to specific values. The file naming scheme is flexible, which makes it a bit harder to describe what you're looking for, but here goes:

You'll want to look in your Firefox program folder, which typically is in one of these locations (varies for 32-bit / 64-bit):

  • C:\Program Files\Mozilla Firefox\defaults\pref
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref

Caution: Do not double-click script files! The default action for a script file it to execute as a Windows system script. (Typically this would just not work, but why risk it.)

Make sure Windows is showing hidden files: https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files

A file named channel-prefs.js is normal. Any other file in this folder is suspicious and could be used to pre-set or lock preferences. Remove any such files to a neutral location for further analysis at your leisure. You can rename the file with a .txt extension and examine it for the name of another file that contains the locking code.

More info:


Modified Firefox shortcut

Find the icon you use to start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

Windows should show the Shortcut tab and select the Target field. The Target should be along the following lines:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If yours has a parameters like -private or -private-window go ahead and remove that.


Any progress so far?

When you start Firefox, it has been changed to automatic private browsing? That is set using either: * "Firefox will: Never remember history" * "Firefox will: Use custom settings for history" + check in the box for "Always use private browsing mode" I don't know whether an add-on could do that. ?? Could you check these other possibilities (details below): (1) user.js file (2) Autoconfig file (3) modified Firefox shortcut '''user.js''' This is an optional settings file that Firefox looks for at startup to override your previous session settings. Open up the Troubleshooting Information page using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter Use Find (Ctrl+f) to look for ''user.js'' and see whether the page mentions that you have one. In that case, there will be a link to view its contents. The line that might cause this problem would be similar to: user_pref("browser.privatebrowsing.autostart", true); If you see that, you can remove the user.js file. There is a section on that in the following article: [[How to fix preferences that won't save]] ---- '''Autoconfig file''' This is a file that can set initial preference values and/or lock them to specific values. The file naming scheme is flexible, which makes it a bit harder to describe what you're looking for, but here goes: You'll want to look in your Firefox program folder, which typically is in one of these locations (varies for 32-bit / 64-bit): * C:\Program Files\Mozilla Firefox\defaults\pref * C:\Program Files (x86)\Mozilla Firefox\defaults\pref Caution: ''Do not double-click script files!'' The default action for a script file it to execute as a Windows system script. (Typically this would just not work, but why risk it.) Make sure Windows is showing hidden files: https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files A file named '''channel-prefs.js''' is normal. '''Any other file''' in this folder is suspicious and could be used to pre-set or lock preferences. Remove any such files to a neutral location for further analysis at your leisure. You can rename the file with a .txt extension and examine it for the name of another file that contains the locking code. More info: * [[Customizing Firefox Using AutoConfig]] * http://kb.mozillazine.org/Locking_preferences ---- '''Modified Firefox shortcut''' Find the icon you use to start Firefox, and either: * Right-click a desktop shortcut, then click Properties * Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties Windows should show the Shortcut tab and select the Target field. The Target should be along the following lines: * "C:\Program Files\Mozilla Firefox\firefox.exe" * "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" If yours has a parameters like '''-private''' or '''-private-window''' go ahead and remove that. ---- Any progress so far?
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Thanks for your help

But I do not know what's going on here, nothing works
Thanks for your help But I do not know what's going on here, nothing works
Hat Ihnen das weitergeholfen? 0
Zitieren
FredMcD
  • Top 10 Contributor
4220 Lösungen 58909 Antworten
Veröffentlicht

[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

When done, copy and post the results here.


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

[v57+] Places Maintenance is built into Firefox. Type '''about:support'''<enter> in the address bar. You will find '''Places Database''' near the bottom. Press the '''Verify Integrity''' button. When done, copy and post the results here. ------------- Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8632 Lösungen 70599 Antworten
Veröffentlicht

Hilfreiche Antwort

Okay, it doesn't look like Firefox is set to clear your history. Do you have any external cleaning programs that might touch Firefox data such as Advanced SystemCare or CCleaner? Please don't let external programs delete history.


For many users, Firefox 67 migrated their settings and data to a new profile folder named default-release but in some cases, it glitches.

If you haven't already, could you close out of Firefox and do a normal Windows shutdown and restart to complete any pending updates and release any file locks.

If Firefox again starts up without your data, could you check whether your stuff is available in a different profile, as follows:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Do you have another profile named default or default-longnumber listed on this page? If so, you can check whether it is the one you were using recently by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

Anything new there?

Okay, it doesn't look like Firefox is set to clear your history. Do you have any external cleaning programs that might touch Firefox data such as Advanced SystemCare or CCleaner? Please don't let external programs delete history. ---- For many users, Firefox 67 migrated their settings and data to a new profile folder named '''default-release''' but in some cases, it glitches. If you haven't already, could you close out of Firefox and do a normal Windows shutdown and restart to complete any pending updates and release any file locks. If Firefox again starts up without your data, could you check whether your stuff is available in a different profile, as follows: '''Profile Manager Page''' Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!) The profile that Firefox is currently using will have this: '''This is the profile in use and it cannot be deleted.''' Do you have another profile named '''default''' or default-''longnumber'' listed on this page? If so, you can check whether it is the one you were using recently by clicking its '''Launch profile in new browser''' button. If it isn't what you want, simply close that new window. If it IS what you want, back on the about:profiles page, click the '''Set as default profile''' button for that profile so Firefox uses it automatically at the next startup. Anything new there?
Hat Ihnen das weitergeholfen? 2
Zitieren

Fragesteller

+ Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 0 records + Table moz_annos has 0 records + Table moz_items_annos has 0 records + Table moz_meta has 7 records + Table sqlite_stat1 has 15 records + Index sqlite_autoindex_moz_origins_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_places_originidindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI

+ Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 0 records + Table moz_annos has 0 records + Table moz_items_annos has 0 records + Table moz_meta has 7 records + Table sqlite_stat1 has 15 records + Index sqlite_autoindex_moz_origins_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_places_originidindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

i have Advanced SystemCare but i dont let it to delete any history but now i remove it to see if the problem from it or no i will restart my pc to see if it work or no about the sec Solution i dont have another profile

i have Advanced SystemCare but i dont let it to delete any history but now i remove it to see if the problem from it or no i will restart my pc to see if it work or no about the sec Solution i dont have another profile
Hat Ihnen das weitergeholfen?
Zitieren

Hilfreiche Antwort

jscher2000 Thanks again for your help I was skeptical about Advanced SystemCare that he is doing this but i went throw the setting to check if he clear the history but all was good now i remove it and all is good now ty again

jscher2000 Thanks again for your help I was skeptical about Advanced SystemCare that he is doing this but i went throw the setting to check if he clear the history but all was good now i remove it and all is good now ty again
Hat Ihnen das weitergeholfen? 1
Zitieren
jscher2000
  • Top 10 Contributor
8632 Lösungen 70599 Antworten
Veröffentlicht

Hopefully that was it!

Hopefully that was it!
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.