X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Browser displays hex a in square instead of actual text characters.

Veröffentlicht

After years of stable operation this behavior began after an OS system update enabled me to update Firefox to 64.0.xx. I've tried both Refresh Firefox, and trashing prefs.js, without success. All social sites affected, Feedly, and others.

Noted: Firefox (preferred browser) is now the application associated with all html, json, js, and perhaps other files.

After years of stable operation this behavior began after an OS system update enabled me to update Firefox to 64.0.xx. I've tried both Refresh Firefox, and trashing prefs.js, without success. All social sites affected, Feedly, and others. Noted: Firefox (preferred browser) is now the application associated with all html, json, js, and perhaps other files.
Angefügte Screenshots

Geändert am von swampgrafx

Ausgewählte Lösung

What font is Firefox trying to use?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

Diese Antwort im Kontext lesen 0
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

Weitere Informationen

FredMcD
  • Top 10 Contributor
4248 Lösungen 59433 Antworten
Veröffentlicht

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17483 Lösungen 158000 Antworten
Veröffentlicht

Ausgewählte Lösung

What font is Firefox trying to use?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

What font is Firefox trying to use? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts ---- You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Tried this first, no effect.

''FredMcD [[#answer-1232794|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 </blockquote> Tried this first, no effect.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el said

What font is Firefox trying to use? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

level 3 > 1; two more parameters show as modified. Fixed! Thank you.

''cor-el [[#answer-1232805|said]]'' <blockquote> What font is Firefox trying to use? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts ---- You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels </blockquote> level 3 > 1; two more parameters show as modified. Fixed! Thank you.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17483 Lösungen 158000 Antworten
Veröffentlicht

Do you know what font Firefox couldn't access and that made Firefox fallback to a last resort font ('A')?

The Font tab in the Inspector should show this. This usually happens when Fonts are installed by third-party font managers.

Do you know what font Firefox couldn't access and that made Firefox fallback to a last resort font ('A')? The Font tab in the Inspector should show this. This usually happens when Fonts are installed by third-party font managers.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el said

Do you know what font Firefox couldn't access and that made Firefox fallback to a last resort font ('A')? The Font tab in the Inspector should show this. This usually happens when Fonts are installed by third-party font managers.

Helvetica Neue, which seems strange because that's pretty much universal. It looked like it might have broken the CSS. I use FontExplorer Pro and it may have coincided with the first time I launched the app after system update - I have two versions of Hel Neue, should probably prune.

''cor-el [[#answer-1232825|said]]'' <blockquote> Do you know what font Firefox couldn't access and that made Firefox fallback to a last resort font ('A')? The Font tab in the Inspector should show this. This usually happens when Fonts are installed by third-party font managers. </blockquote> Helvetica Neue, which seems strange because that's pretty much universal. It looked like it might have broken the CSS. I use FontExplorer Pro and it may have coincided with the first time I launched the app after system update - I have two versions of Hel Neue, should probably prune.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.