X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Stop autoplay of videos, not just the audio portion

Veröffentlicht

I was pleased when a recent release of Firefox promised to block autoplay by default, but it turns out that it merely blocks the sound of videos. When I go to the websites of, say, the NY TImes or Washington Post, annoying videos are running, using up bandwidth. I can't find any setting within Firefox -- or any add-on -- that succeeds in turning these off. A silent video is better than a noisy one, but why can't we block ALL autoplay?

I was pleased when a recent release of Firefox promised to block autoplay by default, but it turns out that it merely blocks the sound of videos. When I go to the websites of, say, the NY TImes or Washington Post, annoying videos are running, using up bandwidth. I can't find any setting within Firefox -- or any add-on -- that succeeds in turning these off. A silent video is better than a noisy one, but why can't we block ALL autoplay?
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4274 Lösungen 59943 Antworten
Veröffentlicht

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type media.autoplay.enabled and set it to false.

Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type '''media.autoplay.enabled''' and set it to '''false.'''
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Thanks for the reply. I tried that some time ago; it's been set to false but the videos play on.

Thanks for the reply. I tried that some time ago; it's been set to false but the videos play on.
Hat Ihnen das weitergeholfen? 0
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17591 Lösungen 159130 Antworten
Veröffentlicht

media.autoplay.enable is no longer support and is replaced by media.autoplay.default

  • media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

See also:

  • media.block-autoplay-until-in-foreground
media.autoplay.enable is no longer support and is replaced by media.autoplay.default *media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. See also: *media.block-autoplay-until-in-foreground
Hat Ihnen das weitergeholfen? 0
Zitieren
winnick 0 Lösungen 2 Antworten
Veröffentlicht

This is nuts and I cannot believe that Mozilla cannot give us a straight anser that actually works. Setting media.autoplay.default = 1 does not work.

It is almost as though contrary to the stated aims of Mozilla, and Firefox, they are actually working with advertisers to force me to watch or listen to their ads.

This is a simple question. When I go to a web page I do not want ANY video to start up, nor any sound to play, unless I specifically click on the arrow or otherwise give some affirmative response requesting the video or sound to start. I view any other action as an intrusion into my privacy.

What does it take to get an honest answer?

This is nuts and I cannot believe that Mozilla cannot give us a straight anser that actually works. Setting media.autoplay.default = 1 does not work. It is almost as though contrary to the stated aims of Mozilla, and Firefox, they are actually working with advertisers to force me to watch or listen to their ads. This is a simple question. When I go to a web page I do not want ANY video to start up, nor any sound to play, unless I specifically click on the arrow or otherwise give some affirmative response requesting the video or sound to start. I view any other action as an intrusion into my privacy. What does it take to get an honest answer?
Hat Ihnen das weitergeholfen?
Zitieren
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 Lösungen 1024 Antworten
Veröffentlicht

In Menu -> Options -> Privacy & Security -> Permissions -> Autoplay I have Autoplay set to Block Audio & Video Be sure to select Save Changes or the Value will not change in your config entries. When I visit NY Times or Wash Post, no videos play.


(The relevant config entries are: media.autoplay.default 0 = allow audio & video 1 = block audio 5 = block audio & video)

((Other config entries mentioned here are default))

In Menu -> Options -> Privacy & Security -> Permissions -> Autoplay I have Autoplay set to Block Audio & Video Be sure to select Save Changes or the Value will not change in your config entries. When I visit NY Times or Wash Post, no videos play. (The relevant config entries are: media.autoplay.default 0 = allow audio & video 1 = block audio 5 = block audio & video) ((Other config entries mentioned here are default))
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I've long had Autoplay permission set to Block. This has no effect for me - and, evidently, for others.

I've long had Autoplay permission set to Block. This has no effect for me - and, evidently, for others.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17591 Lösungen 159130 Antworten
Veröffentlicht

Are you using any content blocking extensions that might interfere with the builtin Firefox auto-play feature ?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Are you using any content blocking extensions that might interfere with the builtin Firefox auto-play feature ? Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Hat Ihnen das weitergeholfen?
Zitieren
winnick 0 Lösungen 2 Antworten
Veröffentlicht

Switched to Safe Mode. No difference, videos still play without me doing anything.

Two things occur to me. Is there some code in the site HTML that tells the video to start? Is there some code in Firefox that has it set as a default to start all video? And on that last, for which I try to enter a 1 or 5 code in the appropriate field to no avail, how does that fail?

Let's take Fox News. Their web page opens with pictures, titles and links. When you click a link it opens a page with a picture at the top, an arrow in the center, and an arrow at left lower corner. If you wait, or scroll down to just read the content, after a few seconds you will hear sound and if you scroll back up you will see either that video, or an ad running.

Switched to Safe Mode. No difference, videos still play without me doing anything. Two things occur to me. Is there some code in the site HTML that tells the video to start? Is there some code in Firefox that has it set as a default to start all video? And on that last, for which I try to enter a 1 or 5 code in the appropriate field to no avail, how does that fail? Let's take Fox News. Their web page opens with pictures, titles and links. When you click a link it opens a page with a picture at the top, an arrow in the center, and an arrow at left lower corner. If you wait, or scroll down to just read the content, after a few seconds you will hear sound and if you scroll back up you will see either that video, or an ad running.
Hat Ihnen das weitergeholfen?
Zitieren
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 Lösungen 1024 Antworten
Veröffentlicht

Try a "Test Profile" This is the easiest way to eliminate extensions and tell if you need to do a Refresh.

Type (or paste) about:profiles in the address bar and press Enter. You will see at least one Profile which says: Profile: Default User - This is the profile in use and it cannot be deleted. That is the Profile with all of your data. Just above that, click Create a New Profile. A Profile Wizard will open. Go through the steps naming the Profile anything that you want, except Default User, of course. Below the new profile click Launch Profile In New Browser.

In the first window, under Profile: Default User, select Set As Default Profile. When you launch Firefox again, it will open your Default Profile. Close that window.

(The New Profile won't interfere with anything or use any resources. You can leave it if you ever want to Test something again, or, you can Remove it later.)

Only change Menu -> Options -> Privacy & Security -> Permissions -> Autoplay to Block Audio & Video select Save Changes Close your Options tab Navigate to a website and check that Audio & Video is being blocked.

Try a "Test Profile" This is the easiest way to eliminate extensions and tell if you need to do a Refresh. Type (or paste) about:profiles in the address bar and press Enter. You will see at least one Profile which says: Profile: Default User - This is the profile in use and it cannot be deleted. That is the Profile with all of your data. Just above that, click Create a New Profile. A Profile Wizard will open. Go through the steps naming the Profile anything that you want, except Default User, of course. Below the new profile click Launch Profile In New Browser. In the first window, under Profile: Default User, select Set As Default Profile. When you launch Firefox again, it will open your Default Profile. Close that window. (The New Profile won't interfere with anything or use any resources. You can leave it if you ever want to Test something again, or, you can Remove it later.) '''Only''' change Menu -> Options -> Privacy & Security -> Permissions -> Autoplay to Block Audio & Video select Save Changes Close your Options tab Navigate to a website and check that Audio & Video is being blocked.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.