X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Having trouble undoing autoplay block

Veröffentlicht

So, I DON'T want Firefox to block autoplaying of videos, as I like to put on Youtube playlists and work and it isn't feasible for me to rush over to my laptop and click every time the video changes.

I have the latest versions of Firefox (67.0.4).

I have gone to Options, Privacy & Security, and unchecked the box next to "Block websites from automatically playing sound". This did nothing. It still blocks Youtube videos from playing until I click on the video window.

I also went to the about:config page. All the settings there seem to be the opposite of what other users have used to disable autoplay (since I want to enable it). Pic attached to show which settings I have been looking at.

I have also gone to the exceptions page and added Youtube as an exception. Firefox still is not allowing autoplay (with and without the "Block websites..." box checked).

Does someone know of something I am missing? This only occurred after the 66 update, and I've been trying to undo it as it is becoming very annoying for me.

I have tested the same videos on Chrome and Edge (neither of which I prefer to use, hence trying to fix Firefox), and they play right away with no problems.

I will state that some videos do play automatically, but it is not often and is very sporadic.

So, I DON'T want Firefox to block autoplaying of videos, as I like to put on Youtube playlists and work and it isn't feasible for me to rush over to my laptop and click every time the video changes. I have the latest versions of Firefox (67.0.4). I have gone to Options, Privacy & Security, and unchecked the box next to "Block websites from automatically playing sound". This did nothing. It still blocks Youtube videos from playing until I click on the video window. I also went to the about:config page. All the settings there seem to be the opposite of what other users have used to disable autoplay (since I want to enable it). Pic attached to show which settings I have been looking at. I have also gone to the exceptions page and added Youtube as an exception. Firefox still is not allowing autoplay (with and without the "Block websites..." box checked). Does someone know of something I am missing? This only occurred after the 66 update, and I've been trying to undo it as it is becoming very annoying for me. I have tested the same videos on Chrome and Edge (neither of which I prefer to use, hence trying to fix Firefox), and they play right away with no problems. I will state that some videos do play automatically, but it is not often and is very sporadic.
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

Fragesteller

McCoy said

If it still doesn't work the way you want it to, you could try this on the "about:config" page : Type in the search bar foreground Look for the preference : media.block-autoplay-until-in-foreground and see if setting the value to false will work for you If not : change it back to the default (don't forget to close and restart Firefox)

Tried that too. Didn’t seem to effect anything.

Having some of the videos working is better than none, so thank you. Hopefully they will fix this issue in future updates.

''McCoy [[#answer-1231927|said]]'' <blockquote> If it still doesn't work the way you want it to, you could try this on the "about:config" page : Type in the search bar '''foreground''' Look for the preference : '''media.block-autoplay-until-in-foreground''' and see if setting the value to '''false''' will work for you If not : change it back to the default (don't forget to close and restart Firefox) </blockquote> Tried that too. Didn’t seem to effect anything. Having some of the videos working is better than none, so thank you. Hopefully they will fix this issue in future updates.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17413 Lösungen 157294 Antworten
Veröffentlicht

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

cor-el said

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

This does not solve the issue at all. Same problems. Over half the videos I go to on Youtube do not autoplay. Playlists seem to play once I have watched the first video, but again, the first video does NOT autoplay.

Chrome autoplays and Edge autoplays. Firefox does not, despite all the options being set to autoplay.

''cor-el [[#answer-1231939|said]]'' <blockquote> You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile </blockquote> This does not solve the issue at all. Same problems. Over half the videos I go to on Youtube do not autoplay. Playlists seem to play once I have watched the first video, but again, the first video does NOT autoplay. Chrome autoplays and Edge autoplays. Firefox does not, despite all the options being set to autoplay.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.