Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can not access my Hotmail email on Firefox

  • 14 Antworten
  • 1 hat dieses Problem
  • 123 Aufrufe
  • Letzte Antwort von chzuck

more options

I cannot access my Hotmail email account on Firefox. I can access the account on Edge. Firefox is becoming problematic lately with strange things happening. I cannot access some features on my bank website with Firefox but can with Edge. I don't like Edge but may be forced to use it if I cannot access necessary things on Firefox.

Ausgewählte Lösung

I tried that several times with same results in Firefox. Although I can now get my Hotmail webmail, when I try to go from Hotmail to another site I get the Hotmail sign in page once or twice before I can go where I want. It is not just on one PC either. Firefox is nuts on my laptop as well. Is there a wide spread issue? My Google calendar works as it should now so maybe that was their problem. It is so frustrating!

UPDATE: It appears as though Firefox's recommendation of Ghostery ad block was causing all of my grief. I was sure I tried Firefox safe start and had the same results, but safe start should have kept Ghostery from starting. Anyway I turned Ghostery on and off to verify and Ghostery does cause my problem.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (14)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Hello chzuck,

Just in case the above doesn't fix the problem; would you please check your settings here :

3-bar menu (or Tools) => Options => Privacy & Security => Content Blocking

See : https://support.mozilla.org/en-US/kb/content-blocking

more options

Something in Firefox is causing problems with it being able to access my Hotmail email account. This has been and off and on again problem for the last week or two. I have Cyberfox installed and no problems there. No problems with Edge either. I tried clearing cache and resetting Firefox and neither one helped the problem.

more options

Hi chzuck, could you walk me through where the problem starts with your Hotmail account?

Let's start here:

https://outlook.live.com/mail/inbox

That should redirect to the login page if you aren't already logged in to your Hotmail account. Is that working normally?

Are you able to log in?

Does the site redirect back to your inbox as expected?

Any error messages?

more options
more options

Sounds like the redirect is failing. Please make sure the redirect block is turned off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false


You also could try the original address again: https://outlook.live.com/mail/inbox

If the login isn't working across the two different live.com domains, there might be a problem with too strict cookie settings. This article describes how to loosen those if needed: Websites say cookies are blocked - Unblock them.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

jscher2000 said

Sounds like the redirect is failing. Please make sure the redirect block is turned off: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste access and pause while the list is filtered (3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

You also could try the original address again: https://outlook.live.com/mail/inbox

If the login isn't working across the two different live.com domains, there might be a problem with too strict cookie settings. This article describes how to loosen those if needed: Websites say cookies are blocked - Unblock them.

This was set to false. And now for no reason at all I can now access my Hotmail, for now.

more options

jscher2000 said

Sounds like the redirect is failing. Please make sure the redirect block is turned off: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste access and pause while the list is filtered (3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

You also could try the original address again: https://outlook.live.com/mail/inbox

If the login isn't working across the two different live.com domains, there might be a problem with too strict cookie settings. This article describes how to loosen those if needed: Websites say cookies are blocked - Unblock them.

cor-el said

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.
  • click the shield icon for more details and possibly disable the protection
You can check the Web Console about what content is blocked

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

I will keep this info handy for the next time I have this access issue. Thanks.

more options

Now Google calendar does not load completely. I am ready to dump Firefox. IT IS SCREWED UP BIGTIME!

more options

Did you test in Firefox's Safe Mode (see one of the earlier posts about that)?

more options

Ausgewählte Lösung

I tried that several times with same results in Firefox. Although I can now get my Hotmail webmail, when I try to go from Hotmail to another site I get the Hotmail sign in page once or twice before I can go where I want. It is not just on one PC either. Firefox is nuts on my laptop as well. Is there a wide spread issue? My Google calendar works as it should now so maybe that was their problem. It is so frustrating!

UPDATE: It appears as though Firefox's recommendation of Ghostery ad block was causing all of my grief. I was sure I tried Firefox safe start and had the same results, but safe start should have kept Ghostery from starting. Anyway I turned Ghostery on and off to verify and Ghostery does cause my problem.

Geändert am von chzuck

more options

Hi chzuck, thank you for the update.

If you decide to try a different ad blocker or tracking blocker, keep in mind that any content blocking extension will break sites from time to time. Each should provide a toolbar button to manage what is blocked when a page isn't loading correctly.

more options

My AdBlock Plus was working fine, never should have tried Ghostery even thought it was recommended by Firefox. Keep with what has worked.