Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Favicon icons seem scrambled

  • 4 Antworten
  • 4 haben dieses Problem
  • 808 Aufrufe
  • Letzte Antwort von nroose

more options

This week, after Firefox updated, I noticed that the icons for sites seem to be randomly scrambled in my bookmarks and on my new tab" screen.

For example, Facebook link on my browser bar shows the icon for Gmail. My Gmail link on the menu bar has no favicon any more and the gmail link on the blank tab page, is actually tie YouTube favicon.

Any way to re-read the sites as I visit them and have it correct itself?

Ausgewählte Lösung

Could be a problem with the favicons.sqlite in the profile folder that stores favicons.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair the favicon database then try to remove favicons.sqlite in the profile folder with Firefox closed. You need to visit (click) a bookmark to make Firefox retrieve the favicon. If this didn't help then rename/remove places.sqlite as well. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

See also:

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (4)

more options

Ausgewählte Lösung

Could be a problem with the favicons.sqlite in the profile folder that stores favicons.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair the favicon database then try to remove favicons.sqlite in the profile folder with Firefox closed. You need to visit (click) a bookmark to make Firefox retrieve the favicon. If this didn't help then rename/remove places.sqlite as well. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

See also:

more options

In order - I tried clicking the "Verify Integrity" button - and no fix. Next - I renamed the favicons.splite file - (I renamed to OLD.favicons.splite ) that seems to have fixed things. As I go back to sites in my menus - it recaptures the current favicon files from the sites and displays correctly, now.

Thank you!

more options

I had a similar problem but less global than RexSmith70's. I had just two wrong favicons, for Google Docs and Google Drive. Verify Integrity didn't do anything, but deleting favicons.sqlite fixed the problem. Thanks, cor-el.

more options

Yeah. I had this problem for a long time. I ran some queries on the sqlite tables, and tried the suggestion in other places to delete specific or all of the favicon rows before finally just removing the file. To me it looked like the ids in the tables before I deleted the file were just too high for them to work. One of them was 47,357,795,150,914. Seems like that is 10x the limit for unsigned 16 bit integer. Another column had numbers like 4,176,269,289, which is very close to that unsigned 16 bit max as well. So perhaps some part of the code that uses them are munging that number and getting the wrong icon. I have no idea how they got that high. This is definitely a bug in Firefox. Please fix it.