X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Accounts Page Stretched To Full Width

Veröffentlicht

I am using FF 67.0.1 x64 on Windows 10 1903 x64, both are fresh installs. When I visit the accounts.firefox page it displays stretched to full width. I restarted with add-ons disabled, but it still displayed the same. If I remember correctly, it looked normal in "safe-mode".

Anyone else experience this and have an idea as to why all of a sudden this is happening?

I am using FF 67.0.1 x64 on Windows 10 1903 x64, both are fresh installs. When I visit the accounts.firefox page it displays stretched to full width. I restarted with add-ons disabled, but it still displayed the same. If I remember correctly, it looked normal in "safe-mode". Anyone else experience this and have an idea as to why all of a sudden this is happening?
Angefügte Screenshots
Zitieren

Mehr Details zum System

Installierte Plugins

Bitwarden, AdGuard, DDG Privacy Essentials, HTTPS Everywhere, and Decentraleyes

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4120 Lösungen 57526 Antworten
Veröffentlicht

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above file. Then rename or delete it. Restart Firefox.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

duplicate reply... see below

duplicate reply... see below

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I have done what you suggested and here are the results:

1st attempt: deleted file and started FF. Bookmarks toolbar wasn’t showing so I displayed it. Opened the accounts screen and it was still stretched.

2nd attempt: deleted file again and started FF. Bookmarks bar was missing like before, but I went to the accounts screen FIRST and it was centered and how it should be. I then displayed the bookmarks toolbar and the accounts screen stretched back out to full width.

So it appears it’s something to do with the bookmarks toolbar. If I turn the toolbar on/off, the accounts page goes from normal to stretched.

I have made no changes to FF besides the mentioned add-ons, so I am not sure if this is something I’ve done or something 67.0.1 has done.

I have done what you suggested and here are the results: 1st attempt: deleted file and started FF. Bookmarks toolbar wasn’t showing so I displayed it. Opened the accounts screen and it was still stretched. 2nd attempt: deleted file again and started FF. Bookmarks bar was missing like before, but I went to the accounts screen FIRST and it was centered and how it should be. I then displayed the bookmarks toolbar and the accounts screen stretched back out to full width. So it appears it’s something to do with the bookmarks toolbar. If I turn the toolbar on/off, the accounts page goes from normal to stretched. I have made no changes to FF besides the mentioned add-ons, so I am not sure if this is something I’ve done or something 67.0.1 has done.

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren
FredMcD
  • Top 10 Contributor
4120 Lösungen 57526 Antworten
Veröffentlicht

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17186 Lösungen 155327 Antworten
Veröffentlicht

This could be a mobile view of the page that is displayed full screen.

Quote: If I remember correctly, it looked normal in "safe-mode".

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

This could be a mobile view of the page that is displayed full screen. Quote: ''If I remember correctly, it looked normal in "safe-mode".'' If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via one of these: *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit ---- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I was incorrect about it working in safe-mode, I tried too many things at that moment.

So... in safe mode, which disables all add-ons, the accounts page appears normal. When I display the Bookmarks Toolbar, the accounts page goes to full width again. It's like that toolbar strips all html/css from that page.

Another item I tested was the version on Windows. As of now, Windows 1809 and 1903 (both x64) running FF 67.0.1 have the same results when the Bookmarks Toolbar is enabled. It doesn't matter if it's in safe-mode or with add-ons disabled.

Try it yourselves. View the Account Page, and toggle the Bookmarks Toolbar on/off and see if it does the same for you.

I was incorrect about it working in safe-mode, I tried too many things at that moment. So... in safe mode, which disables all add-ons, the accounts page appears normal. When I display the Bookmarks Toolbar, the accounts page goes to full width again. It's like that toolbar strips all html/css from that page. Another item I tested was the version on Windows. As of now, Windows 1809 and 1903 (both x64) running FF 67.0.1 have the same results when the Bookmarks Toolbar is enabled. It doesn't matter if it's in safe-mode or with add-ons disabled. Try it yourselves. View the Account Page, and toggle the Bookmarks Toolbar on/off and see if it does the same for you.

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17186 Lösungen 155327 Antworten
Veröffentlicht

Does it has effect if you change the dimension of the Firefox window or zoom out the page ?

Does it has effect if you change the dimension of the Firefox window or zoom out the page ?
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I just tried making the browser NOT full screen and yes, the accounts page went from normal to stretched.

On a side note: I just wiped my laptop using a USB key with Windows 1903 x64, installed all Windows updates, etc... then installed FF 67.0.2 from the site.

With no Bookmarks Toolbar displayed, it looks correct/centered. With Bookmarks Toolbar displayed, it looks full width.

With and without Bookmarks Toolbar displayed and browser NOT maximized, it looks incorrect... full width.

Being that I freshly wiped my laptop and installed everything as new, it cannot be an %AppData% issue. It must be a FF 67 issue OR possible a Windows 1809/1903 issue OR something within FF Sync. I'm at a loss here.

I just tried making the browser NOT full screen and yes, the accounts page went from normal to stretched. On a side note: I just wiped my laptop using a USB key with Windows 1903 x64, installed all Windows updates, etc... then installed FF 67.0.2 from the site. With no Bookmarks Toolbar displayed, it looks correct/centered. With Bookmarks Toolbar displayed, it looks full width. With and without Bookmarks Toolbar displayed and browser NOT maximized, it looks incorrect... full width. Being that I freshly wiped my laptop and installed everything as new, it cannot be an %AppData% issue. It must be a FF 67 issue OR possible a Windows 1809/1903 issue OR something within FF Sync. I'm at a loss here.

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17186 Lösungen 155327 Antworten
Veröffentlicht

Are you using desktop mode or tablet mode ?

Are you using desktop mode or tablet mode ?
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8433 Lösungen 68786 Antworten
Veröffentlicht

It seems to be a "responsive" layout that keys off the height of the viewport area instead of the width. (Or instead of a combination of height and width.)

Or to put that another way, it's not you, it's the site.


It appears the style sheet switches over from desktop to mobile when the available height is less than 641 pixels.

It seems to be a "responsive" layout that keys off the height of the viewport area instead of the width. (Or instead of a combination of height and width.) Or to put that another way, it's not you, it's the site. ---- ''It appears the style sheet switches over from desktop to mobile when the available height is less than 641 pixels.''

Geändert am von jscher2000

Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I was just thinking the same. I dabbled building websites years back and I'm thinking the min-width/min-height within their responsive layout has a misconfiguration. Displaying the toolbar reduces the height by 40px (give or take), which would change the display into responsive mode. My laptop display is at 1366x768 and the accounts page only looks like it should without a toolbar and the window maximized.

I was just thinking the same. I dabbled building websites years back and I'm thinking the min-width/min-height within their responsive layout has a misconfiguration. Displaying the toolbar reduces the height by 40px (give or take), which would change the display into responsive mode. My laptop display is at 1366x768 and the accounts page only looks like it should without a toolbar and the window maximized.

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Desktop mode, I have tablet mode turned off.

Desktop mode, I have tablet mode turned off.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el said

Are you using desktop mode or tablet mode ?

Desktop mode, I have tablet mode turned off.

''cor-el [[#answer-1229402|said]]'' <blockquote> Are you using desktop mode or tablet mode ? </blockquote> Desktop mode, I have tablet mode turned off.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17186 Lösungen 155327 Antworten
Veröffentlicht

There are lots of @media rules in the style sheet file if I use the Inspector.

  • @media (min-width:521px) and (min-height:641px)

Zooming out the page makes Firefox report a larger window dimensions and thus switch from mobile to desktop mode. Zooming in makes Firefox switch from desktop to mobile mode at some point.

There are lots of @media rules in the style sheet file if I use the Inspector. *@media (min-width:521px) and (min-height:641px) Zooming out the page makes Firefox report a larger window dimensions and thus switch from mobile to desktop mode. Zooming in makes Firefox switch from desktop to mobile mode at some point.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Whatever the case may be, it was a recent change to FF; I'm guessing 67, possibly 67.0.1. I've been using FF since forever and always had the Bookmark toolbar displayed. It's up until now that the account screen looks funky.

I just zoomed out to 90% and that fixed it.

Whatever the case may be, it was a recent change to FF; I'm guessing 67, possibly 67.0.1. I've been using FF since forever and always had the Bookmark toolbar displayed. It's up until now that the account screen looks funky. I just zoomed out to 90% and that fixed it.

Geändert am von dubstir

Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8433 Lösungen 68786 Antworten
Veröffentlicht

I don't think it's a change to Firefox, I think it's a change to that web page. When I test in the ancient 32-bit Firefox 52 ESR, the layout flips at the same point as I shorten the height of the window.

I don't think it's a change to Firefox, I think it's a change to that web page. When I test in the ancient 32-bit Firefox 52 ESR, the layout flips at the same point as I shorten the height of the window.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

That is what I meant, I said FF because I only access that particular page through the FF browser.

That is what I meant, I said FF because I only access that particular page through the FF browser.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.