X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Why does Firefox keep refreshing old tab?

Veröffentlicht

I'm using firefox 67.0.1 It was fine 2-3 ago. Now when i change from tab a to tab b and then back from tab a firefox refreshing its tab it's very annoying when i watch video (youtub*) and checking my email and back to watch the video firefox refreshing it page so the video replayed themselves. I know it's for memory management. but can it be setting to stop??

I'm using firefox 67.0.1 It was fine 2-3 ago. Now when i change from tab a to tab b and then back from tab a firefox refreshing its tab it's very annoying when i watch video (youtub*) and checking my email and back to watch the video firefox refreshing it page so the video replayed themselves. I know it's for memory management. but can it be setting to stop??

Ausgewählte Lösung

Hello espeon88,

This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of :

https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/

If you want to disable this feature :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.unloadOnLowMemory

and set its value to false

Then close and restart Firefox.

Diese Antwort im Kontext lesen 2
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Linux; U; Android 9; en-us; POCOPHONE F1 Build/PKQ1.180729.001) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/61.0.3163.128 Mobile Safari/537.36 XiaoMi/MiuiBrowser/10.7.2-g

Weitere Informationen

Fragesteller

i notice someone has the same problem with me.. bug no one is responding

i notice someone has the same problem with me.. bug no one is responding
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

Ausgewählte Lösung

Hello espeon88,

This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of :

https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/

If you want to disable this feature :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.unloadOnLowMemory

and set its value to false

Then close and restart Firefox.

Hello espeon88, This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ If you want to disable this feature : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.tabs.unloadOnLowMemory''' and set its value to '''false''' Then close and restart Firefox.
Hat Ihnen das weitergeholfen? 2
Zitieren

Fragesteller

McCoy said

Hello espeon88, This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ If you want to disable this feature : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : browser.tabs.unloadOnLowMemory and set its value to false Then close and restart Firefox.

thank you for the solution and fast response

''McCoy [[#answer-1228783|said]]'' <blockquote> Hello espeon88, This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ If you want to disable this feature : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.tabs.unloadOnLowMemory''' and set its value to '''false''' Then close and restart Firefox. </blockquote> thank you for the solution and fast response
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

espeon88 said

thank you for the solution and fast response

My pleasure  !

''espeon88 [[#answer-1228797|said]]'' <blockquote> thank you for the solution and fast response </blockquote> My pleasure !
Hat Ihnen das weitergeholfen?
Zitieren
kitsunekudasai 0 Lösungen 2 Antworten
Veröffentlicht

Hilfreiche Antwort

McCoy said

Hello espeon88, This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ If you want to disable this feature : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : browser.tabs.unloadOnLowMemory and set its value to false Then close and restart Firefox.

Thanks both of you, this solution seems to work. It is indeed true that I have low memory on this little laptop and this new feature isn't exactly helpful.

''McCoy [[#answer-1228783|said]]'' <blockquote> Hello espeon88, This sounds like one of the new features that came with the update to Firefox 67.0, which apparantly you seem to be aware of : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/ If you want to disable this feature : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.tabs.unloadOnLowMemory''' and set its value to '''false''' Then close and restart Firefox. </blockquote> Thanks both of you, this solution seems to work. It is indeed true that I have low memory on this little laptop and this new feature isn't exactly helpful.
Hat Ihnen das weitergeholfen? 1
Zitieren
ZLYman 0 Lösungen 3 Antworten
Veröffentlicht

This solution does not appear to be my issue. I have 32GB memory, and at any given time I have from 10-25 GB free and open. Right now I have 24.5 GB of free memory. AND my problem started at about version 64 and is very random about when a tab goes belly-up. I can close the offending tab and then re-open and solve the issue. For the occasional screw-up, not a big deal. BUT 6 tabs refuse to update after 10 minutes is not acceptable.

AND browser.tabs.unloadOnLowMemory was already set to false due to my large available memory? How much memory can Firefox access and use for the browser?

This solution does not appear to be my issue. I have 32GB memory, and at any given time I have from 10-25 GB free and open. Right now I have 24.5 GB of free memory. AND my problem started at about version 64 and is very random about when a tab goes belly-up. I can close the offending tab and then re-open and solve the issue. For the occasional screw-up, not a big deal. BUT 6 tabs refuse to update after 10 minutes is not acceptable. AND browser.tabs.unloadOnLowMemory was already set to false due to my large available memory? How much memory can Firefox access and use for the browser?
Hat Ihnen das weitergeholfen? 1
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

@ ZLYman :

Maybe it's best that you start your own thread and post a new question :

https://support.mozilla.org/en-US/questions/new/desktop/other

(you'll have to scroll down some)

@ ZLYman : Maybe it's best that you start your own thread and post a new question : https://support.mozilla.org/en-US/questions/new/desktop/other (you'll have to scroll down some)
Hat Ihnen das weitergeholfen?
Zitieren
ZLYman 0 Lösungen 3 Antworten
Veröffentlicht

Okay! I just decided to do just that and when I went back one page, I saw your response.

Okay! I just decided to do just that and when I went back one page, I saw your response.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

ZLYman said

Okay! I just decided to do just that and when I went back one page, I saw your response.

Good for you !

''ZLYman [[#answer-1245764|said]]'' <blockquote> Okay! I just decided to do just that and when I went back one page, I saw your response. </blockquote> Good for you !
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.