X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Autofill no longer available???

Veröffentlicht

My Firefox updated today 6/8/19 and there is no more autofill option for addresses. Where did it go and how do I get it back? I tried to download an add on but that doesn't work either.

My Firefox updated today 6/8/19 and there is no more autofill option for addresses. Where did it go and how do I get it back? I tried to download an add on but that doesn't work either.

Ausgewählte Lösung

Last time I checked, the Form Autofill extension checks that certain data matched up to the U.S. first, and only if that is found true does it enable itself. You can force it on as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste formauto and pause while the list is filtered

(3) Double-click the extensions.formautofill.available preference to display a small dialog and change detect to on and then click OK

Does that work for you?

Diese Antwort im Kontext lesen 1
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Weitere Informationen

WestEnd
  • Top 25 Contributor
60 Lösungen 5379 Antworten
Veröffentlicht

Check the settings during update to be sure they haven't changed back to default.

Check the settings during update to be sure they haven't changed back to default.

Geändert am von WestEnd

Hat Ihnen das weitergeholfen? 0
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

Ausgewählte Lösung

Last time I checked, the Form Autofill extension checks that certain data matched up to the U.S. first, and only if that is found true does it enable itself. You can force it on as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste formauto and pause while the list is filtered

(3) Double-click the extensions.formautofill.available preference to display a small dialog and change detect to on and then click OK

Does that work for you?

[https://support.mozilla.org/questions/1243192#answer-1207652 Last time I checked], the Form Autofill extension checks that certain data matched up to the U.S. first, and only if that is found true does it enable itself. You can ''force'' it on as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''formauto''' and pause while the list is filtered (3) Double-click the '''extensions.formautofill.available''' preference to display a small dialog and change '''detect''' to '''on''' and then click OK Does that work for you?
Hat Ihnen das weitergeholfen? 1
Zitieren
Veröffentlicht

Fragesteller

Thank you, jscher2000 that worked.

Thank you, jscher2000 that worked.
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

I changed the extensions.formautofill.available pref from "detect" to "on", re-opened Preferences, but I still don't see anything that says autofill. I also tried using the search bar at the top and it says:

Search Results: Sorry! There are no results in Preferences for “autofill”.

I searched for "address" as well since it's called address autofill, but I still don't see it. I'm using the latest FF en-US version too, so isn't this pref supposed to be enabled by default?

At the top of the above linked article it says:

Note: The address autofill feature is currently available for en-US Firefox releases, for users located in the US.

After reading your post here I see the discrepancy which I suppose caused it to not be detected. Requested Locales is set to ["en-GB"] , although I bought the laptop in the US, have never left the US, am using the en-US version, and don't see a setting to change it to US.

Thanks

I changed the '''extensions.formautofill.available''' pref from "detect" to "on", re-opened Preferences, but I still don't see anything that says autofill. I also tried using the search bar at the top and it says: ''Search Results: Sorry! There are no results in Preferences for “autofill”.'' I searched for "address" as well since it's called [[Automatically fill in your address on web forms|address autofill]], but I still don't see it. I'm using the latest FF en-US version too, so isn't this pref supposed to be enabled by default? At the top of the above linked article it says: ''Note: The address autofill feature is currently available for en-US Firefox releases, for users located in the US.'' After reading your post [https://support.mozilla.org/questions/1243192#answer-1207652 here] I see the discrepancy which I suppose caused it to not be detected. '''Requested Locales''' is set to ["en-GB"] , although I bought the laptop in the US, have never left the US, am using the en-US version, and don't see a setting to change it to US. Thanks

Geändert am von shape5

Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

Hi shape5, could you check on the Troubleshooting Information page to see whether you find it in the Features table? Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Scroll down past "Application Basics" to "Firefox Features" -- you would normally see this (in an easier-to-read layout):

Name Version ID Firefox Monitor 3.0 fxmonitor@mozilla.org Firefox Screenshots 39.0.0 screenshots@mozilla.org Form Autofill 1.0 formautofill@mozilla.org Web Compat 6.1.0 webcompat@mozilla.org WebCompat Reporter 1.1.0 webcompat-reporter@mozilla.org

Are you missing Form Autofill or any of the others?

Hi shape5, could you check on the Troubleshooting Information page to see whether you find it in the Features table? Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter/Return Scroll down past "Application Basics" to "Firefox Features" -- you would normally see this (in an easier-to-read layout): Name Version ID Firefox Monitor 3.0 fxmonitor@mozilla.org Firefox Screenshots 39.0.0 screenshots@mozilla.org Form Autofill 1.0 formautofill@mozilla.org Web Compat 6.1.0 webcompat@mozilla.org WebCompat Reporter 1.1.0 webcompat-reporter@mozilla.org Are you missing Form Autofill or any of the others?
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

"Form Autofill 1.0" is listed under "Firefox Features", and believe it or not, when I go to the Preferences now and do a search for the same term "autofill" it finally shows up under "Forms and Autofill". However, I just updated to v69.0.1 from v69, I believe. Did this setting require restarting the browser or did it have to do w/ the update?

Also, is it possible to change the Locales setting?

"Form Autofill 1.0" is listed under "Firefox Features", and believe it or not, when I go to the Preferences now and do a search for the same term "autofill" it finally shows up under "Forms and Autofill". However, I just updated to v69.0.1 from v69, I believe. Did this setting require restarting the browser or did it have to do w/ the update? Also, is it possible to change the Locales setting?

Geändert am von shape5

Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

shape5 said

Did this setting require restarting the browser or did it have to do w/ the update?

Restarting might be required after changing the value of the preference in about:config. I haven't tested recently enough to remember.

''shape5 [[#answer-1255355|said]]'' <blockquote> Did this setting require restarting the browser or did it have to do w/ the update? </blockquote> Restarting might be required after changing the value of the preference in about:config. I haven't tested recently enough to remember.
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

Ok. Anyway, many thanks for your help and your original post to this question.

Do you know if it's possible to change the Locales setting shown in about:support?

Ok. Anyway, many thanks for your help and your original post to this question. Do you know if it's possible to change the Locales setting shown in about:support?
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

shape5 said

Do you know if it's possible to change the Locales setting shown in about:support?

Some of the locales are based on the specific version of Firefox you installed. There are built-in language differences.

Some of the locales are based on the Languages settings on the Options page.

I haven't experimented in detail. Which one did you want to change?

''shape5 [[#answer-1255368|said]]'' <blockquote>Do you know if it's possible to change the Locales setting shown in about:support? </blockquote> Some of the locales are based on the specific version of Firefox you installed. There are built-in language differences. Some of the locales are based on the Languages settings on the Options page. I haven't experimented in detail. Which one did you want to change?
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17482 Lösungen 157982 Antworten
Veröffentlicht

Do you have the en-US Firefox version installed?

Maybe check this via the installed dictionaries that you see under Languages if you right-click in a text area like used by this forum.

You can select the language for the user interface via "Options/Preferences -> General -> Language".

  • Choose the languages used to display menus, messages, and notifications from Firefox
Do you have the en-US Firefox version installed? Maybe check this via the installed dictionaries that you see under Languages if you right-click in a text area like used by this forum. You can select the language for the user interface via "Options/Preferences -> General -> Language". *Choose the languages used to display menus, messages, and notifications from Firefox
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

jscher2000 said

I haven't experimented in detail. Which one did you want to change?

Originally, just the Requested Locales, but now after what I discovered below, also the Default Locale if possible.

cor-el said

Do you have the en-US Firefox version installed? You can select the language for the user interface via "Options/Preferences -> General -> Language".

Aha, well, this explains why the Requested Locales was set to en-GB. Under "General -> Language" it was set to English (United Kingdom) rather than (United States). After changing this, it shows both en-US & en-GB for Requested Locales.

I used the Download Now button on the Firefox home page: https://www.mozilla.org/en-US/firefox/mac/ before and I'm in the US. I guess mine is the GB version b/c it says "Default Locale: en-GB" in about:support. Very strange...

update: If I select "Download in another language", it shows: Browser: Firefox, Platform: macOS, Language: English (US) for default options, and I never checked this page before. I went ahead and downloaded it from here and now it shows en-US for Default Locale. I figured this was easier than trying to figure out how to modify it.

''jscher2000 [[#answer-1255381|said]]'' <blockquote> I haven't experimented in detail. Which one did you want to change? </blockquote> Originally, just the Requested Locales, but now after what I discovered below, also the Default Locale if possible. ''cor-el [[#answer-1255431|said]]'' <blockquote> Do you have the en-US Firefox version installed? You can select the language for the user interface via "Options/Preferences -> General -> Language". </blockquote> Aha, well, this explains why the Requested Locales was set to en-GB. Under "General -> Language" it was set to English (United Kingdom) rather than (United States). After changing this, it shows both en-US & en-GB for Requested Locales. I used the Download Now button on the Firefox home page: https://www.mozilla.org/en-US/firefox/mac/ before and I'm in the US. I guess mine is the GB version b/c it says "Default Locale: en-GB" in about:support. Very strange... '''update:''' If I select "Download in another language", it shows: Browser: Firefox, Platform: macOS, Language: English (US) for default options, and I never checked this page before. I went ahead and downloaded it from here and now it shows en-US for Default Locale. I figured this was easier than trying to figure out how to modify it.

Geändert am von shape5

Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

Now that I have the feature enabled with a saved address entered, how do I get it working? I've been on 3 sites that have forms and I've had to fill all of them in manually.

Now that I have the feature enabled with a saved address entered, how do I get it working? I've been on 3 sites that have forms and I've had to fill all of them in manually.
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

shape5 said

Now that I have the feature enabled with a saved address entered, how do I get it working? I've been on 3 sites that have forms and I've had to fill all of them in manually.

Is this still a problem? I find that Firefox often recognizes that a form is asking for name, address, phone type information and shows a drop-down on the field. You don't see that anywhere? There must be some other reason it doesn't fill, but I'm not an expert on how it is supposed to work.

''shape5 [[#answer-1255911|said]]'' <blockquote> Now that I have the feature enabled with a saved address entered, how do I get it working? I've been on 3 sites that have forms and I've had to fill all of them in manually. </blockquote> Is this still a problem? I find that Firefox often recognizes that a form is asking for name, address, phone type information and shows a drop-down on the field. You don't see that anywhere? There must be some other reason it doesn't fill, but I'm not an expert on how it is supposed to work.
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

That's what I figured but I wasn't able to get it to work. From what I've observed, FF remembers individual field entries from forms you've already filled out under Privacy & Security:History:Remember search and form history, but Autofill, which is under Forms & Autofill just above this, is supposed to offer those entries on the first visit.

This is one example where it doesn't work for me, even when revisiting. Does Autofill work for you here? http://support.tenorshare.com/ims/support?site=101

That's what I figured but I wasn't able to get it to work. From what I've observed, FF remembers individual field entries from forms you've already filled out under '''Privacy & Security:History:Remember search and form history''', but Autofill, which is under '''Forms & Autofill''' just above this, is supposed to offer those entries on the first visit. This is one example where it doesn't work for me, even when revisiting. Does Autofill work for you here? http://support.tenorshare.com/ims/support?site=101
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8700 Lösungen 71112 Antworten
Veröffentlicht

shape5 said

This is one example where it doesn't work for me, even when revisiting. Does Autofill work for you here? http://support.tenorshare.com/ims/support?site=101

Address Autofill does not kick in for me on that form.

After a little experimentation, it seems it might be because there isn't an address field. You can test on this page:

https://www.jeffersonscher.com/res/register.html

When I start typing, I get suggestions from saved addresses, but if I pause and delete the address field from the form and try again, then I don't.

Interesting, but doesn't lend itself to an easy workaround.

By the way, I noticed Firefox had accumulated a bunch of jumbled entries, so I streamlined them down to one work and one home address. Not sure if that will help the feature work better, but it should make it more predictable.

''shape5 [[#answer-1257633|said]]'' <blockquote> This is one example where it doesn't work for me, even when revisiting. Does Autofill work for you here? http://support.tenorshare.com/ims/support?site=101 </blockquote> Address Autofill does not kick in for me on that form. After a little experimentation, it seems it might be because there isn't an address field. You can test on this page: https://www.jeffersonscher.com/res/register.html When I start typing, I get suggestions from saved addresses, but if I pause and delete the address field from the form and try again, then I don't. Interesting, but doesn't lend itself to an easy workaround. ''By the way, I noticed Firefox had accumulated a bunch of jumbled entries, so I streamlined them down to one work and one home address. Not sure if that will help the feature work better, but it should make it more predictable.''
Hat Ihnen das weitergeholfen?
Zitieren
shape5 1 Lösungen 28 Antworten
Veröffentlicht

Oh great, thanks for the test form. Yes, it works for me as well at this link. It should work even without an address field though. For ex, this form here: https://www.bondbarchocolate.com/contact has no address field yet Autofill still pops up for me with a drop-down menu which says "Also autofills email", whereas the drop-down I get at your link says "Also autofills address, email". So I think there is another issue that somehow causes the form to be incompatible. And I have only 1 address in my Autofill Saved Addresses thus far, so this shouldn't be a factor on my end.

Oh great, thanks for the test form. Yes, it works for me as well at this link. It should work even without an address field though. For ex, this form here: https://www.bondbarchocolate.com/contact has no address field yet Autofill still pops up for me with a drop-down menu which says "Also autofills email", whereas the drop-down I get at your link says "Also autofills address, email". So I think there is another issue that somehow causes the form to be incompatible. And I have only 1 address in my Autofill Saved Addresses thus far, so this shouldn't be a factor on my end.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.