Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

After opening Firefox my home page opens ok but if I close and re-open Firefox my home page fails to load and only 'new tab' shows.

more options

I am running Firefox 67. At some point after the update I now find that, after PC boot up, Firefox initially loads my home page ok. However, if I close Firefox and re-open it my home page is not opened and only 'New Tab' is shown. This is true for all subseqent repeat attempts in that PC session. I can, at any point in a Firefox session, bring up the home page by selecting a bookmark for that URL. If close down the PC and re-boot then, again, the home page is initally found ok on opening Firefox but lost thereafter if I close and re-open Firefox. I've also had some recent Windows 10 1809 updates (KB4505056 & KB4494441) which may also be factors in this problem.

I am running Firefox 67. At some point after the update I now find that, after PC boot up, Firefox initially loads my home page ok. However, if I close Firefox and re-open it my home page is not opened and only 'New Tab' is shown. This is true for all subseqent repeat attempts in that PC session. I can, at any point in a Firefox session, bring up the home page by selecting a bookmark for that URL. If close down the PC and re-boot then, again, the home page is initally found ok on opening Firefox but lost thereafter if I close and re-open Firefox. I've also had some recent Windows 10 1809 updates (KB4505056 & KB4494441) which may also be factors in this problem.

Geändert am von Daveattavistock

Alle Antworten (8)

more options

Hello Daveattavistock,

Other people are reporting about the homepage not showing at startup as well - slightly different from what's happening in your case, though.

May I ask you a few questions :

  1. When you click on the Home button, does the homepage load as usual ?
  2. Do you happen to have the New Tab page set to show a blank page ?
  3. Very unlikely, but could it be that you (inadvertently) set Firefox to restore the previous session ?
  4. At startup, do you get a completely blank page, or something that looks like your new tab page ?
  5. Do you have any extensions, and if so : would you disable them to see if that will make a difference ?
more options

Is Firefox still using the same profile in both cases if you check this on the about:support and about:profiles pages?

Firefox 67 and later can use a dedicated profile for each of the Firefox update channels and will lock the profile, so it can only be used by Firefox in a specific installation folder. For Release this profile would be a xxxxxxxx.default-release profile.

more options

Hi McCoy,

thanks for your reply.

1. When I click the Home button the home page loads as normal (the homepage URL is still in the settings and hasn't changed or been modified)

2. The New Tab page is set to the Firefox Search default. However, when I initially load Firefox, a New Tab blank screen briefly opens followed by the home Page. If I then close Firefox and re-open it I just get a blank New Tab screen. If I then click on the '+' button I always get the default Firefox search default screen in accordance with my setting.

3. Firefox, 'restore previous session' is not selected.

4. By 'startup' I assume you mean Firefox startup... see answer 2

5. I do not have any extensions.

Regards.

Daveattavistock

more options

Hi Co-rel,

thanks for your reply.

There is only one profile and it is the same in both cases.

Regards,

Daveattavistock

more options

Hi Daveattavistock, there were many bug reports filed in recent days related to custom home pages not loading. Some key factors users and developers have identified are as follows, but there could be other causes that haven't bubbled up:

Custom home page not shown with this combination of settings:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Options > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Options > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If either of those has its default value, the problem does not occur, they need to both be set to cause the problem. Note for anyone testing it: the custom home page may load on the first restart, it stops loading on the second and later restarts.

I think some kind of fix is in development (bug 1554167; dupes: 1554747, 1553239).

more options

Hi jscher 2000,

thanks for your reply.

I have both of the privacy & security settings you list.

This is helpful to know... so I will wait for the fix.

Regards,

Daveattavistock

more options

Hi jscher 2000,

correction... I have the Cookies & Site Data setting but in the History setting I only have'Clear history when Firefox closes' selected.

Regards,

Daveattavistock

more options

Daveattavistock said

I have the Cookies & Site Data setting but in the History setting I only have'Clear history when Firefox closes' selected.

Oh, yes, the other two options that do not have the red box are not involved in this problem, as far as I know.