X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Master password started to pop up everywhere where passwords should be entered

Veröffentlicht

I use the master password. It has always worked well but some day ago it started to pop up everywhere where passwords should be entered, although I am already logged in. It is terribly annoying to have to close windows every time I start the browser that opens my Wordpress blog which I am always logged on to. Thus, it is the same error on all websites I am logged in when I visit them.

- Why did it become so sudden? - How can I change it so that it does not open every time I visit a website I am logged in to?

I use the master password. It has always worked well but some day ago it started to pop up everywhere where passwords should be entered, although I am already logged in. It is terribly annoying to have to close windows every time I start the browser that opens my Wordpress blog which I am always logged on to. Thus, it is the same error on all websites I am logged in when I visit them. - Why did it become so sudden? - How can I change it so that it does not open every time I visit a website I am logged in to?

Ausgewählte Lösung

A possible cause of the MP prompt at startup can be the hotfix extension to add the new intermediate certificate to the Firefox Certificate Manager. If you have this extension listed on the about:studies page then try to remove it when possible.

If you run Firefox 66.0.5 then you no longer need an extension or other workarounds to install the new certificate, so possibly also check the about:addons page for a (hot)fix extension and remove this extension.

Diese Antwort im Kontext lesen 0
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Weitere Informationen

Fragesteller

I have now switched off the master password. It cannot be used anymore for the window to enter the master password has started to appear wherever I surf the net. Every new place I want it has my password, though I am not registered on the website I come to. I am waiting for answers how I solve this problem that arose from nowhere for no reason. I have not made any changes to the web browser at all.

I have now switched off the master password. It cannot be used anymore for the window to enter the master password has started to appear wherever I surf the net. Every new place I want it has my password, though I am not registered on the website I come to. I am waiting for answers how I solve this problem that arose from nowhere for no reason. I have not made any changes to the web browser at all.
Hat Ihnen das weitergeholfen?
Zitieren
My_Cheese_Is_Slippin'
  • Top 10 Contributor
38 Lösungen 429 Antworten
Veröffentlicht

Do you use an ad blocker? I had the same problem begin this morning. Some outdated filters in my ad blocker was causing the problem.

Do you use an ad blocker? I had the same problem begin this morning. Some outdated filters in my ad blocker was causing the problem.
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

No, I do not use any ad blocker. I use: Popup Blocker Ultimate Simple Blocker (blocks inappropriate sites)

I'll try to disable the add-ons.

No, I do not use any ad blocker. I use: Popup Blocker Ultimate Simple Blocker (blocks inappropriate sites) I'll try to disable the add-ons.
Hat Ihnen das weitergeholfen?
Zitieren
FredMcD
  • Top 10 Contributor
4186 Lösungen 58430 Antworten
Veröffentlicht

There is a preference that sets how long the Master Password is unlocked:

http://kb.mozillazine.org/About:config_Entries#Security. Search for; security. ask_for_password and; security.password_lifetime

There is a preference that sets how long the Master Password is unlocked: http://kb.mozillazine.org/About:config_Entries#Security. Search for; '''security. ask_for_password''' and; '''security.password_lifetime'''
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17334 Lösungen 156717 Antworten
Veröffentlicht

The security.password_lifetime pref only works in SeaMonkey and doesn't not (and never has) worked in Firefox (a search in the source only comes with the pref setting). In Firefox you need to cancel a MP prompt (e.g. show passwords) to logout.


Are you using Sync? What security software do you have?

Is the Password Manager working properly? Do you get a MP prompt when you inspect the logins?

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"

You can try to switch on Login debugging and set this pref to true about:config page.

  • signon.debug = true

That will create a log in the Browser Console.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
The security.password_lifetime pref only works in SeaMonkey and doesn't not (and never has) worked in Firefox (a search in the source only comes with the pref setting). In Firefox you need to cancel a MP prompt (e.g. show passwords) to logout. ---- Are you using Sync? What security software do you have? Is the Password Manager working properly? Do you get a MP prompt when you inspect the logins? *Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords" You can try to switch on Login debugging and set this pref to true <b>about:config</b> page. *signon.debug = true That will create a log in the Browser Console. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Browser_Console Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el said

The security.password_lifetime pref only works in SeaMonkey and doesn't not (and never has) worked in Firefox (a search in the source only comes with the pref setting). In Firefox you need to cancel a MP prompt (e.g. show passwords) to logout.

Are you using Sync? What security software do you have?

Is the Password Manager working properly? Do you get a MP prompt when you inspect the logins?

  • Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords"

You can try to switch on Login debugging and set this pref to true about:config page.

  • signon.debug = true

That will create a log in the Browser Console.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

I'll test your ideas. This just started suddenly, I haven't installed anything or changed anything in settings. There was no update when this problem started. I do not use the master password now because it is difficult that it should be opened every time I surf on a page.

''cor-el [[#answer-1222641|said]]'' <blockquote> The security.password_lifetime pref only works in SeaMonkey and doesn't not (and never has) worked in Firefox (a search in the source only comes with the pref setting). In Firefox you need to cancel a MP prompt (e.g. show passwords) to logout. ---- Are you using Sync? What security software do you have? Is the Password Manager working properly? Do you get a MP prompt when you inspect the logins? *Options/Preferences -> Privacy & Security: Logins & Passwords: "Saved Logins" -> "Show Passwords" You can try to switch on Login debugging and set this pref to true <b>about:config</b> page. *signon.debug = true That will create a log in the Browser Console. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Browser_Console Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems </blockquote> I'll test your ideas. This just started suddenly, I haven't installed anything or changed anything in settings. There was no update when this problem started. I do not use the master password now because it is difficult that it should be opened every time I surf on a page.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17334 Lösungen 156717 Antworten
Veröffentlicht

This can possibly also happen with one of the hotfix extensions that are used to add a new intermediate certificate to replace the old expired certificate that is used to sign extension. The MP is required to be able to install this new certificate in the Certificate Manager. You can check the about:studies page and the extensions folder in the profile folder. Once the new certificate is installed, you should no longer need the hotfix extension that installs the new certificate.

You can check in the Certificate Manager whether you have the new intermediate certificate installed. You can find it under the Authorities tab.

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates

Scroll down to see if you can locate this entry:

This can possibly also happen with one of the hotfix extensions that are used to add a new intermediate certificate to replace the old expired certificate that is used to sign extension. The MP is required to be able to install this new certificate in the Certificate Manager. You can check the about:studies page and the extensions folder in the profile folder. Once the new certificate is installed, you should no longer need the hotfix extension that installs the new certificate. You can check in the Certificate Manager whether you have the new intermediate certificate installed. You can find it under the Authorities tab. *Options/Preferences -> Privacy & Security<br>Certificates: View Certificates Scroll down to see if you can locate this entry: *Mozilla Corporation: signingca1.addons.mozilla.org
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

cor-el said

This can possibly also happen with one of the hotfix extensions that are used to add a new intermediate certificate to replace the old expired certificate that is used to sign extension. The MP is required to be able to install this new certificate in the Certificate Manager. You can check the about:studies page and the extensions folder in the profile folder. Once the new certificate is installed, you should no longer need the hotfix extension that installs the new certificate. You can check in the Certificate Manager whether you have the new intermediate certificate installed. You can find it under the Authorities tab.
  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates
Scroll down to see if you can locate this entry:

Yes, it is in the list!

I now remember that I opened (checked) to install a quick fix for add-ons that suddenly stopped working. It is still checked. Before it was not checked.

Could it be the fault?

''cor-el [[#answer-1222855|said]]'' <blockquote> This can possibly also happen with one of the hotfix extensions that are used to add a new intermediate certificate to replace the old expired certificate that is used to sign extension. The MP is required to be able to install this new certificate in the Certificate Manager. You can check the about:studies page and the extensions folder in the profile folder. Once the new certificate is installed, you should no longer need the hotfix extension that installs the new certificate. You can check in the Certificate Manager whether you have the new intermediate certificate installed. You can find it under the Authorities tab. *Options/Preferences -> Privacy & Security<br>Certificates: View Certificates Scroll down to see if you can locate this entry: *Mozilla Corporation: signingca1.addons.mozilla.org </blockquote> Yes, it is in the list! I now remember that I opened (checked) to install a quick fix for add-ons that suddenly stopped working. It is still checked. Before it was not checked. Could it be the fault?

Geändert am von Workmanen

Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17334 Lösungen 156717 Antworten
Veröffentlicht

Ausgewählte Lösung

A possible cause of the MP prompt at startup can be the hotfix extension to add the new intermediate certificate to the Firefox Certificate Manager. If you have this extension listed on the about:studies page then try to remove it when possible.

If you run Firefox 66.0.5 then you no longer need an extension or other workarounds to install the new certificate, so possibly also check the about:addons page for a (hot)fix extension and remove this extension.

A possible cause of the MP prompt at startup can be the hotfix extension to add the new intermediate certificate to the Firefox Certificate Manager. If you have this extension listed on the <b>about:studies</b> page then try to remove it when possible. If you run Firefox 66.0.5 then you no longer need an extension or other workarounds to install the new certificate, so possibly also check the <b>about:addons</b> page for a (hot)fix extension and remove this extension. *https://support.mozilla.org/en-US/kb/update-firefox-latest-version

Geändert am von cor-el

Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I remove...

hotfix-update-xpi-signing-intermediate-bug-v1.0.3-1548973 This is a hotfix that updates an intermediate certificate used for signing add-ons. It is one of the mechanisms used to fix bug 1548973. This is the second release of the hotfix, it is v1.0.3.

...and my problem is solved!!!

THANKS!

I remove... '''''hotfix-update-xpi-signing-intermediate-bug-v1.0.3-1548973''' This is a hotfix that updates an intermediate certificate used for signing add-ons. It is one of the mechanisms used to fix bug 1548973. This is the second release of the hotfix, it is v1.0.3.'' ...and my problem is solved!!! THANKS!

Geändert am von Workmanen

Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.