X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How Do You Enable Java

Veröffentlicht

I am trying to use a website that needs me to enable Java for the website to work. It gives me some firefox directions on how to do it. I just can't figure it out. Can somebody please help me ASAP thank you

I am trying to use a website that needs me to enable Java for the website to work. It gives me some firefox directions on how to do it. I just can't figure it out. Can somebody please help me ASAP thank you
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Weitere Informationen

McCoy
  • Top 10 Contributor
521 Lösungen 4903 Antworten
Veröffentlicht

Hello Trisha801,

If you only need Java on one site, you could use the portable Firefox 52.9.0 ESR, as it will not interfere with your Firefox release version and profile :

https://portableapps.com/apps/internet/firefox-portable-legacy-52

Would that work for you  ?

(Or maybe you could use IE on that site, as it still supports Java)

Hello Trisha801, If you only need Java on one site, you could use the portable Firefox 52.9.0 ESR, as it will not interfere with your Firefox release version and profile : https://portableapps.com/apps/internet/firefox-portable-legacy-52 Would that work for you ? (Or maybe you could use IE on that site, as it still supports Java)
Hat Ihnen das weitergeholfen? 0
Zitieren
jscher2000
  • Top 10 Contributor
8640 Lösungen 70690 Antworten
Veröffentlicht

Hi Trisha801, just a footnote that all versions of Firefox run JavaScript, a built-in scripting language that doesn't rely on the old Java plugin.

If a website says you need to enable JavaScript, this might not indicate a problem with your JavaScript setting -- because then half the web would tell you JavaScript isn't working -- but possibly with content blocking.

Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Hi Trisha801, just a footnote that all versions of Firefox run Java''Script'', a built-in scripting language that doesn't rely on the old Java plugin. If a website says you need to enable JavaScript, this might not indicate a problem with your JavaScript ''setting'' -- because then half the web would tell you JavaScript isn't working -- but possibly with content blocking. Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.
Hat Ihnen das weitergeholfen? 1
Zitieren
James
  • Moderator
1594 Lösungen 11232 Antworten
Veröffentlicht
Also see http://kb.mozillazine.org/JavaScript_is_not_Java
Hat Ihnen das weitergeholfen?
Zitieren
Kenneth LaGrow (Witchdoctor) 0 Lösungen 2 Antworten
Veröffentlicht

I can't log into Google with the update on Firefox. I had no problem with the older version, why was Java discontinued? Now, in order to check my email I have to use Internet Explorer or Microsoft Edge, both sucks.

I can't log into Google with the update on Firefox. I had no problem with the older version, why was Java discontinued? Now, in order to check my email I have to use Internet Explorer or Microsoft Edge, both sucks.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17422 Lösungen 157426 Antworten
Veröffentlicht

Hi Kenneth LaGrow

This is likely not about Java, but about JavaScript like posted above and is in most cases caused by content blocking extensions.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Hi Kenneth LaGrow This is likely not about Java, but about JavaScript like posted above and is in most cases caused by content blocking extensions. If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/content-blocking ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Hat Ihnen das weitergeholfen?
Zitieren
Kenneth LaGrow (Witchdoctor) 0 Lösungen 2 Antworten
Veröffentlicht

I got it working. It wasn't the browser, Gmail wasn't loading properly. I restarted my system and tried again and it went through with no problem. Thank you for the tips though, they may come in handy in the future.

I got it working. It wasn't the browser, Gmail wasn't loading properly. I restarted my system and tried again and it went through with no problem. Thank you for the tips though, they may come in handy in the future.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.