X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Sudden addon signing failure

Veröffentlicht

This morning a significant number of my installed addons failed their signature test. Among these addons were uBlock Origin, Honey, Tampermonkey and Reddit Enhancement Suite. All of these addons are well known, so why have their signature tests failed? Furthermore, I seem completely unable to reinstall these extensions, despite them being available on the addon store.

The real problem is this: Why was this failure instant? This is unacceptable behaviour, a cooldown period needs to be available to allow someone to prepare a solution. I.E - a warning that "x addon does not meet standards and will be disabled in x days". Simply halting those addons and telling the end user after the fact is poor, poor behaviour - and was why I moved from Chrome to Firefox in the first place.

Furthermore, why is no workaround available on the stable channel? I'm astounded that a UX design this poor is a product of Mozilla.

This morning a significant number of my installed addons failed their signature test. Among these addons were uBlock Origin, Honey, Tampermonkey and Reddit Enhancement Suite. All of these addons are well known, so why have their signature tests failed? Furthermore, I seem completely unable to reinstall these extensions, despite them being available on the addon store. The real problem is this: Why was this failure instant? This is unacceptable behaviour, a cooldown period needs to be available to allow someone to prepare a solution. I.E - a warning that "x addon does not meet standards and will be disabled in x days". Simply halting those addons and telling the end user after the fact is poor, poor behaviour - and was why I moved from Chrome to Firefox in the first place. Furthermore, why is no workaround available on the stable channel? I'm astounded that a UX design this poor is a product of Mozilla.

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 27.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17575 Lösungen 158975 Antworten
Veröffentlicht

This is a problem with an expired intermediate certificate that is used to verify signed extensions that causes extensions to get disabled. This is being worked on.

See also:


At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.
  • Bug 1548973 - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

This is a problem with an expired intermediate certificate that is used to verify signed extensions that causes extensions to get disabled. This is being worked on. See also: *https://www.reddit.com/r/mozilla/comments/bkhjms/yes_firefox_has_disabled_many_extensions_no_its/ *https://www.reddit.com/r/firefox/comments/bkfte9/if_you_have_issues_with_your_addons_being_marked/ ---- *https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote><pre>At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.</pre></blockquote> *[https://bugzilla.mozilla.org/show_bug.cgi?id=1548973 Bug 1548973] - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Veröffentlicht

Fragesteller

Oh dear. This really highlights my second point, doesn't it?

Why was this failure instant? This is unacceptable behaviour, a cooldown period needs to be available to allow someone to prepare a solution.
Oh dear. This really highlights my second point, doesn't it? <blockquote> ''Why was this failure instant? This is unacceptable behaviour, a cooldown period needs to be available to allow someone to prepare a solution.'' </blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17575 Lösungen 158975 Antworten
Veröffentlicht
See also: *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
Pj 42 Lösungen 869 Antworten
Veröffentlicht

monr0e said

The Forum shows your Adobe Flash Plug-in is out of date. (Version 27.x.x.xxx)
You're running an older version, which can cause problems and be a Security Risk.
If you don't use it and do not keep it updated, you can Disable or Uninstall it.

Mar 12th, 2019...
Latest Adobe Flash Version (32.0.0.171).
In the FireFox Browser, go to Add-ons > Plug-ins and click on the Shockwave Flash Options to check the Flash version.
Flash seems not to Automatically Update, so you need to keep a regular eye on these for Updates. (Flash Support will end in FireFox at some point down the road.)
You can update Flash from your Anti-Virus Program's 'Software Updater' area (Avast can do this) or on Adobe's Website:

https://helpx.adobe.com/flash-player.html

Upon having an older version, go to step 2 on Adobe's site (the link referenced above) to download the latest version:
Note : UnCheck the boxes for the additional sponsored software that is offered on the download page if you do not want it also installed.


There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, 66.0.4.

Mozilla Blog Post Update:
A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).
There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above.
(May 5, 16:25 EDT)


~Pj

''monr0e [[#question-1258062|said]]'' <blockquote> </blockquote> The Forum shows your Adobe Flash Plug-in is out of date. (Version 27.x.x.xxx)<Br> You're running an older version, which can cause problems and be a '''<U>Security Risk</U>'''. <Br> If you don't use it and do not keep it updated, you can Disable or Uninstall it.<Br> Mar 12th, 2019...<Br> Latest Adobe Flash Version (32.0.0.'''171'''). <Br> In the FireFox Browser, go to '''Add-ons''' > '''Plug-ins''' and click on the '''Shockwave Flash''' Options to check the Flash version.<Br> Flash seems not to Automatically Update, so you need to keep a regular eye on these for Updates. (Flash Support will end in FireFox at some point down the road.) <Br> You can update Flash from your Anti-Virus Program's 'Software Updater' area (Avast can do this) or on Adobe's Website: <Br> https://helpx.adobe.com/flash-player.html<Br> Upon having an older version, go to step 2 on Adobe's site (the link referenced above) to download the latest version:<Br> Note : UnCheck the boxes for the additional sponsored software that is offered on the download page if you do not want it also installed.<Br> <Hr> There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, '''66.0.4'''. <Br> <Br> [https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ Mozilla Blog Post Update]: <Br> <B>A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).<Br> There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above. <Br> (May 5, 16:25 EDT)</B> ~Pj