X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How do I place a line between each inbox entry on Thunderbird 60.6.1 for Mac?

Veröffentlicht

I am new to Thunderbird. I installed it on my Windows 10 PC and there is a blank line between each inbox entry. So far I am unable to figure out how to get Thunderbird 60.6.1 on my iMac (running Mojave 10.14.4) to automatically insert a blank line (i.e. double space) between each inbox entry. I find that the double spacing makes it much easier to review incoming messages.

Thanks

I am new to Thunderbird. I installed it on my Windows 10 PC and there is a blank line between each inbox entry. So far I am unable to figure out how to get Thunderbird 60.6.1 on my iMac (running Mojave 10.14.4) to automatically insert a blank line (i.e. double space) between each inbox entry. I find that the double spacing makes it much easier to review incoming messages. Thanks
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1 Safari/605.1.15

Weitere Informationen

sfhowes
  • Top 10 Contributor
1438 Lösungen 6822 Antworten
Veröffentlicht

Line height of the Threads Pane:

https://support.mozilla.org/en-US/questions/1255915

Line height of the Threads Pane: https://support.mozilla.org/en-US/questions/1255915
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Thank you for the response, but this solution is way beyond my skill level.

It’s interesting to me that on Windows 10, it appears that the default inbox configuration is to place a blank line between each message heading, while on a Mac it’s necessary to go through these complex (at least for me) steps.

Thank you for the response, but this solution is way beyond my skill level. It’s interesting to me that on Windows 10, it appears that the default inbox configuration is to place a blank line between each message heading, while on a Mac it’s necessary to go through these complex (at least for me) steps.
Hat Ihnen das weitergeholfen?
Zitieren
Matt
  • Top 10 Contributor
  • Moderator
3220 Lösungen 22044 Antworten
Veröffentlicht

Try using a theme. Walnut is very popular with MAC users, perhaps it double spaces the lists.

Try using a theme. Walnut is very popular with MAC users, perhaps it double spaces the lists.
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

Thanks Matt - but still no joy.

I've been pursuing the themes and add-ons catalogs, but still haven't come up with anything that solves the problem. My issue is that without double-spacing of each message line, my in-box looks very cluttered.

Seems like there should be a simple solution......

Thanks Matt - but still no joy. I've been pursuing the themes and add-ons catalogs, but still haven't come up with anything that solves the problem. My issue is that without double-spacing of each message line, my in-box looks very cluttered. Seems like there should be a simple solution......
Hat Ihnen das weitergeholfen?
Zitieren
sfhowes
  • Top 10 Contributor
1438 Lösungen 6822 Antworten
Veröffentlicht

WMBrian said

Seems like there should be a simple solution......

The given solution is simple and doesn't pose any risk, as you can always delete the css file to undo its effects. Help/Troubleshooting Information, click Show in Finder to open the profile folder in Finder, then close TB. Create a new folder in the profile named chrome, and in the chrome folder create a new text file. Copy in the few lines cited in the other post and save the text file as userChrome.css. Restart TB and it will display the line height according to your setting.

''WMBrian [[#answer-1215971|said]]'' <blockquote> Seems like there should be a simple solution...... </blockquote> The given solution is simple and doesn't pose any risk, as you can always delete the css file to undo its effects. Help/Troubleshooting Information, click Show in Finder to open the profile folder in Finder, then close TB. Create a new folder in the profile named chrome, and in the chrome folder create a new text file. Copy in the few lines cited in the other post and save the text file as userChrome.css. Restart TB and it will display the line height according to your setting.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Well, I gave it a shot and unfortunately the results were not good. Where my inbox should be is a blank screen and the spinning pinwheel.

When I restart Thunderbird, I briefly see the list of my inbox accounts on the left side, but then the screen goes blank. I do see the “compact folders?”dialog box at the top of the screen - but my response to that doesn’t seem to matter.

This problem(Thunderbird locking up) began, after I inserted the file in the chrome folder. I tried moving Thunderbird to trash and reinstalling it multiple times, but the file that’s causing the problem appears to remain. I did go into Thunderbird profiles and delete the chrome folder which I created in an attempt to double space my inbox.

Thunderbird continues to receive new messages entering my inbox, but I can’t access anything. At the bottom of the screen on the left I see notifications, that Thunderbird is searching my mail account folders, but I can’t access anything. Interestingly, the background color at the margins of the inbox have been changing colors from brown, two green, now to white.

It seems like the culprit, is a file that remains, even After I drag Thunderbird to the trashcan and then reinstall it.

Any thoughts would be appreciated. I am getting to the point where I may just go back to AppleMail, but would really like to get Thunderbird working properly instead.

Thanks

Well, I gave it a shot and unfortunately the results were not good. Where my inbox should be is a blank screen and the spinning pinwheel. When I restart Thunderbird, I briefly see the list of my inbox accounts on the left side, but then the screen goes blank. I do see the “compact folders?”dialog box at the top of the screen - but my response to that doesn’t seem to matter. This problem(Thunderbird locking up) began, after I inserted the file in the chrome folder. I tried moving Thunderbird to trash and reinstalling it multiple times, but the file that’s causing the problem appears to remain. I did go into Thunderbird profiles and delete the chrome folder which I created in an attempt to double space my inbox. Thunderbird continues to receive new messages entering my inbox, but I can’t access anything. At the bottom of the screen on the left I see notifications, that Thunderbird is searching my mail account folders, but I can’t access anything. Interestingly, the background color at the margins of the inbox have been changing colors from brown, two green, now to white. It seems like the culprit, is a file that remains, even After I drag Thunderbird to the trashcan and then reinstall it. Any thoughts would be appreciated. I am getting to the point where I may just go back to AppleMail, but would really like to get Thunderbird working properly instead. Thanks
Hat Ihnen das weitergeholfen?
Zitieren
sfhowes
  • Top 10 Contributor
1438 Lösungen 6822 Antworten
Veröffentlicht

The TB program is stored in a separate location from the profile folder, which holds all user data. Since most issues are caused by errors in the profile, uninstalling and reinstalling the program has no effect. If you deleted the chrome subfolder, returning to the previous state, and you have lockups, there are a number of possible reasons, such as an incompatible antivirus program scanning email, Spotlight Integration (OS X search), corrupted global search indexing, Time Machine interference, incompatible add-ons etc..

A full list of reasons for poor performance, for Mac and Windows, is given here. The list may seem daunting, but in the absence of further details about your experience, I can't point to a specific remedy.

The TB program is stored in a separate location from the profile folder, which holds all user data. Since most issues are caused by errors in the profile, uninstalling and reinstalling the program has no effect. If you deleted the chrome subfolder, returning to the previous state, and you have lockups, there are a number of possible reasons, such as an incompatible antivirus program scanning email, Spotlight Integration (OS X search), corrupted global search indexing, Time Machine interference, incompatible add-ons etc.. A full list of reasons for poor performance, for Mac and Windows, is given [https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems here]. The list may seem daunting, but in the absence of further details about your experience, I can't point to a specific remedy.
Hat Ihnen das weitergeholfen?
Zitieren
Chris Ilias
  • Moderator
350 Lösungen 1924 Antworten
Veröffentlicht

Hi Brian, I have both macOS and Windows 10. I've never heard of a blank line between inbox entries. I think something you have already installed may have added it to your Windows machine.

Would you mind sending us a screenshot of what you're seeing? For instructions, see How do I create a screenshot of my problem?.

Hi Brian, I have both macOS and Windows 10. I've never heard of a blank line between inbox entries. I think something you have already installed may have added it to your Windows machine. Would you mind sending us a screenshot of what you're seeing? For instructions, see [[How do I create a screenshot of my problem?]].
Hat Ihnen das weitergeholfen?
Zitieren
Matt
  • Top 10 Contributor
  • Moderator
3220 Lösungen 22044 Antworten
Veröffentlicht

Chris Ilias said

Hi Brian, I have both macOS and Windows 10. I've never heard of a blank line between inbox entries.

my windows version has what amounts to double spacing.

''Chris Ilias [[#answer-1216603|said]]'' <blockquote> Hi Brian, I have both macOS and Windows 10. I've never heard of a blank line between inbox entries. </blockquote> my windows version has what amounts to double spacing.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Chris, what I'm after is double spacing between inbox entries. Can't send an example of what I'm seeing because TB is not responding.

SF: If it is my Profile that is causing the problem, is there any reason I couldn't delete my profile and Thunderbird and then reinstall Thunderbird - which (I think) would create a new profile? I recognize that I would then be starting from scratch.

Thanks

Chris, what I'm after is double spacing between inbox entries. Can't send an example of what I'm seeing because TB is not responding. SF: If it is my Profile that is causing the problem, is there any reason I couldn't delete my profile and Thunderbird and then reinstall Thunderbird - which (I think) would create a new profile? I recognize that I would then be starting from scratch. Thanks
Hat Ihnen das weitergeholfen?
Zitieren
Chris Ilias
  • Moderator
350 Lösungen 1924 Antworten
Veröffentlicht

As a troubleshooting step, can you test if the problem occurs in a new profile? For instructions on creating a new profile, use the instructions in the article: Using Multiple Profiles

As a troubleshooting step, can you test if the problem occurs in a new profile? For instructions on creating a new profile, use the instructions in the article: [[Using Multiple Profiles]]
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

My profile idea didn't work, so I tried opening TB in safe mode and disabling all themes, add-on and extensions then reopening in normal mode. That worked and I am now back where I was before I screwed things up yesterday - but my inbox is still single spaced. A screenshot of a portion of my inbox is attached.

Thanks

My profile idea didn't work, so I tried opening TB in safe mode and disabling all themes, add-on and extensions then reopening in normal mode. That worked and I am now back where I was before I screwed things up yesterday - but my inbox is still single spaced. A screenshot of a portion of my inbox is attached. Thanks
Hat Ihnen das weitergeholfen?
Zitieren
Chris Ilias
  • Moderator
350 Lösungen 1924 Antworten
Veröffentlicht

Hi Brian, It looks like you have the Theme Font & Size Changer add-on installed, which is probably the culprit.

  1. Go to Tools > Add-ons.
  2. Beside Theme Font & Size Changer, click Remove.
Hi Brian, It looks like you have the Theme Font & Size Changer add-on installed, which is probably the culprit. # Go to '''Tools > Add-ons'''. # Beside ''Theme Font & Size Changer'', click '''Remove'''.
Hat Ihnen das weitergeholfen?
Zitieren
sfhowes
  • Top 10 Contributor
1438 Lösungen 6822 Antworten
Veröffentlicht

I agree, TF&SC is probably incompatible with the userChrome remedy, as it adjusts the font and line height of the Threads Pane, among other features. If you disable or remove TF&SC, you can probably keep the rest of your add-ons, as I don't think there are any others, besides some themes, that affect line height.

I don't have a mac to test, but the userChrome should then work as it does on my W10 setup.

I agree, TF&SC is probably incompatible with the userChrome remedy, as it adjusts the font and line height of the Threads Pane, among other features. If you disable or remove TF&SC, you can probably keep the rest of your add-ons, as I don't think there are any others, besides some themes, that affect line height. I don't have a mac to test, but the userChrome should then work as it does on my W10 setup.
Hat Ihnen das weitergeholfen?
Zitieren
Wayne Mery
  • Moderator
573 Lösungen 5353 Antworten
Veröffentlicht

So the cause is TF&SC ??

So the cause is TF&SC ??
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Hi Wayne. I apologize for not giving an update on things.

I tried removing TF & SC and then instituting the recommended changes but no change. I've resigned myself to a single spaced inbox. If that's my biggest problem then I think I'm in pretty good shape :)

Thanks for your input and assistance.

Hi Wayne. I apologize for not giving an update on things. I tried removing TF & SC and then instituting the recommended changes but no change. I've resigned myself to a single spaced inbox. If that's my biggest problem then I think I'm in pretty good shape :) Thanks for your input and assistance.
Hat Ihnen das weitergeholfen?
Zitieren
Chris Ilias
  • Moderator
350 Lösungen 1924 Antworten
Veröffentlicht

If you'd like, we can arrange a Skype session and troubleshoot this live.

If you'd like, we can arrange a Skype session and troubleshoot this live.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Very kind of you to offer Chris, but for now at least I can live with things the way they are.

Thanks very much.

Brian

Very kind of you to offer Chris, but for now at least I can live with things the way they are. Thanks very much. Brian
Hat Ihnen das weitergeholfen?
Zitieren
Toad-Hall
  • Top 10 Contributor
1711 Lösungen 11426 Antworten
Veröffentlicht

Just in case you did not quite get things right with the userChrome.css....did you do this:

In Thunderbird Help > Troubleshooting Information click on 'Show in Finder'

A new window opens showing contents of your profile name folder.

Exit Thunderbird now.

Create new folder and call it chrome note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder. See image below.

open 'Notepad' or similar text editor.

Copy all the text between lines below and paste it into the Notepad document.


/*
 
* Do not remove the @namespace line -- it's required for correct functioning
 */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

/*
#threadTree treechildren:-moz-tree-row 
{
height: 20pt !important; 
}


Save the document as filename userChrome.css in the chrome folder. Note the spelling all lower case except for the 'C'. Make sure the extension is .css

If the line height needs adjusting you can change the 20pt to eg: 22 or 25, but make sure Thunderbird is closed first and remember to save the file.

see images below as guide. Restart Thunderbird.

If not working, please post an image of your userChrome.css file showing all the contents.

Just in case you did not quite get things right with the userChrome.css....did you do this: In Thunderbird Help > Troubleshooting Information click on 'Show in Finder' A new window opens showing contents of your profile name folder. Exit Thunderbird now. Create new folder and call it '''chrome''' note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder. See image below. open 'Notepad' or similar text editor. Copy all the text between lines below and paste it into the Notepad document. ---------------------------------------------- <pre> /* * Do not remove the @namespace line -- it's required for correct functioning */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* #threadTree treechildren:-moz-tree-row { height: '''20'''pt !important; } </pre> ---------------------------------------- Save the document as filename '''userChrome.css''' in the '''chrome''' folder. Note the spelling all lower case except for the 'C'. Make sure the extension is .css If the line height needs adjusting you can change the 20pt to eg: 22 or 25, but make sure Thunderbird is closed first and remember to save the file. see images below as guide. Restart Thunderbird. If not working, please post an image of your userChrome.css file showing all the contents.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

I think that I've made all the changes correctly - but apparently not. To be really clear, what I'm trying to do is get TB to place a blank line between each inbox entry so that they are easier to read.

Images below.

Thanks for your help.

I think that I've made all the changes correctly - but apparently not. To be really clear, what I'm trying to do is get TB to place a blank line between each inbox entry so that they are easier to read. Images below. Thanks for your help.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.