Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Websockets on localhost stopped working in 66.0

  • 6 Antworten
  • 1 hat dieses Problem
  • 5055 Aufrufe
  • Letzte Antwort von Istoman

more options

After updating to Firefox 66.0 on MacOS 10.13.6 today, websockets on my localhost stopped working.

When using Create React App (version of "react-scripts": "2.1.8" => "webpack-dev-server": "3.1.14" => "sockjs": "0.3.19"), hot reload is broken and I get following error in the console:

`The connection to ws://localhost:3000/sockjs-node/743/khw0phgj/websocket was interrupted while the page was loading.`

When I tried https://www.websocket.org/echo.html, it works fine and no problems with hot reload in Chrome 72.0.

How can I debug and fix this problem please? (when I googled the error message, I got a lot of outdated advice from previous versions of Firefox)

Geändert am von Peter Hozák

Ausgewählte Lösung

No error in 65.0.2 when I downgraded => most likely a bug in Firefox, reported as https://bugzilla.mozilla.org/show_bug.cgi?id=1536843

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (6)

more options

Click the link using Windows 10 and it came up with no progblems and it said also "This Browser Supports WebSocket". So what is the error screenshot saying?

more options

Ausgewählte Lösung

No error in 65.0.2 when I downgraded => most likely a bug in Firefox, reported as https://bugzilla.mozilla.org/show_bug.cgi?id=1536843

Geändert am von Peter Hozák

more options

WestEnd said

So what is the error screenshot saying?

The error message was in my original post - repeating here if it was hard to notice:


The connection to ws://localhost:3000/sockjs-node/743/khw0phgj/websocket was interrupted while the page was loading.

more options

Does toggling this pref on the about:config page make a difference?

  • network.websocket.allowInsecureFromHTTPS
more options

cor-el said

Does toggling this pref on the about:config page make a difference?
  • network.websocket.allowInsecureFromHTTPS

nope

more options

I can second this is happening only since 66.0 and also on a Vue dev server (so this is not a react-scripts thing).