Hilfe durchsuchen

Firefox Developer Edition 66.0b6 completely kills flash?

  • 4 Antworten
  • 1 hat dieses Problem
  • 716 Aufrufe
  • Letzte Antwort von Sadir

more options

I use Firefox Developer Edition as my main browser on a 64bit version of Windows 7 Home Premium. I recently updated the browser to version 66.0b6, and it appears to have completely killed support for Adobe Flash on the browser. I have checked the about:plugins page, and it shows no flash plugin installed. I have also attempted to install Flash multiple times by downloading it from Adobe's website. The installation claims to be completed without issue, but results in no changes in the plugins page, and no working version of Flash. Flash works fine on the other browsers on my system, and worked without issue in previous versions of Firefox. I am aware of security concerns with the Flash plugin, however considering there is a lot of older content on the internet that relies on the technology, completely disabling it with no way for users to manually enable it seems a bit excessive. Is this indeed what Firefox has done, or is there something wrong with my browser?

Thanks for the help.

Ausgewählte Lösung

Flash should still work in Firefox 66 DE.

If Firefox doesn't find the Shockwave Flash plugin then it is possible that the key(s) in the Windows Registry that Firefox scans for plugins is missing.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Ausgewählte Lösung

Flash should still work in Firefox 66 DE.

If Firefox doesn't find the Shockwave Flash plugin then it is possible that the key(s) in the Windows Registry that Firefox scans for plugins is missing.

more options

cor-el said

Flash should still work in Firefox 66 DE. If Firefox doesn't find the Shockwave Flash plugin then it is possible that the key(s) in the Windows Registry that Firefox scans for plugins is missing.

Thanks a lot, you were absolutely right, for some reason the scanning of the registry for plugins in my Firefox had ended up disabled. I have corrected the appropriate value in the about:config settings and it now works correctly.

more options

In FF 69, Flash will not be supported by default. I guess there will be an option to 'turn it back on'.

Meanwhile, this update:

From Adobe, Feb 12th, 2019...

New Flash Update (32.0.0.142): https://get.adobe.com/flashplayer

Announcements:
Mac NPAPI Sandbox - Mozilla Firefox
The Mac NPAPI Flash sandbox is enabled by default on Firefox 62 and later.

Disabling the sandbox requires using about:config to set...

dom.ipc.plugins.sandbox-level.flash to 0

...and then restarting the browser. The sandbox is known to prevent the following features from working:

  • Print to PDF from the Flash print dialog
  • Print to “Open in Preview” from the Flash print dialog
  • Quicklook in the File->Open dialog
  • Saving files to the filesystem from a Flash applet
  • Flash applets downloading and running the Adobe Air installer
  • Flash triggering Adobe Air applications to run


~Pj

more options

Pj said

In FF 69, Flash will not be supported by default. I guess there will be an option to 'turn it back on'. Meanwhile, this update: From Adobe, Feb 12th, 2019...
New Flash Update (32.0.0.142): https://get.adobe.com/flashplayer
Announcements:
Mac NPAPI Sandbox - Mozilla Firefox
The Mac NPAPI Flash sandbox is enabled by default on Firefox 62 and later.

Disabling the sandbox requires using about:config to set...
dom.ipc.plugins.sandbox-level.flash to 0
...and then restarting the browser. The sandbox is known to prevent the following features from working:
  • Print to PDF from the Flash print dialog
  • Print to “Open in Preview” from the Flash print dialog
  • Quicklook in the File->Open dialog
  • Saving files to the filesystem from a Flash applet
  • Flash applets downloading and running the Adobe Air installer
  • Flash triggering Adobe Air applications to run

~Pj

Thanks PJ, I heard about the upcoming decisions in Firefox 69, although that's not an issue I guess as long as you can manually make the decision to enable it. I didn't know about the sandbox application though, and have now disabled it following your advice. Thanks for the tips.