X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Cannot add Exceptions to Content Blocking, any suggestions?

Veröffentlicht

Just a blank/non-editable window appears, where I cannot do or add anything, as in Screenshot attached here, (screenshot not yet loading properly, but the explanation here covers it), any suggestions will be appreciated.

Just a blank/non-editable window appears, where I cannot do or add anything, as in Screenshot attached here, (screenshot not yet loading properly, but the explanation here covers it), any suggestions will be appreciated.

Ausgewählte Lösung

The only way to add an exception is via the Control Center 'i' icon drop-down list when Firefox is showing the Control Center 'i' icon. Via "Content Blocking" on the about:preferences page you can only inspect and remove an exception.


Diese Antwort im Kontext lesen 1

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4230 Lösungen 59038 Antworten
Veröffentlicht

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
FredMcD
  • Top 10 Contributor
4230 Lösungen 59038 Antworten
Veröffentlicht

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
cor-el
  • Top 10 Contributor
  • Moderator
17425 Lösungen 157456 Antworten
Veröffentlicht

Ausgewählte Lösung

The only way to add an exception is via the Control Center 'i' icon drop-down list when Firefox is showing the Control Center 'i' icon. Via "Content Blocking" on the about:preferences page you can only inspect and remove an exception.


The only way to add an exception is via the Control Center 'i' icon drop-down list when Firefox is showing the Control Center 'i' icon. Via "Content Blocking" on the about:preferences page you can only inspect and remove an exception. ---- *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking

Fragesteller

Thank you, that was such a quick fix it makes you feel foolish for not noticing it, but that's okay, fixed is fixed, awesome.

Thank you, that was such a quick fix it makes you feel foolish for not noticing it, but that's okay, fixed is fixed, awesome.

Fragesteller

& Thanks to all, sorry screenshot didn't post, have done a great many, don't know why it wouldn't post here, but the issue has been resolved.

& Thanks to all, sorry screenshot didn't post, have done a great many, don't know why it wouldn't post here, but the issue has been resolved.
miguelk 0 Lösungen 24 Antworten
Veröffentlicht

cor-el said

The only way to add an exception is via the Control Center 'i' icon drop-down list when Firefox is showing the Control Center 'i' icon. Via "Content Blocking" on the about:preferences page you can only inspect and remove an exception.
''cor-el [[#answer-1191773|said]]'' <blockquote> The only way to add an exception is via the Control Center 'i' icon drop-down list when Firefox is showing the Control Center 'i' icon. Via "Content Blocking" on the about:preferences page you can only inspect and remove an exception. ---- *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking </blockquote>
miguelk 0 Lösungen 24 Antworten
Veröffentlicht

Hilfreiche Antwort

Sorry, but this is not working for me. No exception gets added to the list. I tried it in safe mode, but still the same. Please advise. Thank you.

Edit:

I just noticed that "Turn Off Blocking For This Site" dialogue is missing in my stable Firefox along with the respective icon Control Center 'i' icon drop-down list, however, it appears in Nightly, even with all addons enabled, and the exception gets added. I'm using the same profile for both, so this is not the issue.

Seems to be a bug, or it simply hasn't been implemented in the stable versions of FF yet.

Sorry, but this is not working for me. No exception gets added to the list. I tried it in safe mode, but still the same. Please advise. Thank you. Edit: I just noticed that "Turn Off Blocking For This Site" dialogue is missing in my stable Firefox along with the respective icon Control Center 'i' icon drop-down list, however, it appears in Nightly, even with all addons enabled, and the exception gets added. I'm using the same profile for both, so this is not the issue. Seems to be a bug, or it simply hasn't been implemented in the stable versions of FF yet.

Geändert am von miguelk

cor-el
  • Top 10 Contributor
  • Moderator
17425 Lösungen 157456 Antworten
Veröffentlicht

You should always use a separate profile for each Firefox version, especially Nightly and other developer versions (Beta, DE). Profiles used by such unstable alpha and beta versions are not compatible with a release version and you run the risk losing data. Preferences are changed all the time and file format version can also change. Best would be to create a new profile for Firefox release and copy specific personal data to that profile or use Sync.

You should always use a separate profile for each Firefox version, especially Nightly and other developer versions (Beta, DE). Profiles used by such unstable alpha and beta versions are not compatible with a release version and you run the risk losing data. Preferences are changed all the time and file format version can also change. Best would be to create a new profile for Firefox release and copy specific personal data to that profile or use Sync. *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
jell 0 Lösungen 15 Antworten
Veröffentlicht

Hilfreiche Antwort

I agree with Miguel. The solution doesn't work. Adding the exception for the site makes no change. Changing the block settings from standard to strict makes no change. The shield icon doesn't even appear no matter what settings I've changed.

I am simply trying to disable ad blocker to access a news article on the Washington Post. It really shouldn't be this hard.

I agree with Miguel. The solution doesn't work. Adding the exception for the site makes no change. Changing the block settings from standard to strict makes no change. The shield icon doesn't even appear no matter what settings I've changed. I am simply trying to disable ad blocker to access a news article on the Washington Post. It really shouldn't be this hard.
malkintent 0 Lösungen 2 Antworten
Veröffentlicht

There is no option to disable blocking in my version of FF. This has been true for the last 3 versions (now on 68.0 Quantum). See the screen shots - what I actually see, what I'm supposed to see according to the help, and current version.

Thanks, Steve

There is no option to disable blocking in my version of FF. This has been true for the last 3 versions (now on 68.0 Quantum). See the screen shots - what I actually see, what I'm supposed to see according to the help, and current version. Thanks, Steve

Geändert am von malkintent

cor-el
  • Top 10 Contributor
  • Moderator
17425 Lösungen 157456 Antworten
Veröffentlicht

Hi malkintent

If Firefox doesn't show the shield icon then tracking protection isn't blocking content. Blocking (third-party) cookies that is likely what happens in the first screenshot isn't part of Content Blocking, but is about other privacy settings and thus you can't create an exception.

I assume you see the shield icon when you visit this website and can possibly disable Content Blocking?

If the website complains then you may have an extension that blocks content or you otherwise have made changes to Firefox that affects this website. Content Blocking isn't the problem in this case, so you will have to look at other privacy settings (Private Browsing mode can be a problem).

See also:

Hi malkintent If Firefox doesn't show the shield icon then tracking protection isn't blocking content. Blocking (third-party) cookies that is likely what happens in the first screenshot isn't part of Content Blocking, but is about other privacy settings and thus you can't create an exception. I assume you see the shield icon when you visit this website and can possibly disable Content Blocking? If the website complains then you may have an extension that blocks content or you otherwise have made changes to Firefox that affects this website. Content Blocking isn't the problem in this case, so you will have to look at other privacy settings (Private Browsing mode can be a problem). See also: *https://support.mozilla.org/en-US/kb/content-blocking
malkintent 0 Lösungen 2 Antworten
Veröffentlicht

Thank you cor-el! Following your suggestion, I was able to determine that it was the ghostery extension actually doing the blocking and not FF.

Thank you cor-el! Following your suggestion, I was able to determine that it was the ghostery extension actually doing the blocking and not FF.