Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Phone number I have on my website changes to an unrecognized number....

  • 25 Antworten
  • 1 hat dieses Problem
  • 78 Aufrufe
  • Letzte Antwort von jscher2000

more options

When my website is viewed in firefox on a desktop, the phone number I have listed changes to an unrecognizable one. In the website is correct, ie: pages, footer, etc... but when viewed in FF, it changes.

Ausgewählte Lösung

Google Tag Manager might do different things for different people (or should I say, different "anonymous profiles"). I block it.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (20)

more options

Sorry to hear that you are having issues. Are you able to share a link to your website so that we can test it for ourselves?

more options

Thanks Wesley!

The correct phone number is (205) 370-9450 and is located throughout the website.

The phone number it changes to is (205) 216-5781 in it only does it when viewed in FF desktop, not mobile. If you view the same website in Edge, it doesn't change it. I'm not an edge fan at all, but I'm worried it may affect business.

Website is: www.OneCallRoofing.com

more options

No problem here with the phone number, so it sounds this is an issue on your side.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Geändert am von cor-el

more options

Is there a specific page that you are having an issue with?

I've loaded the homepage and the contact page, both of which show the correct phone number (see screenshot).

It could just be that you are viewing an older version of your page that Firefox has loaded from the cache. I'd recommend clearing your cache to see if that helps.

more options

You're looking at an image of the phone number in the header of the website. I'm referring to any area on the website that has the phone number typed in.

more options

I deleted the cache, refreshed and now a new number is showing: 205-216-5781. Very frustrating... If you look at the site on both FF and Edge, scroll down into the webpage, you will see correct phone number ending in 9450 in Edge, but you'll see 5781 in FF....

more options

I'm still getting the correct phone number appearing, including in the spot that you have indicated (see my screenshot). I don't see anything in your code that would cause this type of issue.

Any chance you are able to test it from Firefox on a different computer?

If not, try the following:

  1. Type about:networking in your Firefox address bar
  2. Bypass the security warning (don't worry, I'll be your adult supervision)
  3. Select DNS lookup on the side
  4. Type www.onecallroofing.com in the textbox
  5. Press Resolve
  6. Make note of that IP address that appears
  7. Close Firefox
  8. Press the Windows key + R
  9. Type cmd
  10. Press Ok
  11. Type ipconfig /flushdns (There is a space before the slash)
  12. Open Firefox
  13. Try viewing your website again

If the issue continues, post that IP address on this forum and I will compare it to the IP address that my system accessing.

Basically, the IP address points to the server that has your website on it. But in some cases, your website moves to a different server or it's stored on multiple servers. Perhaps your computer is still trying to access an old copy of your website this way.

more options

Hi Wesley, I did as you instructed (1 - 13 above). Same issue...

This is the IP address that you wanted me to take note of: 23.235.192.46

more options

That's the same as mine, so you are being directed to the correct server.

Did you design this website yourself or did a company do it for you?

more options

We designed it in WordPress

more options

Are you able to test on a different computer using Firefox?

more options

Yes I did and it does not have the same issue... Wow, could that mean its a setting on my machine?

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility

more options

It's possible. It seems unlikely that everyone viewing your website is having this issue, so I don't think it's any harm to your business.

I would recommend checking on the website again in a day or two to see if you are still having issues. Waiting this amount of time will force Firefox to completely redownload your website the next time that you view the website on this computer. This would rule out any issue with Firefox maybe just accessing a saved version of the website.

Just make sure to completely power down your computer before you view the website after waiting for a day or two.

Let us know how it goes.

more options

Thanks Wesley, I really appreciate your time. I will follow your advice...

more options

Just one other thought. When you use View Page Source in Firefox, Firefox should display what was received from the server before it is modified by any add-ons or scripts running in the browser. If you call that up using either:

  • right-click > View Page Source
  • Ctrl+u

and find that part of the page, is the number correct or incorrect in the source file?

If it's correct, an add-on could be the culprit. I can't tell whether you tried the Safe Mode test cor-el mentioned.

If it's already incorrect, the page may be changing between the server and Firefox, for example, through a proxy server or filtering software.

(It's also possible that your WordPress installation is hacked, but usually in that case, the owner of the site doesn't see it, only strangers see it, so it would be the dumbest hacking ever if you're the only one who gets the wrong number.)

more options

So, I just checked View Page Source and the phone # shows correctly:

24 / 7 / 365 EMERGENCY SERVICE!
We serve residential and commercial customers
Call 205-370-9450 for fast, friendly service.

I did try safe mode and it was the same wrong number.

See attached for my plugins to FF

more options

See code snippet from view source

more options

In this case, I'd say that running a scan for malware (as suggested by cor-el above) is probably your best option. It's possible that there is a malicious software or piece of code converting phone numbers into fake or scam phone numbers to direct calls to themselves.

Also, can you show us the Extensions section instead of the Plugins section? Every Firefox user has pretty much the same plugins installed. It's the extensions that often cause issues in Firefox.

more options

See extension in the attached...

  1. 1
  2. 2