X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How do I disable "cast to Roku" in Firefox?

Veröffentlicht

I've been using Firefox Beta on Android for a while now.

Recently my household purchased a Roku, a type of HTPC. While I was watching a video in Firefox Beta, I noticed a new button in the video UI, that said "Cast to <my Roku model>". You can read more about this feature here: https://support.mozilla.org/en-US/kb/use-firefox-android-send-videos-your-roku

How do I disable this functionality? I appreciate Mozilla adding convenient features, but I don't want to be in my room watching a private video, accidentally press this button (it's right next to the other controls), and have my video play on the living room TV where my roommate is sitting.

I've been using Firefox Beta on Android for a while now. Recently my household purchased a Roku, a type of HTPC. While I was watching a video in Firefox Beta, I noticed a new button in the video UI, that said "Cast to <my Roku model>". You can read more about this feature here: https://support.mozilla.org/en-US/kb/use-firefox-android-send-videos-your-roku How do I disable this functionality? I appreciate Mozilla adding convenient features, but I don't want to be in my room watching a private video, accidentally press this button (it's right next to the other controls), and have my video play on the living room TV where my roommate is sitting.

Ausgewählte Lösung

Try to set this pref to false on the about:config page.

  • browser.casting.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Diese Antwort im Kontext lesen 1

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 30.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17422 Lösungen 157414 Antworten
Veröffentlicht

Ausgewählte Lösung

Try to set this pref to false on the about:config page.

  • browser.casting.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set this pref to false on the <b>about:config</b> page. *browser.casting.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
cor-el
  • Top 10 Contributor
  • Moderator
17422 Lösungen 157414 Antworten
Veröffentlicht

The System Details list shows that you have an outdated Flash plugin, current is 32.0.0.101 (32.0 r0).

  • Shockwave Flash 30.0 r0

You can find the installation path of a plugin on the about:plugins page.

You can download the latest NPAPI Flash plugin for Firefox on this page.

Make sure to remove checkmarks for including unwanted additional software.

The System Details list shows that you have an outdated Flash plugin, current is 32.0.0.101 (32.0 r0). *Shockwave Flash 30.0 r0 You can find the installation path of a plugin on the <b>about:plugins</b> page. You can download the latest NPAPI Flash plugin for Firefox on this page. *https://get.adobe.com/flashplayer/otherversions/ Make sure to remove checkmarks for including unwanted additional software.

Fragesteller

cor-el said

Try to set this pref to false on the about:config page.
  • browser.casting.enabled = false

Thank you, that worked.

''cor-el [[#answer-1187022|said]]'' <blockquote> Try to set this pref to false on the <b>about:config</b> page. *browser.casting.enabled = false </blockquote> Thank you, that worked.
als 0 Lösungen 21 Antworten
Veröffentlicht

cor-el said

Try to set this pref to false on the about:config page.
  • browser.casting.enabled = false

Does this flag only exist in FF for Android?

''cor-el [[#answer-1187022|said]]'' <blockquote> Try to set this pref to false on the <b>about:config</b> page. *browser.casting.enabled = false </blockquote> Does this flag only exist in FF for Android?