X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Please make Firefox compatible with Enhanced Dictation

Veröffentlicht

I use the native dictation software for the Mac called Enhanced Dictation which is run locally from my computer. I'm running High Sierra. I need to be able to navigate around the screen using my voice.

The way I normally interact with clickable items on a website, using the Safari browser, is that I say the command "show numbers" and the dictation software maps a number to each clickable item on the webpage. Then I can speak the number and the software will click on that item. However, when I attempted to use the Firefox browser, and spoke the command "show numbers," no numbers appeared. The result is that I cannot navigate Firefox with my voice and thus your browser inaccessible to me. Perhaps Firefox is missing a type of framework for my software to interact with.

I use the native dictation software for the Mac called Enhanced Dictation which is run locally from my computer. I'm running High Sierra. I need to be able to navigate around the screen using my voice. The way I normally interact with clickable items on a website, using the Safari browser, is that I say the command "show numbers" and the dictation software maps a number to each clickable item on the webpage. Then I can speak the number and the software will click on that item. However, when I attempted to use the Firefox browser, and spoke the command "show numbers," no numbers appeared. The result is that I cannot navigate Firefox with my voice and thus your browser inaccessible to me. Perhaps Firefox is missing a type of framework for my software to interact with.

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.1 Safari/605.1.15

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17519 Lösungen 158412 Antworten
Veröffentlicht

This could be an issue caused by multi-process that isolates a window.

You can disable multi-process windows in Firefox 58+ by setting this pref to false on the about:config page to see if that has effect.

  • browser.tabs.remote.autostart = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This could be an issue caused by multi-process that isolates a window. You can disable multi-process windows in Firefox 58+ by setting this pref to false on the <b>about:config</b> page to see if that has effect. *browser.tabs.remote.autostart = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Veröffentlicht

Fragesteller

Hi, thank you for the suggestion

I went into about:config and changed the setting of browser.tabs.remote.autostart to equal false. I rebooted the computer. Nothing has changed.

Hi, thank you for the suggestion I went into about:config and changed the setting of browser.tabs.remote.autostart to equal false. I rebooted the computer. Nothing has changed.
cor-el
  • Top 10 Contributor
  • Moderator
17519 Lösungen 158412 Antworten
Veröffentlicht

If disabling multi-process didn't work then you can reset the browser.tabs.remote.autostart pref to its default value to re-enable the multi-process feature.

Try to disable enhanced dictation, if it is currently enabled. Dictation & Speech pane in System Preferences, select the Dictation tab, and disable dictation. Then enable dictation again. Log out or restart the computer. If dictation now works, you can try enabling enhanced dictation.

If disabling multi-process didn't work then you can reset the browser.tabs.remote.autostart pref to its default value to re-enable the multi-process feature. Try to disable enhanced dictation, if it is currently enabled. Dictation & Speech pane in System Preferences, select the Dictation tab, and disable dictation. Then enable dictation again. Log out or restart the computer. If dictation now works, you can try enabling enhanced dictation.
Veröffentlicht

Fragesteller

Thank you again. Unfortunately, this did not work either.

Thank you again. Unfortunately, this did not work either.
cor-el
  • Top 10 Contributor
  • Moderator
17519 Lösungen 158412 Antworten
Veröffentlicht

Maybe you should take this to a Mac oriented forum as they might know better how his feature works.

Maybe you should take this to a Mac oriented forum as they might know better how his feature works.