X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Unable to use a language pack

Veröffentlicht

Hi

This is with current Firefox 63.0.1. I am using the en-us version and want to to switch the interface to French. For this I:

- added the French language pack addon - following the instructions on this page: https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack

That documentation suggests to set the intl.locale.requested variable on the about:config page. However this configuration key does not exist in FF 63.0.1.

I found what looks like a more suitable key:

intl.multilingual.enabled

After setting this variable to True, I got a new section in FF options (see screenshot). The language selector now shows both English and French as it's supposed to. After selecting French, a message and a button appear:

"Redémarrer Firefox pour appliquer ces changements" or "Restart Firefow to apply those changes".

However the button "Aply and restart" is active but does not do anything when clicked. And restarting FF manually comes back up with English still selected.

So how can I actually use FF in either French or English?

Thanks

Hi This is with current Firefox 63.0.1. I am using the en-us version and want to to switch the interface to French. For this I: - added the French language pack addon - following the instructions on this page: https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack That documentation suggests to set the intl.locale.requested variable on the about:config page. However this configuration key does not exist in FF 63.0.1. I found what looks like a more suitable key: intl.multilingual.enabled After setting this variable to True, I got a new section in FF options (see screenshot). The language selector now shows both English and French as it's supposed to. After selecting French, a message and a button appear: "Redémarrer Firefox pour appliquer ces changements" or "Restart Firefow to apply those changes". However the button "Aply and restart" is active but does not do anything when clicked. And restarting FF manually comes back up with English still selected. So how can I actually use FF in either French or English? Thanks
Angefügte Screenshots
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
16719 Lösungen 151155 Antworten
Veröffentlicht

This pref doesn't exist by default, so you need to create a new Boolean pref via the right-click context menu with the name intl.locale.requested and set its value to 'fr'.

  • intl.locale.requested = "fr" or "en-US,fr"

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This pref doesn't exist by default, so you need to create a new Boolean pref via the right-click context menu with the name <b>intl.locale.requested</b> and set its value to 'fr'. *intl.locale.requested = "fr" or "en-US,fr" You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Hi

Thanks, I figured as much. Are you aware of the intl.multilingual.enabled pref? is this going to be the next iteration of language handling? should I report the fact it does not work somewhere?

Best regards

Hi Thanks, I figured as much. Are you aware of the intl.multilingual.enabled pref? is this going to be the next iteration of language handling? should I report the fact it does not work somewhere? Best regards
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.