Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Thunderbird password manager is not saving passwords

  • 14 Antworten
  • 4 haben dieses Problem
  • 2178 Aufrufe
  • Letzte Antwort von springfest

more options

Thunderbird keeps asking for my password to fetch and send email for the first time each session. I've checked the box asking Password Manager to save my password. When I go to passwords via Options, no passwords have been saved.

Alle Antworten (14)

more options

Additional information: if I check the box to save the password, Thunderbird does nothing at all. I then immediately try again, without checking the box, Thunderbird pulls the mail. Same behavior for sending mail.

more options

What OS do you use? What version of Thunderbird are you using?

Do you use a product like CCleaner ? If yes, advise you do not allow products like CCleaner any access to any Thunderbird file or folder as it has a habit of deleting useful files like session files and password files etc.

Good info here: http://kb.mozillazine.org/Password_not_remembered_%28Thunderbird%29

How to get quick access to profile: Make hidden files and folders visible: http://kb.mozillazine.org/Show_hidden_files_and_folders

In Thunderbird

  • 'Help' > 'Troubleshooting Information'
  • click on 'Open folder'
  • It should open a new window showing you the contents of your 'profile name' folder.
  • Exit Thunderbird now - this is important.

Thunderbird must not be running if you intend to do anything to any files.

more options

I am running Win10 Home, Thunderbird 60.2.1. I do not use CCleaner. Bitdefender does have a 'clean up your hard drive functionality', but I only use that on a rare occasion.

The help file you referred me to doesn't seem to apply here. Also, the two files the CCleaner erases are present in my profile folder.

more options

What do you mean by "first time each session"?

Do you mean that it remembers it until Windows reboots?

Or do you mean only until the next Thunderbird restart?

more options

It only remembers password for that Thunderbird session.

more options

There are more questions here than answers.

1. Do you have a remote calendar that is asking for the password? 2. Do you have an anti virus that is caching the passwords? Norton's is known to do that and the Thunderbird password manager shows nothing at all in saved passwords.

I would be inclined to look at external products like anti virus for the cause rather than Thunderbird.

more options

I've changed nothing on my desktop and i get the same problem, no saved passwords and i have to enter them ever time, such a pain. My laptop works fine, very odd.

more options

Matt said

There are more questions here than answers. 1. Do you have a remote calendar that is asking for the password? 2. Do you have an anti virus that is caching the passwords? Norton's is known to do that and the Thunderbird password manager shows nothing at all in saved passwords. I would be inclined to look at external products like anti virus for the cause rather than Thunderbird.

1) No remote calendar asking for password 2) I'm running BitDefender, but I've been running that program for a few years now without it interfering with Thunderbird.

Additional information to issue: A few months ago I had to wipe and reload all my software trying to chase down an unrelated issue to my keyboard. Prior to this Thunderbird worked just fine (would keep passwords). If anything, I have fewer software programs running around my system now...wouldn't have expected Thunderbird to perform worse.

more options

Try this: In Thunderbird

  • Help > Troubleshooting Information
  • click on 'Open Folder' button
  • A new window opens showing the contents of your profile name folder.
  • Exit Thunderbird now.
  • copy this file to desktop as temp backup : pkcs11.txt
  • delete this file from profile name folder : pkcs11.txt

Start Thunderbird At prompt enter password and select to remember it.

If all works ok, delete 'pkcs11.txt' from desktop.

Is password saved ? Please post results.

more options

Toad-Hall said

Is password saved ? Please post results.

Nope. Same result as always. Thanks for trying.

more options

Try this: Thunderbird used to use key3db, but now uses key4db.

In thunderbird

  • Help > Troubleshooting Information
  • click on 'show Folder' button

a new window opens showing profile folder name.

  • Close Thunderbird now - this is important
  • Scroll down - locate and delete this file: key4.db
  • Close window - top right X

Restart Thunderbird.

At the prompt to enter password, enter password and select the "Use Password Manager to remember the password" checkbox and click on OK.

pleas report back on results.

more options

That did the trick! When I restarted Thunderbird it did not ask me for a password, so on a hunch I simply hit the button for "Get Messages" and they came right in, without me having to enter password. This tells me that Thunderbird had actually saved my password somewhere but simply wasn't seeing it. I went to Options-->Security-->Saved Passwords and they were all there. Previously they hadn't been.

I'm thrilled this worked but I'm curious as to what that file was doing to mess up Thunderbird.

more options

I had the same problem after I copied the contents of the profiles folder from my Win10 to a fresh TB installation on my Linux Mint pc. No way of getting TB to remember any of the passwords.

I tried with removing key4.db but that didn't do anything. What did work though, was the first tip: removing pkcs11.txt. Suddenly all passwords were in the "saved passwords" list.

Thank you guys for letting us see the light.

more options

This fix worked for a little while and then I keep getting the same messages asking for my password even though it is now saved in the password manager.

This just started happening after I changed my password and I am using Mojave on my iMac. Not sure if Mojave is part of the problem but it this keeps up I am going to have to stop using Thunderbird which I have been using for years.

Geändert am von springfest