Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox does not save passwords in Linux Mint

  • 4 Antworten
  • 1 hat dieses Problem
  • 53 Aufrufe
  • Letzte Antwort von grinningdog

more options

I've exhausted Google and Reddit so you're my last hope. Recently migrated to Linux Mint (18.3 Cinnamon) and everything is fine, except passwords are not stored or displayed. If I restart in safe mode, there are my passwords!

So I have tried: disabling all extensions, both one at a time and all of them; selecting default theme (which I was using anyway, although I tried the other dark/light themes as well); disabled Javascript; turned off hardware acceleration; using the default toolbar. Each time I tried something I restarted FF to try and isolate it.

I have uninstalled and reinstalled FF. I have refreshed FF... all to no avail. I have even tried changing video drivers (no, me neither but it was a suggestion on Reddit and I'm getting desperate)

I've had suggestions to use a password manager but that's not really a path I want to follow.

I'd be grateful for any ideas.

Angefügte Screenshots

Geändert am von grinningdog

Alle Antworten (4)

more options

You have answered your own question as you can see :

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected
more options

Thanks for the reply. As I've unsuccessfully done everything on that list except "userChrome.css and userContent.css are ignored (chrome folder) ", are you suggesting that's the solution.

I'm not sure how to test that.

more options

is there a firefox sync at play perhaps that is bringing over an old and/or corrupt settings or add-on?

more options

I tried to sync everything originally without success. Sync is now turned off.