X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

why does firefox suddenly block pop ups even though I do NOT have it checked off. I guess if theres no answer I am off to download a new browser

Veröffentlicht

its blocking fandango, tlc, etc. especially when you have to log in

its blocking fandango, tlc, etc. especially when you have to log in

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 30.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4267 Lösungen 59839 Antworten
Veröffentlicht

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
jscher2000
  • Top 10 Contributor
8785 Lösungen 71851 Antworten
Veröffentlicht

Actually, it's completely normal for Firefox to block some popups -- the ones that Firefox does not think were triggered by a user action such as a click. If you want to turn off the built-in popup blocker, you could do that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type pop and Firefox should filter to the part of the page where you can un-check the "Block pop-up windows" option.

If the problem is not caused by the built-in popup blocker, then FredMcD's suggestions -- add-ons / content blockers -- would be the most likely culprits.

Actually, it's completely normal for Firefox to block ''some'' popups -- the ones that Firefox does not think were triggered by a user action such as a click. If you want to turn off the built-in popup blocker, you could do that here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''pop'' and Firefox should filter to the part of the page where you can un-check the "Block pop-up windows" option. If the problem is not caused by the built-in popup blocker, then FredMcD's suggestions -- add-ons / content blockers -- would be the most likely culprits.

Fragesteller

lisamsw said

its blocking fandango, tlc, etc. especially when you have to log in

did that, its not checked, I even tried checking it then adding the sites with an issue as exceptions and that didnt work.

Also, checked add ons etc and nothing is there

''lisamsw [[#question-1231603|said]]'' <blockquote> its blocking fandango, tlc, etc. especially when you have to log in </blockquote> did that, its not checked, I even tried checking it then adding the sites with an issue as exceptions and that didnt work. Also, checked add ons etc and nothing is there

Geändert am von lisamsw

Fragesteller

FredMcD said

Make sure you are not blocking content. Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

yes it still persists

''FredMcD [[#answer-1148241|said]]'' <blockquote> Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link} </blockquote> yes it still persists
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

lisamsw said

its blocking fandango, tlc, etc. especially when you have to log in

In the header you say that Firefox is suddenly blocking pop-ups - here you're saying that it's blocking sites like Fandango when you have to
log in.

https://www.fandango.com/account/signin?from=%2F

What exactly is it that Firefox is blocking : pop-ups or login pages  ? Or both  ?

''lisamsw [[#question-1231603|said]]'' <blockquote> its blocking fandango, tlc, etc. especially when you have to log in </blockquote> In the header you say that Firefox is suddenly blocking pop-ups - here you're saying that it's blocking sites like Fandango when you have to <BR>log in. https://www.fandango.com/account/signin?from=%2F What exactly is it that Firefox is blocking : pop-ups or login pages ? Or both ?

Fragesteller

McCoy said

lisamsw said
its blocking fandango, tlc, etc. especially when you have to log in

In the header you say that Firefox is suddenly blocking pop-ups - here you're saying that it's blocking sites like Fandango when you have to
log in.

https://www.fandango.com/account/signin?from=%2F

What exactly is it that Firefox is blocking : pop-ups or login pages  ? Or both  ?

seems to be both, for instance on soem you have to log in with your provider to watch, and thats a pop up, fandango is a pop up for their rewards portion, etc. So my answer to you is both

''McCoy [[#answer-1148264|said]]'' <blockquote> ''lisamsw [[#question-1231603|said]]'' <blockquote> its blocking fandango, tlc, etc. especially when you have to log in </blockquote> In the header you say that Firefox is suddenly blocking pop-ups - here you're saying that it's blocking sites like Fandango when you have to <BR>log in. https://www.fandango.com/account/signin?from=%2F What exactly is it that Firefox is blocking : pop-ups or login pages ? Or both ? </blockquote> seems to be both, for instance on soem you have to log in with your provider to watch, and thats a pop up, fandango is a pop up for their rewards portion, etc. So my answer to you is both
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

Am I right assuming that you are talking about 'pop-up menus' and not 'pop-up windows'  ?

See : https://techterms.com/definition/popup

Am I right assuming that you are talking about 'pop-up menus' and not 'pop-up windows' ? See : https://techterms.com/definition/popup

Fragesteller

no, literal pop up boxes, a separate window that pops up, usually thats why its called a pop up isnt it? So when I click log in, it opens a box to choose which to log in with for instance.

no, literal pop up boxes, a separate window that pops up, usually thats why its called a pop up isnt it? So when I click log in, it opens a box to choose which to log in with for instance.
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

And those login pop-ups are blocked  ?

If so : how  ?

Could you possibly provide a screenshot  ?

And those login pop-ups are blocked ? If so : how ? Could you possibly provide a screenshot ?

Fragesteller

yes they are blocked, they n ever pop up (they do if I use IE) the page just stays the same asking me to log in with my provider. With Fandango it doesnt allow me to see my rewards, and Fandango support says its because pop up are blocked (even tho its turned off) again this works from IE but I am not a fan of IE which is why I have been using firefox for years...this is a new issue, it likely started after a recent update

yes they are blocked, they n ever pop up (they do if I use IE) the page just stays the same asking me to log in with my provider. With Fandango it doesnt allow me to see my rewards, and Fandango support says its because pop up are blocked (even tho its turned off) again this works from IE but I am not a fan of IE which is why I have been using firefox for years...this is a new issue, it likely started after a recent update
cor-el
  • Top 10 Contributor
  • Moderator
17567 Lösungen 158896 Antworten
Veröffentlicht

Did you try Firefox Safe Mode?

Do you have any content blocking extensions?

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Did you try Firefox Safe Mode? Do you have any content blocking extensions? *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection. *click the shield icon for more detail and possibly disable the protection *You can check the Web Console by Tracking Protection *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection-firefox If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Fragesteller

Safemode the issue persists and I have only one extension and its certainly not a content blocker I also do not get the shield icon, I have an i in a circle, a lock (usually green) and thats it.

Safemode the issue persists and I have only one extension and its certainly not a content blocker I also do not get the shield icon, I have an i in a circle, a lock (usually green) and thats it.
McCoy
  • Top 10 Contributor
545 Lösungen 5143 Antworten
Veröffentlicht

lisamsw said

yes they are blocked, they n ever pop up (they do if I use IE) the page just stays the same asking me to log in with my provider.

Would this be a cable provider or a TV provider  ?

With Fandango it doesnt allow me to see my rewards, and Fandango support says its because pop up are blocked (even tho its turned off)

You have turned it off in Options, but would you try this please :

When you're on Fandango's site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to 'Page Info'. Then click on the little black arrow on the dropdown and then on 'More Information'. Click on the 'Permissions' tab and scroll down to 'Open Pop-up Windows'. Uncheck 'Use Default' and check 'Allow'.

''lisamsw [[#answer-1148523|said]]'' <blockquote> yes they are blocked, they n ever pop up (they do if I use IE) the page just stays the same asking me to log in with my provider. </blockquote> Would this be a cable provider or a TV provider ? <blockquote> With Fandango it doesnt allow me to see my rewards, and Fandango support says its because pop up are blocked (even tho its turned off) </blockquote> You have turned it off in Options, but would you try this please : When you're on Fandango's site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to 'Page Info'. Then click on the little black arrow on the dropdown and then on 'More Information'. Click on the 'Permissions' tab and scroll down to 'Open Pop-up Windows'. Uncheck 'Use Default' and check 'Allow'.