Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Bookmarks toolbar isn't showing up

  • 15 Antworten
  • 6 haben dieses Problem
  • 8688 Aufrufe
  • Letzte Antwort von speedkore

more options

For some reason, my bookmarks toolbar simply disappeared. I've tried rebooting, turning the bookmarks toolbar on and off, and even reinstalling firefox to no avail. Please help.

Angefügte Screenshots

Ausgewählte Lösung

I can't think of any other reason the toolbar would not appear. So we could suggest:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

New Profile Test

The purpose of this test is to bypass all existing settings. It takes about 3 minutes, plus the time to customize.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like July2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. If asked about activating add-ons or signing into Sync, just ignore those tabs.

Can you display the Bookmarks Toolbar in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (15)

more options

Hi, hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions and restart Firefox; then if it's OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

Safe Mode also would disable any userChrome.css file you might have set up to customize the interface area of Firefox. If that doesn't sound familiar, you probably haven't created/downloaded one.

more options

There's still the same problem within safe mode.

more options

Hi smchase, does the Bookmarks Toolbar show up in the Customize mode? There's also a "Restore Defaults" button at the bottom of that tab.

See: Customize Firefox controls, buttons and toolbars

more options

No it doesn't, and that doesn't solve it.

more options

Are bookmarks working at all? For example, can you use the Bookmarks Sidebar (Ctrl+b) or the Bookmarks menu on the classic Menu Bar (you can tap the Alt key to activate the bar temporarily). If those open, can you expand the Bookmarks Toolbar category? If so, are the expected bookmarks still there?

Have you seen the error message mentioned in this article: Fix "The bookmarks and history system will not be functional" error message?

more options

Yep, the bookmarks are still there and the side bar and everything else works.

more options

Hmm, sometimes the settings file that stores window dimensions and toolbar layout (not including which buttons are where) becomes corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again, and try to display the Bookmarks Toolbar.

Any improvement?

more options

Nope, unfortunately. :(

more options

Ausgewählte Lösung

I can't think of any other reason the toolbar would not appear. So we could suggest:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

New Profile Test

The purpose of this test is to bypass all existing settings. It takes about 3 minutes, plus the time to customize.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like July2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. If asked about activating add-ons or signing into Sync, just ignore those tabs.

Can you display the Bookmarks Toolbar in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

I had the same exact problem, creating new profile solves it, but i had to find the culprit in my profile and i found it

In the profile folder, the file: prefs.js and the line: user_pref("browser.startup.page", 3);

Stop firefox, delete this line, start firefox, active the bookmarks toolbar again and the bookmarks will show

Maybe this fix works for you or not, i don't know, but this is how i fixed my profile to be able to show bookmarks toolbar again

Geändert am von speedkore

more options

Hi speedkore, the setting

user_pref("browser.startup.page", 3);

is the instruction to restore your previous session windows and tabs at startup -- one of the choices in the Startup section on the Options/Preferences page.

I wonder if switching it there might be easier than editing the prefs.js file, and equally effective??

more options

jscher2000 said

I wonder if switching it there might be easier than editing the prefs.js file, and equally effective??

I thought it but i didn't try, i just was tired of deleting files in packs of profile until find which one was blocking the bookmark toolbar, and then deleting lines of that file in packs until find the real culprit, but it was entertaining like a Sherlock Holmes history finding the assassin xD

more options

jscher2000 said

Hi speedkore, the setting user_pref("browser.startup.page", 3); is the instruction to restore your previous session windows and tabs at startup -- one of the choices in the Startup section on the Options/Preferences page. I wonder if switching it there might be easier than editing the prefs.js file, and equally effective??

This was the answer for me. I only found this after doing the clean reinstall, though. I wonder if cancelling the "Restore previous session" would have cured the problem without the clean reinstall. This is something that I cannot test now.

Nick

more options

This happened to me again, i can confirm that going to options and disabling "restore previous session", restart firefox, and enable it again if you want, fixes the issue.

Geändert am von speedkore