Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox Sync silently errors out as it's trying to download an add-on

  • 3 Antworten
  • 1 hat dieses Problem
  • 15 Aufrufe
  • Letzte Antwort von user1494117

more options

i'm getting this in the browser console when Firefox 59.0.2 on Fedora is syncing:

1526076217390 addons.xpi WARN Failed to start download for addon https://addons.mozilla.org/firefox/downloads/file/951074/session_sync-3.0.2-an+fx-linux.xpi?src=sync: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 64" data: no] Stack trace: FileUtils_getDir()@resource://gre/modules/FileUtils.jsm:64 < getTemporaryFile()@resource://gre/modules/addons/XPIInstall.jsm:1017 < openChannel()@resource://gre/modules/addons/XPIInstall.jsm:2244 < startDownload()@resource://gre/modules/addons/XPIInstall.jsm:2237 < install()@resource://gre/modules/addons/XPIInstall.jsm:2176 < install()@resource://gre/modules/addons/XPIInstall.jsm:2648 < installAddonFromSearchResult/<()@resource://services-sync/addonutils.js:147 < handleInstall()@resource://services-sync/addonutils.js:53 < safeCall()@resource://gre/modules/AddonManager.jsm:188 < makeSafe/<()@resource://gre/modules/AddonManager.jsm:203 < waitForSyncCallback()@resource://services-common/async.js:97 < makeSpinningCallback/callback.wait()@resource://services-common/async.js:166 < create()@resource://services-sync/engines/addons.js:317 < applyIncoming()@resource://services-sync/engines.js:361

I am the owner of the my home directory and permissions on mozilla directory tree are 755.

It appears that this error is also affecting regular downloads from all websites. I have treid creating a new, empty profile and still get the error.

All i get is this message in a popup:

"[null] could not be saved, because an unknown error occurred.

Try saving to a different location."

Alle Antworten (3)

more options

Did you get a segmentation fault? and as a freebsd user im embarrassed to ask what 755 mod is, what access level is this, isnt 777 a global rwx ?

more options

no segmentation fault. it just silently stops. it doesn't sync anything (i'm only syncing prefs and add-ons) but it doesn't provide any information that it didn't sync.

755 is rwx for user, rx for group and rx for others

more options

would you come to #sumo on irc.mozilla.org tomorrow around 11am EST, i think i can better assist if we talk live.

if you are awake now, have you tried compiling the source code in a directory in ~/ ?