X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

While Automating Websites through Selenium, FireFox(Version:60) is blocking Flash Objects automatically. How to stop firefox from doing that?.

Veröffentlicht

While Automating Websites through Selenium, FireFox Quantum browser is blocking Flash objects , hence Driver is not able to click on the Flash object element.

Note: I had set manually "Always Activate" option in Adobe Shockwave Flash player, but still when scripts are running through selenium, Firefox is disabling the Flash buttons.

Please provide me with the solution asap.

Thanks in Advance.

While Automating Websites through Selenium, FireFox Quantum browser is blocking Flash objects , hence Driver is not able to click on the Flash object element. Note: I had set manually "Always Activate" option in Adobe Shockwave Flash player, but still when scripts are running through selenium, Firefox is disabling the Flash buttons. Please provide me with the solution asap. Thanks in Advance.

Mehr Details zum System

Installierte Plugins

  • Adobe PDF Plug-In For Firefox and Netscape 18.11.20036
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 29.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Weitere Informationen

Shadow110 1072 Lösungen 14836 Antworten
Veröffentlicht

Hi, can you provide a URL please.

Are you saying that it deactivates the block icon in the address bar to allow and any other block icon on the object ?

Hi, can you provide a URL please. Are you saying that it deactivates the block icon in the address bar to allow and any other block icon on the object ?
Veröffentlicht

Fragesteller

Firefox disables shockwave flash plugin option to "Never Active" and "Block dangerous and intrusive Flash content" option is selected while running scripts through selenium webdriver. Because of it, unable to click on Flash objects.

I have tried below options but didn't work for me.

Tried manually setting shockwave flash plugin option to "Always Activate" and deselected "Block dangerous and intrusive Flash content" option. Used below code in configuration file. profile.setPreference("dom.ipc.plugins.enabled.libflashplayer.so","true"); profile.setPreference("plugin.state.flash", 2);

Please find screenshot of the Flash object ,

Firefox disables shockwave flash plugin option to "Never Active" and "Block dangerous and intrusive Flash content" option is selected while running scripts through selenium webdriver. Because of it, unable to click on Flash objects. I have tried below options but didn't work for me. '''Tried manually setting shockwave flash plugin''' option to "Always Activate" and deselected "Block dangerous and intrusive Flash content" option. '''Used below code in configuration file. '''profile.setPreference("dom.ipc.plugins.enabled.libflashplayer.so","true"); profile.setPreference("plugin.state.flash", 2); '''Please find screenshot of the Flash object ,'''

Geändert am von Amogh

cor-el
  • Top 10 Contributor
  • Moderator
17416 Lösungen 157342 Antworten
Veröffentlicht

If this is about local files (file: protocol) then check this pref on the about:config page.

  • plugins.http_https_only
  • plugins.flashBlock.enabled
If this is about local files (file: protocol) then check this pref on the <b>about:config</b> page. *plugins.http_https_only *plugins.flashBlock.enabled
Veröffentlicht

Fragesteller

Hi cor-el,

plugins.http_https_only was set to True and plugins.flashBlock.enabled was set to False by default .

I tried changing all the possible combinations of *plugins.http_https_only and

  • plugins.flashBlock.enabled, still when my script is running, Shockwave Flash is set to "Never Activate" in Firefox quantum browser(Version:60.0) but same issue is not noticed in older versions of FireFox broswer(version:46)
Hi cor-el, plugins.http_https_only was set to '''True''' and plugins.flashBlock.enabled was set to '''False by default''' . I tried '''changing''' all the possible combinations of *plugins.http_https_only and *plugins.flashBlock.enabled, still when my script is running, Shockwave Flash is '''set to "Never Activate"''' in '''Firefox quantum browser(Version:60.0)''' '''but same''' ''' issue is not noticed''' in '''older versions of FireFox broswer(version:46)'''
cor-el
  • Top 10 Contributor
  • Moderator
17416 Lösungen 157342 Antworten
Veröffentlicht

When both prefs are set to false and the Shockwave Flash plugin is set to always activate then there is not much that can be done if it is still not working.

  • plugins.http_https_only = false
  • plugins.flashBlock.enabled = false
  • plugin.state.flash = 2
When both prefs are set to false and the Shockwave Flash plugin is set to always activate then there is not much that can be done if it is still not working. * plugins.http_https_only = false * plugins.flashBlock.enabled = false * plugin.state.flash = 2
Veröffentlicht

Fragesteller

Hi Corel,

I tried the solution provided by you, but it din't work for me.

Anyways i appreciate your help.

Thank you.

Hi Corel, I tried the solution provided by you, but it din't work for me. Anyways i appreciate your help. Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17416 Lösungen 157342 Antworten
Veröffentlicht

Hilfreiche Antwort

Try to ask advice at the Stack Overflow forum site.

Try to ask advice at the Stack Overflow forum site. *http://stackoverflow.com/questions/
Veröffentlicht

Fragesteller

I have posted in Stackoverflow forum and Adobe forum also, i have not received any working solutions yet.

I have posted in Stackoverflow forum and Adobe forum also, i have not received any working solutions yet.