Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitter gifs do not work.

  • 18 Antworten
  • 1 hat dieses Problem
  • 1463 Aufrufe
  • Letzte Antwort von chikun

more options

I have tried:

Running in safe-mode without add-ons. Checking About:Config that animation is set on true Checked if html-5 works and is all blue.

Gifs work fine on any other site and .mp4 (non-looped) works fine.

Please help. Issue occured after fresh windows install, all drivers and programs are therefore as up to date as possible due to installing them just days ago.

Ausgewählte Lösung

I have done nothing since the problem occured but yesterday for unknown reasons my internet had changed on its own to Public network as opposed to Home network. Why will remain a mystery.

It caused however, inability to load any webpages at all.

  • So i unplugged my router, waiting the classic 10 sec for the modem to restart. (My connection is 2 boxes, most homes have 1)
  • I changed network settings back to Home Network and restarted my pc for good measure.
  • After that I went in to twitter to check if that might've magically fixed things

Currently all gifs play normally.


I have by the way made a ticket to twitter about it 2 days ago but i doubt it was them who did anything from their end. I have also installed malwarebytes during my time of struggle, but I doubt it was that which fixed things.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (18)

more options

Issue is claimed to have been resolved in firefox 47.0 but i am running 59.0.2 and currently experiencing the isssue.

more options

Is it just on Twitter? All of the site or just parts of it?

Please provide public link(s) (no password) that we can check out. No Personal Information Please !


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

FredMcD said

Is it just on Twitter? All of the site or just parts of it? Please provide public link(s) (no password) that we can check out. No Personal Information Please !

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I already stated the answer to your question. Works on other sites. not on twitter.

more options

And did you check out Many site issues ?

more options

FredMcD said

And did you check out Many site issues ?

I have gone through about 5 pages of what google had as results for these searches: twitter firefox gif not showing twitter firefox gif not displaying twitter firefox gif not working twitter gif not showing twitter gif not displaying twitter gif not working gif bugs twitter issues gif twitter firefox gif issues

etc etc etc. would you like my search history?

more options

chikun said

I have gone through about 5 pages of what google had as results for these searches:

That is not what I asked. Follow the instructions on this link where it starts with Many site issues https://support.mozilla.org/en-US/questions/1215808#answer-1106546

more options

Yes ofcourse, I have done that.

more options

AdBlock 3.12.0 Block site 3.1.15 Ghostery – Popup Blocker So all of these are not causing the issue on Titter ? SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Please, at least read what I've written. This is wasting my time.

more options

I read......thanks. Double Confirmation may be strange but..... REFRESH INSTRUCTIONS Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

more options

Did you check the Web Console for error messages?

Some websites have a policy that Firefox obeys that prohibits to include their content on another website. If this content is embedded then that could very well be the case. The Web Console might show a message in such a case about content being blocked.

more options

cor-el said

Did you check the Web Console for error messages? Some websites have a policy that Firefox obeys that prohibits to include their content on another website. If this content is embedded then that could very well be the case. The Web Console might show a message in such a case about content being blocked.

Lots of Content Security Policy such as

Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src"). Source: {

 let activeElement = null;
 let doc.... 991080976263544832:1


and lots of Unhandled promise rejection Unhandled promise rejection undefined such as


init.en.ea7c5644226974af0b5c.js:2:86970 I/

more options

Pkshadow said

I read......thanks. Double Confirmation may be strange but..... REFRESH INSTRUCTIONS Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST. then TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: If is your Profile : Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.

didnt do anything to my issue

more options

Fresh reinstall of firefox, even before I did any alterations I went in to twitter and none of the gifs will load.

If I try to post a gif myself by going through the list of suggested gifs, those play without any issues until posted.

so any already posted gifs do not play.

as previously said: other sites are perfectly functional, issue is on twitter only

more options

any of these look wrong. according to the other suggestions concerning that topic neither of these false ones were mentioned as possible culprit.

more options

You can temporarily disable CSP by toggling this pref to false on the about:config page to check for CSP related issues.

  • security.csp.enable = false

This is a security feature you shouldn't leave it disabled and re-enable this feature once you are done with the website.

more options

cor-el said

You can temporarily disable CSP by toggling this pref to false on the about:config page to check for CSP related issues.
  • security.csp.enable = false
This is a security feature you shouldn't leave it disabled and re-enable this feature once you are done with the website.

that is a terrible life to live. that will not do

more options

Ausgewählte Lösung

I have done nothing since the problem occured but yesterday for unknown reasons my internet had changed on its own to Public network as opposed to Home network. Why will remain a mystery.

It caused however, inability to load any webpages at all.

  • So i unplugged my router, waiting the classic 10 sec for the modem to restart. (My connection is 2 boxes, most homes have 1)
  • I changed network settings back to Home Network and restarted my pc for good measure.
  • After that I went in to twitter to check if that might've magically fixed things

Currently all gifs play normally.


I have by the way made a ticket to twitter about it 2 days ago but i doubt it was them who did anything from their end. I have also installed malwarebytes during my time of struggle, but I doubt it was that which fixed things.