Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Why is my camera not working, even when it's enabled through Firefox?

more options

Hi, today I was supposed to take an online midterm using ProctorU. Unfortunately, I had to switch to Edge (gross!) because despite Firefox having complete access to my camera always, it won't show it. I've used multiple webcam test sites and noe seem to work. The light on my camera turns on, but I just get a flashing red camera icon in the nav bar. My camera works with the native app, it's allowed through the firewall, AdBlock is off for these sites, and in about:config, media*enable search is all set to default.

Alle Antworten (6)

more options

Flashing red it should be a blue light if it is working correctly. That's what my webcam does.

more options

WestEnd said

Flashing red it should be a blue light if it is working correctly. That's what my webcam does.

Lol, yeah I'm aware. It IS functioning in Edge, but no picture shows up in Firefox (or Chrome for that matter).

Geändert am von typewriteronLSD

more options

typewriteronLSD said

WestEnd said
Flashing red it should be a blue light if it is working correctly. That's what my webcam does.

Lol, yeah I'm aware. It IS functioning in Edge, but no picture shows up in Firefox (or Chrome for that matter).

That would indicate hardware communication problem.

more options

WestEnd said

typewriteronLSD said
WestEnd said
Flashing red it should be a blue light if it is working correctly. That's what my webcam does.

Lol, yeah I'm aware. It IS functioning in Edge, but no picture shows up in Firefox (or Chrome for that matter).

That would indicate hardware communication problem.


So it would indicate, but again, the camera functions perfectly in the native app and in Edge. When Flash asks for permission and I give it, nothing shows up, which indicates a *software* problem, either within Flash or within Firefox itself.

more options

Hi, please check here : Copy/Paste about:preferences#privacy to the Address Bar then Enter. Go down to Permissions --> Camera and Click Settings and see if that web site is in there and if Blocked, also look at bottom of that for Check Mark in Block new Requests ..... and if there is please remove it.

Please also try in : SAFE MODE as Adblock may cause the issue or the 2 Flash you are running.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

You are running 2 different versions of Flash 27.00 & 29.00 Please use this to uninstall but Right Click and Run as Administrator https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Please reinstall Flash after removal : Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

Hi, please check here : Copy/Paste about:preferences#privacy to the Address Bar then Enter. Go down to Permissions --> Camera and Click Settings and see if that web site is in there and if Blocked, also look at bottom of that for Check Mark in Block new Requests ..... and if there is please remove it. Please also try in : SAFE MODE as Adblock may cause the issue or the 2 Flash you are running. In Firefox Safe mode these changes are effective:
  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
TEST''''is issue still there ? You are running 2 different versions of Flash 27.00 & 29.00 Please use this to uninstall but Right Click and Run as Administrator https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Please reinstall Flash after removal : Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Please let us know if this solved your issue or if need further assistance.

Hi, I tried everything above, but I still have the red camera icon. I think it's worth noting that one of the sites I'm testing with also tests my mic. It can detect the mic levels but it also flashes with a red mic icon.

Anything else I can try?

Geändert am von typewriteronLSD