X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Your solutions are based on menus or commands that my version of Thunderbird (Linux) does not have.

Veröffentlicht

This often happens, and it stops your support from being any use to me. My current problem is, for instance, that I just want to change the default browser that is opened when I click a link in an email. Your solution page for this (https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser) directs me to "preferences", "general" (no problem to find this) and then to a button "make default" that is just not there: my "general" tab window (see encl. screenshot) looks totally different from what you show. I work under Freshbook, an adaptation of Ubuntu.

This often happens, and it stops your support from being any use to me. My current problem is, for instance, that I just want to change the default browser that is opened when I click a link in an email. Your solution page for this (https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser) directs me to "preferences", "general" (no problem to find this) and then to a button "make default" that is just not there: my "general" tab window (see encl. screenshot) looks totally different from what you show. I work under Freshbook, an adaptation of Ubuntu.

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/65.0.3325.181 Chrome/65.0.3325.181 Safari/537.36

Weitere Informationen

Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

http://kb.mozillazine.org/Menu_differences_in_Windows,_Linux,_and_Mac

But that appears to be an article about Firefox and is not especially relevant to Thunderbird.

If you find a fault with one of these articles, chip in and help modify it.

http://kb.mozillazine.org/Menu_differences_in_Windows,_Linux,_and_Mac But that appears to be an article about Firefox and is not especially relevant to Thunderbird. If you find a fault with one of these articles, chip in and help modify it.

Geändert am von Zenos

James
  • Moderator
1596 Lösungen 11246 Antworten
Veröffentlicht

In Firefox: Edit > Preferences > General

The General is top one on the left side so you click on it if it is not already selected and then look at startup section.

But if you meant make Thunderbird as the default email client as you posted this thread in Thunderbird section then see https://support.mozilla.org/en-US/kb/make-thunderbird-default-mail-client

http://kb.mozillazine.org/Menu_differences_in_Windows,_Linux,_and_Mac

The Menus are a little different on Mac OSX due to Apple HIG and Linux due to Gnome HIG.

In Firefox: Edit > Preferences > General The General is top one on the left side so you click on it if it is not already selected and then look at startup section. But if you meant make Thunderbird as the default email client as you posted this thread in Thunderbird section then see https://support.mozilla.org/en-US/kb/make-thunderbird-default-mail-client http://kb.mozillazine.org/Menu_differences_in_Windows,_Linux,_and_Mac The Menus are a little different on Mac OSX due to Apple HIG and Linux due to Gnome HIG.

Fragesteller

Thanks for replying, both of you, but the problem is not solved. Zenos's reply was not relevant. James's reply did not work, though it did show me two things: (1) the settings I was originally referred to were in Firefox, not in Thunderbird. So I set Chromium to declare itself the default browser (used to be Firefox, but I want to make Chromium the default), and restarted my computer. However: (2) a link from a Thunderbird email is still opened in Firefox, while a link in a Writer document now asked for (re)setting the default. I did the latter. Now Chromium is the default browser that Writer connects to, while Thunderbird still directs me to Firefox. Note: the default setting in Firefox cannot be switched off, it's still on; so now I have two browsers both thinking they are the default. Thunderbird and Writer each choose a different browser.

Thanks for replying, both of you, but the problem is not solved. Zenos's reply was not relevant. James's reply did not work, though it did show me two things: (1) the settings I was originally referred to were in Firefox, not in Thunderbird. So I set Chromium to declare itself the default browser (used to be Firefox, but I want to make Chromium the default), and restarted my computer. However: (2) a link from a Thunderbird email is still opened in Firefox, while a link in a Writer document now asked for (re)setting the default. I did the latter. Now Chromium is the default browser that Writer connects to, while Thunderbird still directs me to Firefox. Note: the default setting in Firefox cannot be switched off, it's still on; so now I have two browsers both thinking they are the default. Thunderbird and Writer each choose a different browser.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

Hilfreiche Antwort

Have you gone through the process of setting the default browser in the OS?

My reply was relevant in that you need to think about whether you mean the system's default browser, or the default browser you want Thunderbird to invoke. Some users want these to be different and it can be tricky.

The first may possibly be set via the browser itself, but the sure way is to use the OS's settings for identifying the default.

The general rule is that an application, when set to open a link, passes it to the system for handling by the default application for that type of link. It's possible that your Writer has an override for this.

Have you gone through the process of setting the default browser '''in the OS'''? My reply ''was'' relevant in that you need to think about whether you mean the system's default browser, or the default browser you want Thunderbird to invoke. Some users want these to be different and it can be tricky. The first may possibly be set via the browser itself, but the sure way is to use the OS's settings for identifying the default. The general rule is that an application, when set to open a link, passes it to the system for handling by the default application for that type of link. It's possible that your Writer has an override for this.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

Go to Tools|Options|Advanced|General→Config Editor.

Tools|Options (Windows) == Edit|Preferences (Linux)

Type in network.protocol-handler.warn-external

Review the list. Set to true any of these where you want to set the handler invoked by Thunderbird. Next time you click on such a link, you should get a prompt to choose the application to be used, thereby overriding the system default.

Go to '''[http://kb.mozillazine.org/Menu_differences_in_Windows%2C_Linux%2C_and_Mac Tools|Options]|Advanced|General→Config Editor'''. Tools|Options (Windows) == Edit|Preferences (Linux) Type in ''network.protocol-handler.warn-external'' Review the list. Set to '''true''' any of these where you want to set the handler invoked by Thunderbird. Next time you click on such a link, you should get a prompt to choose the application to be used, thereby overriding the system default.

Fragesteller

Thanks again for your time, Zenos, but I'm still no further. As you pointed me to the OS but stated no programme where I can modify its settings, I tried your search line in my file explorer first (assuming this to be the most 'general' application of my OS), but there the preferences have no search option. Then I tried it in the Firefox preferences (which do have this option), but no search results were found. This may be (for all I know) because I have it all in Dutch and the search line is English. My wish is to set one browser (Chromium) as default for all applications.

Thanks again for your time, Zenos, but I'm still no further. As you pointed me to the OS but stated no programme where I can modify its settings, I tried your search line in my file explorer first (assuming this to be the most 'general' application of my OS), but there the preferences have no search option. Then I tried it in the Firefox preferences (which do have this option), but no search results were found. This may be (for all I know) because I have it all in Dutch and the search line is English. My wish is to set one browser (Chromium) as default for all applications.
James
  • Moderator
1596 Lösungen 11246 Antworten
Veröffentlicht
Since you said Dutch Config Editor https://support.mozilla.org/nl/kb/configuratie-editor Make Firefox as default web browser. https://support.mozilla.org/nl/kb/firefox-uw-standaardbrowser-maken Make Thunderbird as default email client. https://support.mozilla.org/nl/kb/thunderbird-de-standaard-e-mailclient-maken

Geändert am von James

Fragesteller

This is German, not Dutch....

This is German, not Dutch....

Fragesteller

..and the problem is not that I don't understand English or German, but Zenos gave me a search line in English, which (I'm presuming!) may not be findable in my Dutch preferences.

..and the problem is not that I don't understand English or German, but Zenos gave me a search line in English, which (I'm presuming!) may not be findable in my Dutch preferences.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

You probably need to ask on support sites for your particular OS for help on setting its defaults. I doubt anyone here can help you with those settings. These are very much dependent on the distro. I could tell you where to go in MX-Linux (which I use), but that won't be of any help with the particular tool set offered by Freshbook.

My "search line" - did you mean this?

network.protocol-handler.warn-external

This is to be used inside Thunderbird's configuration editor. Whenever you use a protocol where you have set that to true, you'll get a prompt to select the required application. You'll probably need to use the
which
command in a terminal window to discover the path to your preferred browser.
You probably need to ask on support sites for your particular OS for help on setting its defaults. I doubt anyone here can help you with those settings. These are very much dependent on the distro. I could tell you where to go in MX-Linux (which I use), but that won't be of any help with the particular tool set offered by Freshbook. My "search line" - did you mean this? ''network.protocol-handler.warn-external'' This is to be used inside Thunderbird's configuration editor. Whenever you use a protocol where you have set that to true, you'll get a prompt to select the required application. You'll probably need to use the <pre>which</pre> command in a terminal window to discover the path to your preferred browser.
Toad-Hall
  • Top 10 Contributor
1766 Lösungen 11876 Antworten
Veröffentlicht

http://kb.mozillazine.org/Changing_the_web_browser_invoked_by_Thunderbird

Try this: In Thunderbird

  • Edit > Preferences > Advanced > General tab
  • click on 'Config editor' button

It will say to be careful :)

  • In top search type: warn-external

locate these two lines:

  • network.protocol-handler.warn-external.http
  • network.protocol-handler.warn-external.https
  • Double click on each of those lines to toggle the 'false' to 'true'
  • close window using top right X
  • click on OK to save and close 'Preferences' window.

Then when you click on link you should be able to choose the desired browser from a popup window instead.

http://kb.mozillazine.org/Changing_the_web_browser_invoked_by_Thunderbird Try this: In Thunderbird * Edit > Preferences > Advanced > General tab * click on 'Config editor' button It will say to be careful :) * In top search type: '''warn-external''' locate these two lines: * network.protocol-handler.warn-external.http * network.protocol-handler.warn-external.https * Double click on each of those lines to toggle the 'false' to 'true' * close window using top right X * click on OK to save and close 'Preferences' window. Then when you click on link you should be able to choose the desired browser from a popup window instead.

Fragesteller

Thanks again to both of you, I'll try it this weekend, when I have time. (Baffled that setting a default browser is so much trouble.... But grateful for your guidance.)

Thanks again to both of you, I'll try it this weekend, when I have time. (Baffled that setting a default browser is so much trouble.... But grateful for your guidance.)
Matt
  • Top 10 Contributor
  • Moderator
3251 Lösungen 22401 Antworten
Veröffentlicht

Well I tried, but google could not locate a Linux distribution called Freshbook.

Instructions for ubuntu are here https://askubuntu.com/questions/79305/how-do-i-change-my-default-browser

Well I tried, but google could not locate a Linux distribution called Freshbook. Instructions for ubuntu are here https://askubuntu.com/questions/79305/how-do-i-change-my-default-browser

Fragesteller

I've tried all your solutions, but none are effective - though this may be partly due to me. Everywhere I encounter terms that I don't understand and that are not explained, but by common sense and intuition I come a long way. I found Thunderbird's config editor and set the two "warn-external" lines to true; I then do get to choose the browser, but cannot find my Chromium in my explorer - except the desk top link to Chromium that I often use, but it won't take that: no browser is opened. So I set the two "warn-external" lines back to false. Matt's solution referred to system settings, which I found (!): they look quite different from what's shown by AskUbuntu, but do have a page for setting default applications. I set the standard browser to Chromium (confirming with "apply"). It does not make any difference: Thunderbird still picks Firefox. I'm giving up for now. Thanks to all for your efforts!

I've tried all your solutions, but none are effective - though this may be partly due to me. Everywhere I encounter terms that I don't understand and that are not explained, but by common sense and intuition I come a long way. I found Thunderbird's config editor and set the two "warn-external" lines to true; I then do get to choose the browser, but cannot find my Chromium in my explorer - except the desk top link to Chromium that I often use, but it won't take that: no browser is opened. So I set the two "warn-external" lines back to false. Matt's solution referred to system settings, which I found (!): they look quite different from what's shown by AskUbuntu, but do have a page for setting default applications. I set the standard browser to Chromium (confirming with "apply"). It does not make any difference: Thunderbird still picks Firefox. I'm giving up for now. Thanks to all for your efforts!

Fragesteller

Oh, by the way: an ironic streak of Chromium is that every time I open it, it tells me it is not my standard browser and offers to become this. I always say yes - and it never makes any difference.

Oh, by the way: an ironic streak of Chromium is that every time I open it, it tells me it is not my standard browser and offers to become this. I always say yes - and it never makes any difference.
Matt
  • Top 10 Contributor
  • Moderator
3251 Lösungen 22401 Antworten
Veröffentlicht

Diederick said

Oh, by the way: an ironic streak of Chromium is that every time I open it, it tells me it is not my standard browser and offers to become this. I always say yes - and it never makes any difference.

So the problem is you have no default browser, or something very similar. It is not a problem with Thunderbird.

It might be a bug in chromium, it might be a bug in your operating system or it may be misconfiguration of that operating system., but non of those thinds are related to Thunderbird.

What operating system are you using. Provide a link to the repository please. I can not find this Freshbook. But in the end I suggest you ask in the support forum for your distribution of Linux.

''Diederick [[#answer-1104178|said]]'' <blockquote> Oh, by the way: an ironic streak of Chromium is that every time I open it, it tells me it is not my standard browser and offers to become this. I always say yes - and it never makes any difference. </blockquote> So the problem is you have no default browser, or something very similar. It is not a problem with Thunderbird. It might be a bug in chromium, it might be a bug in your operating system or it may be misconfiguration of that operating system., but non of those thinds are related to Thunderbird. What operating system are you using. Provide a link to the repository please. I can not find this Freshbook. But in the end I suggest you ask in the support forum for your distribution of Linux.
James
  • Moderator
1596 Lösungen 11246 Antworten
Veröffentlicht

Freshbooks is the name of a invoicing & accounting software for small businesses. It would be confusing for a popular software and a Linux distro to have same name.

No Linux distro with fresh in name at http://distrowatch.org/ and no Ubuntu related version at https://wiki.ubuntu.com/DerivativeTeam/Derivatives

Freshbooks is the name of a invoicing & accounting software for small businesses. It would be confusing for a popular software and a Linux distro to have same name. No Linux distro with fresh in name at http://distrowatch.org/ and no Ubuntu related version at https://wiki.ubuntu.com/DerivativeTeam/Derivatives

Geändert am von James

Fragesteller

Matt, what is a repository and where do I find it? Then I'll try and give you the link, if I can find it.

Matt, what is a repository and where do I find it? Then I'll try and give you the link, if I can find it.
Toad-Hall
  • Top 10 Contributor
1766 Lösungen 11876 Antworten
Veröffentlicht

re: I found Thunderbird's config editor and set the two "warn-external" lines to true; I then do get to choose the browser, but cannot find my Chromium in my explorer

That would be the 'chrome.exe' file you are needing. In Windows OS, if I right click on the shortcut for chrome and select 'Properties', a window opens and the 'Target' tells me where the program is installed and where it runs from. eg: C:\Users\User Account\AppData\Local\Google\Chrome\Application\chrome.exe Perhaps if you do the same, you can locate where the exe file is located on Ubuntu.

re: ''I found Thunderbird's config editor and set the two "warn-external" lines to true; I then do get to choose the browser, but cannot find my Chromium in my explorer'' That would be the 'chrome.exe' file you are needing. In Windows OS, if I right click on the shortcut for chrome and select 'Properties', a window opens and the 'Target' tells me where the program is installed and where it runs from. eg: C:\Users\User Account\AppData\Local\Google\Chrome\Application\chrome.exe Perhaps if you do the same, you can locate where the exe file is located on Ubuntu.

Fragesteller

Thanks, that's one of the things I've tried, but it does not give the location of the .exe file, only that of the shortcut itself.

Thanks, that's one of the things I've tried, but it does not give the location of the .exe file, only that of the shortcut itself.