Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

uBlock Origin downloads but won't finish installing

  • 7 Antworten
  • 1 hat dieses Problem
  • 41 Aufrufe
  • Letzte Antwort von cor-el

more options

The Add-ons Manager page shows several choices to 'Personalize Your Firefox' including 'Owl First Snow 'and 'uBlock Origin'. When selecting the latter, uBO downloads, but does not finish the install. It repeatedly prompts me to click a blue 'Add' button in a popup. I've tried versions 55 thru 58 with the same result. However, uBO does work for me in firefox-54.0.1. I'm putting together a new machine with Debian stretch and firefox quantum. I seem to have installed all the dependencies for 54, but something must be missing for anything beyond that.

The attached image shows that Owl installed completely, but uBO has wavy green lines and no check in the on/off button. No matter how many times I click add, no progress is made.


Angefügte Screenshots

Alle Antworten (7)

more options

Did you contact ublock to verify it was update to work with FF57+? Addon issues are to fixed the creators not FF should they not install or get disabled.

more options

Thank you for your suggestions. The add-on uBLock Origin is indeed compatible with firefox 57+ with the webextensions interface. I believe my issue is not with the add-on itself, but in the firefox installation process. By using the 'Enable add-on debugging' feature and the 'Load Temporary Add-on' button, I was able to successfully install uBlock Origin from the latest .xpi file. However, I'm still unable to install it in the normal permanent manner. This suggests that the add-on is OK, but the install mechanism in the browser is faulty. The add-on only installs in debug mode.

Firefox58.0.1 ublock_origin-1.15.3rc0-an+fx.xpi

more options

Did you uninstall the ublock and then reinstall it after updating FF to see if there wasn't something missed or removed by the latest FF update?

more options

For testing, I've been following the instructions at https://support.mozilla.org/en-US/kb/install-firefox-linux.

I created a test user. On every test, I completely remove all files/directories from this users home directory including those starting with '.' I then unpack the tar file firefox-58.0.1.tar.bz2 and run it. I then surf to https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/ to add the latest uBO. This results in the the add-on status being "downloaded" as shown in on the about:addons page.

If I repeat the above, but load the addon .xpi file thru the addon debugger's temporary load function. The install completes with the status showing the expected Preferences, Disable, and Remove boxes instead of just a "Downloaded" status like above.

In both cases, the addon version is ublock_origin-1.15.4 Thank you for your patience.

more options

Sounds like ublock is having some issues with downloads did you contact them about it?

more options

Turns out there's a bug in firefox version 55 and up where many addons won't install on lInux due to an interaction with some window managers. My window manager, ctwm, is one of them.


Thanks for your help.

more options

Try to download and save the file to your computer (right-click: Save Link As) and install the file locally in the extension manager via the cogwheel button.