Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Cannot get the style editor to behave properly with Sass files

  • 1 Antwort
  • 1 hat dieses Problem
  • 5 Aufrufe
  • Letzte Antwort von Tonnes

more options

Basically, I go into the style editor, source maps are enabled, "show original sources" is checked. I want to edit a sass file and see the changes happen on the live page. I find the Sass file, and save it over the local sass file (.scss extension). I have sass watch working, and the new css is generated with an updated source map after the save. However, when I make changes to the sass file in the editor and save, the changes don't go live. If I reload the page I get an error saying "style sheet could not be loaded" and the sass file I was just working on doesn't show up in the style editor.

I can edit css files and see the changes live without issue.

This problem is consistent on Developer edition 58.0b12 and Firefox 57.0.2.

Am I just doing it wrong?

Basically, I go into the style editor, source maps are enabled, "show original sources" is checked. I want to edit a sass file and see the changes happen on the live page. I find the Sass file, and save it over the local sass file (.scss extension). I have sass watch working, and the new css is generated with an updated source map after the save. However, when I make changes to the sass file in the editor and save, the changes don't go live. If I reload the page I get an error saying "style sheet could not be loaded" and the sass file I was just working on doesn't show up in the style editor. I can edit css files and see the changes live without issue. This problem is consistent on Developer edition 58.0b12 and Firefox 57.0.2. Am I just doing it wrong?

Alle Antworten (1)

more options

I have not tested but as I understand, "Enable Source Maps" should be checked in the DevTools configuration, and "Show original source" should be unchecked in the context menu. Perhaps this article provides more useful info if you haven’t found it already.

If that does not help, can you reproduce this in either an older version such as 56 or earlier, or a Nightly instead? Use a separate profile for those when testing.