Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

fonts displaying as 'A' in a box

  • 3 Antworten
  • 34 haben dieses Problem
  • 642 Aufrufe
  • Letzte Antwort von cor-el

more options

On lots of websites text appear as an 'A' in a box (see screenshot - i've blurred some content due to privacy). I've gone through my preferences and checked 'Allow pages to choose their own fonts, instead of your selections above'. When I uncheck this box using my font selections things display fine however when I check it I get this problem. I'm a web developer so I can't override site fonts, I need them to display as intended. I've checked Chrome and Safari on my machine and they are fine so this problem is isolated to FireFox. I've tried restarting FF in safe mode but it made no difference, I went to the config page and changed network and gfx references back to 'reset' and again it doesn't make a difference.

System details: FF = 56.0 (64 bit) OSX = 10.9.5

Angefügte Screenshots

Geändert am von sanch3z

Alle Antworten (3)

more options

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character.

You can also try to set this pref to 1 on the about:config page in case there is a problem with the security settings. security.sandbox.content.level = 1

more options

You are correct, 'Last resort' is the font detailed in the inspector. I changed the sandbox level to '1' as suggested, restarted FireFox and it has fixed the issue.

I'm slightly nervous about messing around with security settings. Will changing it from '3' to '1' have a negative impact?

Thanks for the help

more options

See the comment here:

#if defined(XP_MACOSX) && defined(MOZ_SANDBOX) && defined(MOZ_CONTENT_SANDBOX)
// This pref is discussed in bug 1083344, the naming is inspired from its
// Windows counterpart, but on Mac it's an integer which means:
// 0 -> "no sandbox" (nightly only)
// 1 -> "preliminary content sandboxing enabled: write access to
//       home directory is prevented"
// 2 -> "preliminary content sandboxing enabled with profile protection:
//       write access to home directory is prevented, read and write access
//       to ~/Library and profile directories are prevented (excluding
//       $PROFILE/{extensions,chrome})"
// 3 -> "no global read/write access, read access permitted to
//       $PROFILE/{extensions,chrome}"
// This setting is read when the content process is started. On Mac the content
// process is killed when all windows are closed, so a change will take effect
// when the 1st window is opened.
pref("security.sandbox.content.level", 3);
#endif